The forum is read-only currently.

wifi connection and local time

since I installed the connection by wifi, kiwi can no longer find the time and does not work correctly no audio and very high latency if I reconnect the wired connection everything is back in order always using the URL of wifi connection.


Wed Aug 26 10:19:42 00:44:00.721 ........ [00] PWD admin config pwd set TRUE, auto-login FALSE
Wed Aug 26 10:20:29 00:44:47.799 ........ TIMEZONE: lat/lon from admin public config: (49.220001, 2.210000)
Wed Aug 26 10:20:29 00:44:48.019 ........ TIMEZONE: timezonedb.com curl error
Wed Aug 26 10:21:29 00:45:48.023 ........ TIMEZONE: lat/lon from admin public config: (49.220001, 2.210000)
Wed Aug 26 10:21:30 00:45:48.249 ........ TIMEZONE: timezonedb.com curl error
«1

Comments

  • Hi, Rene! Maybe wrong time in your system? Try correct clock and use ntp...

    For sync clock with ntp server manualy you can use ntpdate from SSH:
    sudo apt install ntpdate -y
    sudo service ntp stop
    sudo ntpdate 0.fr.pool.ntp.org
    sudo service ntp start


    73! Yuri
  • Hi Yuri,
    Thanks for replay, the utc time is correct by GPS only the local time is missing, if I connect the ethernet wired link everything becomes ok again


    73' Rene
  • edited August 2020
    Rene, when you wrote about wifi connection you mean you added wifi USB dongle to BBG and configure new wifi interface on the debian?
    About screenshot, I seen same result with wire connection when ntp protocol from local network was blocked and BBG could't update time correctly. It's display wrong UTC time and symbol "?" on local time, because curl to timezonedb.com return error. Of course maybe my case only looks like yours...
    73! Yuri
    f6bir
  • Hello, Yes i added wifi USB dongle to BBG and Kiwi run with it (camanserville.no-ip.biz:8074) without wired connection.
    I have 2 kiwi and i have the same problem on both, if I put the wired connection all the local time will be ok (camanserville.no-ip.biz:8073)



    Just with the wifi dongle if I test Time =

    root@kiwisdr:~# timedatectl status
    Local time: Thu 2020-08-27 11:05:27 CEST
    Universal time: Thu 2020-08-27 09:05:27 UTC
    RTC time: Thu 2020-08-27 09:05:27
    Time zone: Europe/Paris (CEST, +0200)
    NTP enabled: yes
    NTP synchronized: yes
    RTC in local TZ: no
    DST active: yes
    Last DST change: DST began at
    Sun 2020-03-29 01:59:59 CET
    Sun 2020-03-29 03:00:00 CEST
    Next DST change: DST ends (the clock jumps one hour backwards) at
    Sun 2020-10-25 02:59:59 CEST
    Sun 2020-10-25 02:00:00 CET
    root@kiwisdr:~#



    73' Rene F6bir
  • Interesting, you can start this curl from SSH manually, for your data it's looks like:
    curl -s --ipv4 "https://api.timezonedb.com/v2.1/get-time-zone?key=HIHUSGTXYI55&format=json&by=position&lat=49.220001&lng=2.210000"
    This request return something when KiwiSDR on the wifi connection or not?
    73! Yuri
    f6bir
  • Thank you Yury for your help, I tested your suggestion, it doesn't answer anything if I'm only on wifi and
    it works if I reconnect the Ethernet cable

    root@kiwisdr:~/Beagle_SDR_GPS# curl -s --ipv4 "https://api.timezonedb.com/v2.1/get-time-zone?key=HIHUSGTXYI55&format=json&by=position&lat=49.220001&lng=2.210000"
    root@kiwisdr:~/Beagle_SDR_GPS#


    root@kiwisdr:~# cdp
    root@kiwisdr:~/Beagle_SDR_GPS# curl -s --ipv4 "https://api.timezonedb.com/v2.1/get-time-zone?key=HIHUSGTXYI55&format=json&by=position&lat=49.220001&lng=2.210000"
    {"status":"OK","message":"","countryCode":"FR","countryName":"France","zoneName":"Europe\/Paris","abbreviation":"CEST","gmtOffset":7200,"dst":"1","zoneStart":1585443600,"zoneEnd":1603587600,"nextAbbreviation":"CET","timestamp":1598607605,"formatted":"2020-08-28 09:40:05"}
    root@kiwisdr:~/Beagle_SDR_GPS#


    Have a nice day
  • I assume your wireless access point/router does not have extra filtering for wireless clients?
    For example does it separate the wireless clients from each other, or wireless from LAN clients?
  • hi, good question but where can I check this, I also noticed that I disappeared from the kiwi map when I was only in wifi this would explain that
    Thank you for your relevance
    73 'F6bir Rene
  • Assuming the device you set port forward on for the Kiwi is also your wireless access point, and has a web interface, I would check for a wireless section.
    Perhaps there are settings like "Security", "Client Isolation" or even "Guest network" that last one is normally more of a problem if the user is trying access services.

    I could be completely wrong on this but I'd like to know those settings are off, and ideally the router is turned off, then ensure the Kiwi is NOT connected by cable and the router turned back on.
    Sometimes if the wireless is blocking traffic, going from Ethernet to Wifi can retain some network setting and give the impression it is working but not fully.
    A cold-boot to wireless only should give us a clearer idea of the condition of WiFi as the Kiwi sees it.

    73 Stu
  • jksjks
    edited August 2020
    The "-s" in "curl -s" (silent mode) is preventing us from seeing any error message if the connection is failing.
    What happens if you do:
    ping 50.116.2.70
    versus
    ping kiwisdr.com

    I'll bet this is a problem with DNS not working with WiFi for some reason (router configuration problem?)
    f6bir
  • Hello and thank you for your suggestions.
    Concerning the box and the router, I have already checked or even modified certain parameters without success.
    I realized the manip proposed by JKS here are the results for the two kiwis and on a Raspi (and all other) connected to the same wifi network without any wired connection at the same place for the three devices. It seems to be a specific problem at BBB
    Admin / console access on the 2 kiwis are rene7890 for a while.
    camanserville.no-ip.biz:8073 or 8074
    and ssh pi@camanserville.no-ip.biz same PW for the Raspi/OpenWebRX

    73 'Rene F6BIR

    root@192.168.1.26's password:
    Last login: Sat Aug 29 07:38:37 2020 from 192.168.1.73
    root@kiwisdr:~# ping kiwisdr.com
    ping: unknown host kiwisdr.com
    root@kiwisdr:~# ping 50.116.2.70
    connect: Network is unreachable
    root@kiwisdr:~#


    root@192.168.1.27's password:
    Last login: Wed Aug 26 11:21:56 2020 from 192.168.1.72
    root@kiwisdr:~# ping kiwisdr.com
    ping: unknown host kiwisdr.com
    root@kiwisdr:~#


    pi@openwebrx:~ $ ping kiwisdr.com
    PING kiwisdr.com (50.116.2.70) 56(84) bytes of data.
    64 bytes from li420-70.members.linode.com (50.116.2.70): icmp_seq=1 ttl=51 time=153 ms
    64 bytes from li420-70.members.linode.com (50.116.2.70): icmp_seq=2 ttl=51 time=159 ms
    64 bytes from li420-70.members.linode.com (50.116.2.70): icmp_seq=3 ttl=51 time=152 ms
    ^C
  • @f6bir
    The default gateway could be missing or wrong defined.
    Can you show the output of "ifconfig" and "route"?
    f6bir
  • Yes see belowing

    For the first one


    root@192.168.1.27's password:
    Last login: Thu Aug 27 05:15:34 2020 from 192.168.1.86
    root@kiwisdr:~# ifconfig
    eth0 Link encap:Ethernet HWaddr 78:04:73:83:2a:c0
    UP BROADCAST MULTICAST DYNAMIC MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:175

    eth0:avahi Link encap:Ethernet HWaddr 78:04:73:83:2a:c0
    inet addr:169.254.7.220 Bcast:169.254.255.255 Mask:255.255.0.0
    UP BROADCAST MULTICAST DYNAMIC MTU:1500 Metric:1
    Interrupt:175

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:99916 errors:0 dropped:0 overruns:0 frame:0
    TX packets:99916 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1
    RX bytes:7679368 (7.3 MiB) TX bytes:7679368 (7.3 MiB)

    wlan0 Link encap:Ethernet HWaddr f4:f2:6d:09:6f:a0
    inet addr:192.168.1.27 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::f6f2:6dff:fe09:6fa0/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST DYNAMIC MTU:1500 Metric:1
    RX packets:11745 errors:0 dropped:1295 overruns:0 frame:0
    TX packets:447 errors:0 dropped:9 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:4407703 (4.2 MiB) TX bytes:50767 (49.5 KiB)

    root@kiwisdr:~# route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    default * 0.0.0.0 U 1002 0 0 eth0
    link-local * 255.255.0.0 U 0 0 0 eth0
    link-local * 255.255.0.0 U 1000 0 0 wlan0
    192.168.1.0 * 255.255.255.0 U 0 0 0 wlan0
    root@kiwisdr:~#

    for the second one:

    root@192.168.1.26's password:
    Last login: Sat Aug 29 07:45:44 2020 from 192.168.1.73
    root@kiwisdr:~# ifconfig
    eth0 Link encap:Ethernet HWaddr 40:bd:32:e9:46:08
    UP BROADCAST MULTICAST DYNAMIC MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:175

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:97491 errors:0 dropped:0 overruns:0 frame:0
    TX packets:97491 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1
    RX bytes:7500908 (7.1 MiB) TX bytes:7500908 (7.1 MiB)

    wlan0 Link encap:Ethernet HWaddr 60:e3:27:17:15:c3
    inet addr:192.168.1.26 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::62e3:27ff:fe17:15c3/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:162197 errors:0 dropped:18345 overruns:0 frame:0
    TX packets:157407 errors:0 dropped:28 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:20635459 (19.6 MiB) TX bytes:137571252 (131.1 MiB)

    root@kiwisdr:~# route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    link-local * 255.255.0.0 U 1000 0 0 wlan0
    192.168.1.0 * 255.255.255.0 U 0 0 0 wlan0
    root@kiwisdr:~#



    And for the Pi on the same wifi network:


    pi@openwebrx:~ $ ifconfig
    eth0: flags=4099 mtu 1500
    ether b8:27:eb:94:fe:c1 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    lo: flags=73 mtu 65536
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10
    loop txqueuelen 1000 (Local Loopback)
    RX packets 24213 bytes 1192572564 (1.1 GiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 24213 bytes 1192572564 (1.1 GiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    wlan0: flags=4163 mtu 1500
    inet 192.168.1.41 netmask 255.255.255.0 broadcast 192.168.1.255
    inet6 fe80::ec90:d14f:956c:e582 prefixlen 64 scopeid 0x20
    ether b8:27:eb:c1:ab:94 txqueuelen 1000 (Ethernet)
    RX packets 5886 bytes 652420 (637.1 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 5073 bytes 2884241 (2.7 MiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    pi@openwebrx:~ $ route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    default box 0.0.0.0 UG 303 0 0 wlan0
    192.168.1.0 0.0.0.0 255.255.255.0 U 303 0 0 wlan0
    pi@openwebrx:~ $
  • edited August 2020
    The default gateway of your first kiwi is pointing to the disconnected eth0.
    The second kiwi doesn't have a default gateway at all.
    So the systems don't know how to reach the internet.

    There seems to be something going wrong when setting up the ip configuration of the wlan0 interfaces. I don't remember how it is done in the kiwis "stock" configuration, since I modified mine quite a while back.
    Is it via /etc/network/interfaces ? I don't remember.
  • I ended up using connmanctl to set the configuration of the interfaces, as I was trying to get wireless working on the Beaglebone Black. I now have the pair of Kiwis almost identical in setup.

    Amusingly one of the Kiwis decided that the wireless card would work again, but would only talk to the network on the ethernet connection. This meant that the Kiwi thought the ethernet was not the LAN, and required the use of passwords for local admin access etc. Went in with connmanctl and disabled wifi, problem resolved.
    f6bir
  • I modified the network config, (wpa_supplicant.conf and interfaces) now the two kiwis are identical, the problem is not solved for all that tomorrow I will use connman to redo a new config
    Thank you for your help
  • The default gateway is still missing.
    If the configuration is done using /etc/network/interfaces, then you can add "gateway 192.168.1.1" (assuming that is the ip-address of your router) to the wlan0 section.
    Or for a temporary solution you could do "route add default gw 192.168.1.1 wlan0" in the terminal.
  • hello there was an error in the word "gateway", do you think this is correct now, but still no positive result
    thank you

  • Hi, Rene. Wrong Iface for default route, - for wifi your need use wlan0 interface not eth0 (it's wired ethernet).
    73! Yuri
  • Hi Yuri I had the tow interfaces connected to modify the set up I send it just to verify the interfaces files data
    Tu 73 Rene
  • OK, for working with any Internet services (DNS, NTP, kiwisdr.com and other) system need default route via correct interface, it's can be add via DHCP options or manually. Of course if interface down - any routes related with this interface gone down too.
    Hope you can configure routes for wlan0 interface.
    73! Yuri
  • Below the both kiwi only wifi wlan0 connected but interner access always fault
    TU

  • Rene, try ping 8.8.8.8 may be DNS not configured too?
  • Yes Yuri it does something and also with ping 50.116.2.70 but not with kiwisdr.com (may be normal on BBB)
    All seems ok now the UTC time is correct I am testing WSPR for a while to check if UTC time is updated normaly. Local time is always faulty indicated as" ?"
    See camanserville.no-ip.biz: 8073 or 8074 same default on both kiwi and tell me if everything looks correct to you
    Thank you for your help which allowed me to find my mistake

    73'

    root@192.168.1.26's password:
    Last login: Sun Aug 30 10:43:13 2020 from 192.168.1.73
    root@kiwisdr:~# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    64 bytes from 8.8.8.8: icmp_seq=1 ttl=117 time=12.7 ms
    64 bytes from 8.8.8.8: icmp_seq=2 ttl=117 time=14.1 ms
    64 bytes from 8.8.8.8: icmp_seq=3 ttl=117 time=12.6 ms
    64 bytes from 8.8.8.8: icmp_seq=4 ttl=117 time=11.6 ms
    64 bytes from 8.8.8.8: icmp_seq=5 ttl=117 time=13.0 ms
    64 bytes from 8.8.8.8: icmp_seq=6 ttl=117 time=12.5 ms
    64 bytes from 8.8.8.8: icmp_seq=7 ttl=117 time=13.8 ms
    64 bytes from 8.8.8.8: icmp_seq=8 ttl=117 time=16.1 ms
    ^X64 bytes from 8.8.8.8: icmp_seq=9 ttl=117 time=12.6 ms
    64 bytes from 8.8.8.8: icmp_seq=10 ttl=117 time=15.1 ms
    ^C
    --- 8.8.8.8 ping statistics ---
    10 packets transmitted, 10 received, 0% packet loss, time 9013ms
    rtt min/avg/max/mdev = 11.645/13.467/16.145/1.295 ms
    root@kiwisdr:~#
  • edited August 2020
    Rene, for test try edit with nano /etc/resolv.conf file and add string:
    nameserver 8.8.8.8.
    After that you can resolve DNS names from BBB, but it's work temporary, for first reboot...
    I don't know how you configure IP on wifi interface, but if you use connmanctl you need to use something like:
    connmanctl config <<your_wifi_service>> --nameservers 8.8.8.8 8.8.4.4
    73! Yuri
  • I think since he is using static IP adress configuration, /etc/resolv.conf will be permanent. So that should work.
  • Hello all, not resolved yet message in log:

    Mon Aug 31 07:59:57 21:50:45.537 0... [01] PWD admin config pwd set TRUE, auto-login FALSE
    Mon Aug 31 08:00:28 21:51:17.020 0... TIMEZONE: lat/lon from admin public config: (49.224380, 2.210537)
    Mon Aug 31 08:00:28 21:51:17.236 0... TIMEZONE: timezonedb.com curl error
    Mon Aug 31 08:01:28 21:52:17.239 0... TIMEZONE: lat/lon from admin public config: (49.224380, 2.210537)
    Mon Aug 31 08:01:29 21:52:17.468 0... TIMEZONE: timezonedb.com curl error
    Mon Aug 31 08:02:29 21:53:17.471 0... TIMEZONE: lat/lon from admin public config: (49.224380, 2.210537)
    Mon Aug 31 08:02:29 21:53:17.652 0... TIMEZONE: timezonedb.com curl error
    Mon Aug 31 08:03:29 21:54:17.656 0... TIMEZONE: lat/lon from admin public config: (49.224380, 2.210537)
    Mon Aug 31 08:03:29 21:54:17.871 0... TIMEZONE: timezonedb.com curl error

    UTC time seems ok, wspr running well since 12hours with wsprnet reporting (f6bir/m)

    connmanctl enable wifi return "time out" I configured Wifi manual using nano /etc/network/interfaces

    I added "nameserver 8.8.8.8" in resolv.conf file.

    I will try again soon

    have a nice week
    73' Rene
  • When I played with connmanctl and general Wireless networking on the AI I found it ran fine for a while then would seem to "do it's own thing".
    I think the manual system conflicts with connman and visa-versa.

    Perhaps see if you can exclude connman on that interface?
    https://askubuntu.com/questions/798346/does-anybody-know-how-to-disable-connman
  • Ury, good news this works with adding "nameserver 8.8.8.8 in resolv.conf, how to make it permanent without using connman."
    Thank you for your patience
  • what follows: "eureka "

    Mon Aug 31 12:03:42 03:47:24.742 0... TIMEZONE: timezonedb.com curl error
    Mon Aug 31 12:04:42 03:48:24.750 0... TIMEZONE: lat/lon from admin public config: (49.224380, 2.210537)
    Mon Aug 31 12:04:43 03:48:24.931 0... TIMEZONE: timezonedb.com curl error
    Mon Aug 31 12:05:43 03:49:24.934 0... TIMEZONE: lat/lon from admin public config: (49.224380, 2.210537)
    Mon Aug 31 12:05:44 03:49:26.126 0... TIMEZONE: from timezonedb.com for (49.224380, 2.210537): utc_offset=7200/2.0 dst_offset=0/0.0
    Mon Aug 31 12:05:44 03:49:26.129 0... TIMEZONE: "CEST", "Europe\/Paris"
Sign In or Register to comment.