admin "re-clone sources" often fails [fixed?]

edited April 24 in Problems and Issues
This discussion was created from comments split from: Clone error code ? [improvements in v1.626].


  • drbdrb
    edited April 24

    I have a Kiwi running Debian Jessie that was stuck at v1.664

    I tried "re-clone sorces" from the Admin page and it repeatedly failed:

    There's no further indication of the reason for failure, but my supposition is that the Kiwi responded so slowly to the git server that the server timed out.

    The solution that seems to have worked was to clone the git repository on to my laptop, then rsync it to the Kiwi.

    Cheers -- Ross

  • When the Kiwi server does a software update is takes steps to make sure the update build has the majority of the Beagle's CPU cycles: It kicks all the active connections and throttles all the realtime activities of the server until the build completes.

    But these steps are not taken when the "re-clone sources" button is used. They probably should be..

  • jksjks
    edited April 16

    I split this discuss off from the previous thread because that thread was about the clone function on the admin config tab clone function (used for cloning Kiwi configuration data). Not the admin console tab "re-clone sources" button.

  • @drb This problem may be solved in the current releases. I'd be interested to know if it works for you now. I had a customer with a trashed clone I was trying to rebuild. And just using the gclone alias on an ssh connection was timing out.

    After a lot of head scratching I figured out that his Internet connection was on the "slow" side. Maybe 180 kB/sec. And this was slow enough to cause the curl of a git clone to fail. After a lot of searching around I found out about the GIT_HTTP_LOW_SPEED_LIMIT and GIT_HTTP_LOW_SPEED_TIME environment variables. These are now set to more reasonable values in the Kiwi /root/.bashrc file. It seemed to cure the problem.

Sign In or Register to comment.