FPGA not responding: 0xffff ( Kiwi 1 )

Hi John,

Sorry for annoying you again. After kiwi2 installation ok, I moved kiwi1 to my old house and the following problem occurred today while setup:

I could see kiwi1 from wifi repeater, however, could not find it via http://my.kiwisdr.com or

This reminded me that a similar situation happened the year before last, so I followed your suggestion and accessed the kiwi log from the background as root.

First with the following commands, respectively, I saw


ps ax | gr kiwid


FPGA not responding: 0xffff It seems like something wrong with the hardware .... ?!

I didn’t give up and tried to apply the soul-returning command for kiwi ....


cp unix_env/kiwi.config/dist.kiwi.json ../kiwi.config/kiwi.json

This time the result was in vain, and have to ask for your advice again. 😅


  • Try a full power cycling. Login to Debian and use the "halt" command to shutdown. Pull the power connection. Wait a few moments. Plug in again.

    Check that this file exists with the command:

    la /usr/local/bin/kiwid.aout

    Should say something like:

    -rwxr-xr-x 1 root root 2.9K Feb 23 09:46 /usr/local/bin/kiwid.aout

    If that doesn't work is there some way I could connect to the Kiwi?

    You'd have to open the ssh port (22) on your router, mapping your public IP address to the local address of the Kiwi ( Also, your ISP has to allow incoming connections, which it may not. In which case this method won't work (can you connect to your Kiwi from the Internet normally without using a reverse proxy?)

  • Is there any more info about this?

  • Dear John,

    Sorry for being late.

    I drove back to my old house last night and took it back to Hsinchu (because it's sure that port 8073 here was already a DMZ) for kiwi1 test.

    As shown below, the file kiwid.aout could be seen via putty w/o problem.

    However, I could not connect to the kiwi1 UI (& admin page) via Firefox+local IP/port.

    and nothing can be found by http://my.kiwisdr.com either.

    If no further suggestions for me to try (or linux commands are very complicated), I will try next to open port22, make sure it can be connected from the public network and notify you at once.

    For kiw1 I didn't use a reverse proxy, rather than using DDns because my floating IP. It seems that putty can also use domain name to connect (I'm not definitely sure).

    When I received kiwi2, kiwi1 was still in good working condition. I really don’t know what operations I did or plugging/unplugging that caused such a problem. Very upset and sorry for everyone 😔.



  • (Cont'd)

    After replacing a new BB/G and flashing v1.486 image, the check results are as follows. This could almost confirm this issue occurred on the kiwi side. 😔 Try finding a paid repair nearby.

  • Can you do some simple voltage and clock frequency checks? The troubleshooting guide has more information: http://www.kiwisdr.com/ks/troubleshooting.pdf

    Do you live in a low humidity environment where static discharge might have been a problem when you moved it? I find it so strange there would be a failure like this after just moving it..

  • Hi John,

    Thank you so much.

    No problem I'll find someone's electrical support and follow your guide first.

    Since I started a business trip today and will be back home after the 25th, so the update will be until about the end of March.



  • Hi Jimmy,

    It seems I have the same problem after I moved the card to upgrade Debian 11 versus.

    Did you resolve it

    73 Rene F6BIR

  • @JIMMY0311 Could you try re-flashing using the latest image file and see if it cures your "FPGA not responding" problem just as @f6bir2 recently found with his?

    File KiwiSDR_v1.665_BBG_BBB_Debian_11.9.img.xz as mentioned in instructions here: http://kiwisdr.com/quickstart/index.html#id-net-reflash

    If this turns out to be a software problem somehow I will reimburse you the cost of the new BBG you just bought!

  • Hi John,

    After taking out kiwi1 earlier and re-flashed the v1.665 image, things did not improve. Since the new BBG and another 2nd-hand BBB didn't work either, I thought this was a hardware issue with the kiwi board side.

    Fortunately, kiwi2 is still working normally ..

    best regards,


  • Okay. I was just amazed that @f6bir2 seemed to solve an identical problem just by re-flashing from an older image (exact version still unknown) to v1.665. I still don't understand how that could possibly have been true.

  • edited April 28


    1. no successful recovery with the those commands (./up) offered by @f6bir2

    2 . re-flashing kiwi1 w/ v1.486 image was of no use either.

    Next-to-do : debug step by step w/ electric-meter & troubleshooting.pdf

  • Is there a quick way to test SPI connectivity?

    It's been a while but I seem to remember* a kernal upgrade broke the overlay mapping, so no SPI = no FPGA response.

    *(when I was doing daft PI stuff)

  • It's been years since I did this. But there's some code commented-out in the FPGA programming routine that I think does a loopback test of the SPI interface. You have to remove the Kiwi board and jumper the MOSI and MISO signals together of course.

    If you look at the Makefile and a few other places you'll note that the Beagle guys changed the way device mapping worked in every single major Debian release. Sometimes within a release. A real shit show.

    One of the reasons we don't have a proper mobile interface or other major features is that I spent so much damn time trying to keep up with that stuff. Just went through it again with Debian 12 and decided I couldn't risk it. So went with Debian 11 for the Kiwi-2.

Sign In or Register to comment.