Plenty of WSPR decodes, no uploads, "Upload Spots" is selected

My Kiwi hasn't uploaded any spots since a few on 13th April. Reading other threads I can see that sometimes the system clock on the Kiwi can be off, but I've checked that using the "date" command on the console and it is OK. The date stamps in the log look correct too.


  • On the admin page, extensions tab, WSPR sub-tab, turn on the "Log spot debug info" option. A message in the log may give you a clue why is not uploading your spots.

  • It was already selected, hence the debug messages indicating successful decodes in the above screenshots. There are just no upload-related messages.

  • Eh, I forgot. Uploads are done differently for the web-based WSPR decoder versus the autorun version. And the debug option only applies to autorun uploads.

    But I just tried it with autorun and noticed that is not currently returning spot upload confirmation info. So that's not helpful.

    But both autorun and web-based spots are uploading from my test Kiwi when I check the database directly on So I'm not sure why you'd be having a problem.

  • On I can only see a small batch of uploads from the 13th April. I will try the autorun version and see if that is any different.

    Otherwise I can force a rebuild to see if that fixes it.

  • edited April 23

    I have found the problem. I didn't realise that the spot was uploaded from the browser. A quick look at the console shows the problem. I am using a reverse proxy with SSL. The site is accessed with http rather than https.

    Would it be possible to change any outside API links to https where https is supported?

  • A bit of a long story. But the WSPR was the first one developed way back in 2016. And at the time I didn't know how to upload spots from C code using curl. So instead I used the iframe hack to do a cross-domain GET. Of course years later when autorun was implemented it had to be done on the C-side using curl. Perhaps I should now change the WSPR extension to use this upload mechanism.

  • edited April 24

    I just tested the WSPR extension (non-autorun) on my Kiwi which is still running v1.601 and it is uploading to the WSPR database fine.

    Just thought I would mention it if it helps with any debugging.

    Yes...v1.601...After a year of failing to find 8 or 16GB MicroSDHC cards locally (and 32GB MicroSDXC cards giving errors on the Beagle...the smallest that can be found around here), I finally ordered several 16GB cards online about a week ago. So, it'll be updated as soon as I make a backup of v1.601, which is long overdue. I didn't want to overwrite the original SD card that came with the Kiwi 1.

    WSPR on 20m over the past 30 minutes.

  • The uploading always worked for me, including recently. It was just the confirmation report that used to send with each upload that seems to be missing.

  • edited April 26

    I see. I haven't really checked for those reports in the log before. Yeah, not seeing any upload messages in the log here.

    You can tell when the decodes are being uploaded when "" flashes in the lower left hand corner of the window (at least on Firefox). I'll usually wait for it to stop before closing the window or extension.

  • Yes. And those flashing messages should stop in the latest releases since I now do the spot uploading on the server side instead of on the client (browser) side.

Sign In or Register to comment.