The forum is read-only currently.

KiwiSDR over Internet settings

I am setting up my KiwiSDR. I'm not network smart, but I believe I am trying to use dynamic IP for my local network (DHCP), Auto add NAT rule and noip.com to translate from w7pua.ddns.net:8073. "Check Port Open" with kiwisdr.com shows Yes Yes. But when I try to open a receiver I get a time out and no connection. To help, here are the three relevant screens:
http://www.janbob.com/electron/KiwiSDR/noip.gif
http://www.janbob.com/electron/KiwiSDR/connect.gif
http://www.janbob.com/electron/KiwiSDR/network.gif
What setting did I mess up? After I get this to work, I will post the proper settings to help someone else with this. Thanks, Bob

Comments

  • It works from outside, I just tried it.

    From inside the network it may not work from http://w7pua.ddns.net:8073 as the router is stopping you looping back into the public interface from the private.

    Fair bit of noise on the antenna at the moment but I could connect.
  • jksjks
    edited December 2019
    Yes, unless your router supports a somewhat obscure thing called "hair-pinning" you can't use the URL w7pua.ddns.net:8073 on your local network. You have to use something that resolves to the Kiwi's local ip address like my.kiwisdr.com or 192.168.0.21:8073 or maybe kiwisdr.local:8073 (the latter doesn't always work).

    Also, in your DUC config take the ":8073" out of the host field. Looks like it doesn't hurt anything but it makes a few other things look weird (e.g. first "check open port" URL). I should change my code to automatically filter that out like I do in a few other places.
  • Hey, thanks!! That is good news. I will try it on my phone, away from the house on Verizon 4G. Yes, right now the antenna is inside the room and about 5-m long. My local connection shows the same noise with a few AM stations like 550kHz, but that is about it. With the internet working, I can move on to making the RF stuff usable.
  • And it works fine on my phone as soon as I turn off Wifi, as expected by the comments. I will remove the port number on the DUC config and do a new screen shot. Thanks so much folks---this is looking good!
Sign In or Register to comment.