v1.507 - New DX Labels editing feature [bug fixes in v1.513,514 see CHANGE_LOG file]



  • See below. Telling you to "flush your browser cache" is so 1998, but I don't know what else to say, lol

  • OK this time around..... thanks

  • For the next version I'm going to make CSV import more tolerant of the format it will accept. Already I have it accepting commas in addition to semicolons as the field delimiter.

  • @pe1rdp If you update to v1.513 I think it should accept your .csv file without problems now.

  • Using excel 2021.

  • the non-display of scheduled labels at times of the day means going in and out of the admin page for maintenance. How about a right-click in user mode to see those not currently displayed?

  • There is a "filter by time/day-of-week" checkbox on the DX label edit panel (user page) that, if unchecked, will show labels not currently displayed in a lighter color with a dashed outline. No need to bring up the admin page.

  • thanks for quick response!

  • That checkbox idea is stolen from the EiBi database. Without filtering the EiBi labels are a huge mess (unless you are sufficiently zoomed in) because there are so many of them. Same reason there had to be category filtering as well.

  • @jks Sorry for late reply, I wasn't near the PC today.

    Running now v1.513 and indeed! I can import the .csv

    Many thanks for great service and software. Now I have all 10m cw beacons available as DX labels. Let the F2 season start hi.

    73 Arno

  • Hi John,

    Sorry, but the CSV import is not working for me, as I keep on getting "File upload: Communication error" whenver I try to upload a file to a remote KiWi.

    I initially thought that I had modified something in the file that the KiWi objected to. But I've just tried downloading a DX CSV file and then immediately uploading it again and I get the same error occurring.

    Could it be due to my large file size ?



  • No, you get a different, specific error message when the file is over 2 MB in length.

    "Comm error" is catch-all when something unexpected about the upload fails.

    Easiest thing to do is email me a copy of your .csv file.

  • Fixed in v1.514. This was because code inherited from the photo upload feature allowed uploading from the local network only. I took that restriction out.

    But uploading your .csv file uncovered a bug with handling UTF-8 .csv files. This has also been fixed. Check carefully that your UTF-8 is okay in the file you're uploading from so it stays good in any subsequent downloads.

  • Hi John,

    Thanks for your help, however I've still got some problems, which may or may not be associated with handling of some 'continental' alphabet characters which seem to be wrongly interpreted when imported into the Excel spreadsheet (they appear as %xx text, xx being alpha numeric strings)

    I've stripped these out of one file, but I'm still getting errors with messages about missing end times, even though that column has been correctly designated, but doesn't contain any numbers.

    I'll spend a bit more time on this today, to see if I can figure out what's really going on, and then I'll hopefully be able to send you a more detailed email.



Sign In or Register to comment.