No IP-address is given [also: problems using the Debian 8 (v1.390) reflash img.xz file]


i have a problem with a new KIWI

if i cvonnect the KIWI at an Router, the become no IP-Adress i see ist Wired, but no IP on the Router-Diagnostic.

The LED-Procedure is also no Answer of a Static or Dynamic IP

the BeagleBone LEDS make followiing Sequence ba Startup:

1) each LED gos on cascadic, if all 4 are on the go all of

2) LEDs 1 and 4 flashes any Time

3) LED 1 ( at the left Side) has a perodic double Flash non ends

i have tries to restore with the SD-Card, but no bether situation after

what i do wrong?



  • an update is likely in process and can takes 30 minutes +

  • When you restore using the sd card does the LED pattern match what is described in the documentation ?

    • Back-and-forth pattern for about 5 minutes.
    • All LEDs on for about 30 second.
    • All LEDs off andBeagle powers down.

    After that, and removing sd card, power up again with the Ethernet connection to the Internet attached. Leave it sit for 1 hour. Then try and determine the ip address again using and/or the ip address pattern in the LEDs.

  • No absolutli not.

    the 4 LEDs go's on one Time at startup with Card

    then the LED 1 and 4 flashes 3-4 times any.

    and after gos LED 1 in front in a double blink, any second


  • edited January 2023

    Hi @ThomasGull, try flashing the latest Debian 10 to microSD card from then remove  KiwiSDR cape, insert microSD card into BBG, press and hold "USER" button and power up the board via a micro USB cable.

    When the LED's start cyclical flashing, release the button and wait until flashing complet and board goes shutdown (all LEDs off).

    Unplug the power cord and remove the microSD card, then attach KiwiSDR cape, plugin Ethernet cable and power on.

    It will take you about 40 minutes to fully update the software to the current version.

  • edited January 2023

    He can do this procedure with Debian 8 image or original card too, but the original microSD card might be damage, I think it's a good idea to re-write the image from the official site to another microSD. :)

  • Thank thats posible, i will check to take a new card, ot make it one?

  • edited February 2023

    How can i make a card?

    Download the software from Github but then create it as a bootable SD with which program and how I'm a little unsure how to do it.

  • You don't need to involve Github. Please follow the instructions here:

  • I have been unable to install a new Debina 8 image on either of two BBG.

    Soon after power all four LEDs flash on after which the LED nearest the corner repeatedly brightly double flashes, which the LED next to it is constantly dimly lit.

    I have tried holding down the reset button while powering up the BBG, but only the power L:ED is lit until I release the reset button. Both BBG behave the same.

    Clearly the CPU is running, but I don't know what it wants

  • @rrobinet I know this sounds like level-one tech support, but try another sd card. Those things are so unreliable. I always buy them a dozen at a time from Mouser/DigiKey because I know 15% of them will be bad. Even a decent brand like Samsung/Panasonic.

    The other thing to get is a BeagleBone-to-USB/A serial cable** (see It's really the only way to definitively see what's going on at boot time. Because of connector clearance a Kiwi board won't fit when the serial connection is in place. But that's generally not an issue when you're just wanting to re-flash.

    ** It's essential that you get the 3.3V version of the serial cable and not 5V. Both versions exist.

  • edited March 2023

    Failure to load was solved by using a 4 GB no-name microSD rather than any of the 16-32 GB Samsung EVOs. I suspect the BBG can't read large microSDs.

    Now I'm fighting to upgrade the V1.390 SW on microSD to a current version, since I see a compilation error "Missing glib.h" when I run: cdp; up

    I installed the Debian 8 image. Perhaps I should start with your Debian 10 image?

  • Glib is needed by the HFDL extension (first released in v1.472). It was quite a lot of trouble getting the Kiwi build process to pull in all the libraries needed by the dumphfdl code. It really should work updating from v1.390 since it obviously works updating from v1.2 (factory image).

    What output do you get from the pkls glib command? This is from a BBG running Debian 8.5

    root@beta:~/Beagle_SDR_GPS# pkls glib

    installed pkgs:

    ii libglib2.0-0:armhf       2.42.1-1+deb8u3            armhf    GLib library of C routines

    ii libglib2.0-bin         2.42.1-1+deb8u3            armhf    Programs for the GLib library

    ii libglib2.0-data        2.42.1-1               all     Common files for GLib library

    ii libglib2.0-dev         2.42.1-1+deb8u3            armhf    Development files for the GLib library

    If you don't see this then try reinstalling:

    apt-get -y --force-yes install libglib2.0-dev

  • edited March 2023

    I successfully installed your Debian 10 image and it upgraded to V 1.588 without problems. So I would recommend that you amend the installation instructions to remove the Debian 8 build from the Quickstart document

    My only remaining problem is that I can't ssh to this Kiwi. I have entered a password from the Admin->Security page, and when that password was rejected I tried setting user "root"'s password from the Admin->Console window. I learned nothing about why my ssh login attempts failed from auth.log:

    What am I missing? Is the sshd in this image configured to reject all root logins?

  • jksjks
    edited March 2023

    I haven't tried restoring from the Debian 8 sd card image in quite a while. So I'll try that and see if I can replicate the problem.

    Starting with Debian 9 (I think) root logins are disabled by default. This is not a Kiwi thing but a Debian and/or Beagle distro decision. I describe here what I do to enable root logins from specifically credentialed hosts:

  • Following your QuickStart microSD installation instructions worked perfectly for me once I found the one 4GB BBG-compatible microSD.

    Enabling remote root access was a little challenge, since the vi editor seems incompatible with the Admin->Console page and the default nano color scheme made it impossible to read the characters in the sshd_config file. I ended up using sed to modify sshd_config and after restarting the ssh service I can ssh to the Kiwi. So this task is completed successfully .

    Hopefully this thread will be useful to others.

  • jksjks
    edited March 2023

    The 2-d (X/Y addressable, "curses-compatible", ANSI escape sequence support -- whatever you want to call it) addition to the Kiwi admin console tab is relatively new. As such I don't have a lot of experience with the default colors used by the various Linux commands when they detect ANSI support is available (environment variable TERM=xterm-256color etc).

    It was a challenge to set the shade of background grey to get reasonable contrast for most of the ANSI colors (use the aliases ansi, ansi2 and ansi3 to see). I was mostly wanting ls -la , top -c and ht (htop) to look good.

    I never use vi myself. It's very possible it uses ANSI sequences that still have bugs. In fact I'd bet on it. I debugged using nano and it seems to work okay. I always use ed as a last resort (something I learned almost 50 years ago now I'm sorry to say, lol). Do pki ed to install if not found.

    With nano, what was difficult to read? When I tried nano /etc/ssh/sshd_config the "cyan on grey" for comment lines was not great, but not terrible.

  • The console implementation is excellent, but 'nano sshd_config' looks like this:

  • jksjks
    edited March 2023

    Yeah, that's awful. I don't know why I thought it was "not terrible".

    I've optimized the color palette for the next release.

  • jksjks
    edited March 2023

    I think you're right Rob. We're going to have to (finally) abandon Debian 8 on the Kiwi. For new re-flashes at least. The glib error is a side-effect of more D8 (Jessie) repos falling into disrepair. And as a result apt-get install is failing for a number of needed libraries.

    I can confirm that 32 GB sd cards are not bootable by the BBB/G. 4 and 8 GB cards seem to work fine. I didn't have any 16 GB.

    I need to look at this some more, but I noticed that all my sd cards failed to write from a single Kiwi running D8.5 The dmesg command showed lots of read/write errors. But at least one of those cards worked the first time from a D10.12 Kiwi. No errors at all. So that's very strange.

  • jksjks
    edited March 2023

    I think I've updated all the documentation now to deal with this situation.

    Remember that you don't need to do anything if you're running Debian 8 and a recent version of the Kiwi software. Although you certainly can do an upgrade to Debian 10 if you'd like.

    It's only when you try and re-flash from the older Debian 8 images that Kiwi software updates will fail (e.g. the v1.2 factory image on the supplied sd card or the v1.390 image that was previously linked in the documentation but has now been removed).

  • About 32 GB sd cards: I've been able to boot from them using a BBG. The key seems to be holding down the boot button (switch) before power up and releasing it a few moments after the 4 LEDs light up.

    But this seems to only be necessary until the first time Debian 10 has booted off the Beagle internal eMMC (i.e. not off an sd card). My guess is that D10 updates uboot on the eMMC. And when you don't use the boot button, and uboot from the eMMC is the first thing to run, the updated version is now able to detect and boot from 32+ GB cards if they happen to be present. But that's just a guess.

    I was able to use the admin page, backup tab function under D10 and have a 32 GB card successfully re-flash the BBG.

Sign In or Register to comment.