The KiwiSDR 2 online store is open for orders! Please visit

Connecting Kiwi via WiFi



  • Thanks, jks, very much appreciated.
  • jksjks
    edited September 2019
    But did it work for you? I have no way of testing it with USB WiFi here.
  • edited September 2019
    Sep 12 09:12:15 kiwi1 kiwid[1310]: 00:00:33.041 ........          DDNS: IF IPv4 0xc0a80153 /24 0xffffff00 wlx503eaa2ded33
    Sep 12 09:12:15 kiwi1 kiwid[1310]: 00:00:33.041 ........          getifaddrs: IF lo fam=10 flags=0x10049 UP RUNNING
    Sep 12 09:12:15 kiwi1 kiwid[1310]: 00:00:33.041 ........          getifaddrs: IF wlx503eaa2ded33 fam=10 flags=0x11043 UP RUNNING
    Sep 12 09:12:15 kiwi1 kiwid[1310]: 00:00:33.041 ........          getifaddrs: CHECK wlx503eaa2ded33 fam=10
    Sep 12 09:12:15 kiwi1 kiwid[1310]: 00:00:33.041 ........          DDNS: IF IPv6 LINK-LOCAL /64 wlx503eaa2ded33
    Sep 12 09:12:15 kiwi1 kiwid[1310]: 00:00:33.042 ........          DDNS: private IPv4 <> 0xc0a80153 /24 0xffffff00 wlx503eaa2ded33
    Sep 12 09:12:15 kiwi1 kiwid[1310]: 00:00:33.042 ........          DDNS: private IPv6 LINK-LOCAL  /64 ff:ff:ff:ff:ff:ff:ff:ff:00:00:00:00:00:00:00:00: wlx503eaa2ded33
    Admin access does also work.
  • Okay, great.

    There are still a few things to be fixed to support more general interface names: DDNS DUC client, DHCP/static IP config from admin page (if this is even possible)
  • edited September 2019
    I think for the BBG it isn't necessary. If someone goes through the pain of finding a compatible USB dongle and kernel and driver and encryption, he might as well configure the IP address.
    If BB-AI compatibility is considered, it would of course make sense, for that specific hardware. That would be very nice.
  • edited February 2020

    As a real linux BEGINNER, I'm delighted to say that I used this thread and another one on here to get my new KIWISDR up and running on an ancient usb wireless dongle. Mine has the Realtek chipset RTL 8188SU but the kiwi somehow used the rtl8712u driver itself - I mean that I didn't tell it to but it recognised it itself.

    The other post I referred to by Matti65, is in the thread here: It gave a nice summary of jobs to do before the wifi will work. These are the commands:

    ssh into the kiwi and do these jobs:

    sudo apt-get install usbutils
    sudo apt-get install firmware-realtek
    sudo apt-get install iw
    sudo apt-get install wireless-tools
    sudo apt-get install wpasupplicant
    sudo apt-get install wavemon

    Once done, I just had to edit the network interfaces config file with the command:

    sudo nano /etc/network/interfaces

    I added the following lines to what was already there in interfaces, as advised in the referenced thread by Matti65, but I changed the "wlan1" that Matti advised, to "wlan0". Here are the lines I added:

    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid "SSID of MY router"
    wpa-psk "My router password"

    The quotation marks shown in the two lines above are not used. Just enter the commands, wpa-ssid, and wpa-psk, with your own network's ssid and password, minus the quotes.

    The wlan0 reference caught me out for a minute, because the instruction I first had referred to wlan1 which is what I first tried and that didn't work because my system had assigned wlan0 to the dongle. I edited that and it came right up after a reboot.

    WELL pleased with this because my situation required that I use an old lynksys router installed with dd-wrt, set up in wireless bridge mode to connect the kiwi to the adsl/wifi router which is in another part of the house, and I thought the proximity of a router and dubious wall wart power supply next to the kiwi could introduce spurious noise, especially the wall wart, which, if it existed, I have now got rid of by using the usb dongle. Every cheap switching wall wart you can put in a drawer away from the electricity socket, has got to make less noise in your antenna.

    Thanks to the people who trod this path before me and left a readable trail to the solution. :smile:
  • After a month of faultless running, the wifi dongle has stopped working when the beagle and kiwi sdr were power cycled by the mains going off momentarily and coming back on again. Happens here in bad weather sometimes.

    Was there anything in the latest update v1.383 which I think was distributed a few days ago. I think the beagle might have updated after the power cut.

    I think the beagle and kiwi had not been rebooted for a few days after the new software became available so it might be that or it might be something to do with the power interruption.

    The interfaces file in /etc/network/interfaces has the lines as before:

    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid "SSID of MY router"
    wpa-psk "My router password"

    with the correct ssid and password. It doesn't get as far as that though, because the green light on the dongle which flashes doesn't light up now, though it used to do so.

    when on a wired connection, during ssh connection, if I type 'ifup wlan0' , the following message is returned:

    wpa_supplicant: sbin/wpa_supplicant daemon failed to start
    run parts: /etc/network if-pre-up.d/wpasupplicant exited with return code 1 Failed to bring up wlan0.

    I have put the dongle in another linux computer and after a few moments, it starts up and works with the green light flashing on the dongle. There is no light on the dongle now when it is in the beagle's usb port.

    I have no idea where to go next and have had to revert to plugging the beagle into an old dd-wrt router set up as a wireless bridge. It works, but I think it introduces noise onto the kiwi.

    Thanks for any insights anyone can shed on this. I know the barest minimum about linux.

  • edited March 2020
    Try wlan1 ....or even 2 !

    All the references to wlan0 will have to be changed.

    There are system files somewhere in /etc/udevs/rules.d I seem to remember that adds the wlan(x) interfaces as they are plugged in, so you could see if another (wlan1 or wlan2) has been added to the residual wlan0...that might be a clue

    During the extensive work I did with wireless dongles on the Kiwisdr I always had to use at least wlan1 and sometimes wlan2, don't believe I ever could use wlan0 - though others have reported that they do

    It just might be that the "power anomalies" you mentioned have caused the kiwi to "think" that another/different wireless dongle has been inserted....each time a different wifi dongle is inserted a new file with a new wlan(x) is created in /etc/udevs/rules.d

    Failing that, start from scratch and remove then re-install all the wireless packages following my original posts some months ago.

    You don't need wavemon unless you actively use it as a wifi network is an excellent package to see how your wireless network/dongle system is performing
  • Thanks for the post.

    I edited the interfaces file as suggested trying wlan1 and wlan2. It had no effect when I tried to call the interface up with the command ifup wlanx where the 'x' is the number of the interface being tried.

    I also looked where you said for a file referencing interfaces in rules.d and there wasn't one.

    Then I removed all the files that were installed earlier according to your guide and reinstalled them. To remove, I used the command sudo apt-get remove and afterwards to reinstall I used sudo apt-get install xxxxx where the x string represents the file names .

    It still drops out of the ifup wlanx process with the earlier mentioned error message.

    I looked round for .conf files or anything that might refer to the wireless interfaces and could find nothing that mentioned them except the file interfaces which was edited in the first place back at the beginning of February to get the dongle working.

    Funny really. It worked in a very straight forward way on installing it back then and worked ever since up until last weekend.

    Stumped! :neutral:
  • edited March 2020
    OK Tony...well this is difficult for me as I no longer have the kiwisdr and so reliant on memory and my notebook
    Thinking more about this I probably have the location of those wlan(x) files wrong because the kiwi/beagle is entirely root config so no need for udev User rules. But those files are around there somewhere and were a revelation to me as to why I had to use wlan2 and wlan3 etc....I was configuring multiple wireless dongles in the kiwisdr to examine the limits of the "stock" beagle kernel for USB wireless

    I put your error messages into a search engine...there are many responses - mostly to do with the Raspberry PI - but some of them may give you a lead

    ifconfig -a and iwconfig will list all the network interfaces - I wonder if the wireless dongle shows ?

    If you can work back through this thread to August last year and my conversations with Martin as we try to identify his wireless dongle...basically by installing lshw (to help characterise the hardware)

    apt-get install lshw

    Then run

    lshw -C network

    I'm assuming at this point that the lsusb command (the reason we install usb utilities) lists the wireless dongle

    The other route is to hand over network management to a "network manager". connman (in the repositories) is probably the best, fairly steep learning curve but not too many commands to do. Though not of the Debian stable, the Archlinux wiki is second to none and the section on connman is excellent

    The problem here is that you will need to disable ALL network configuration by the /etc/network/interfaces no fallback !.
    Before I started into this I made absolutely sure that I was completely happy with kiwi/beagle access through the mini USB socket by "virtual ethernet" - which works fine.

    After getting connman to work, then dropping back to manual network config using the /etc/network/interfaces was just the challenge - "because it's there" !

    This is complicated and experimental but is great fun providing you have that essential "proven" backup - what can go wrong ! I can offer at least encouragement through Skype if you wish - search for G3TDJ

  • Thanks for that Andy.

    I've never accessed the beagle through usb, so I will go and look for those files and also try the commands to list the wireless dongle.

    I'll get back to you when I have done some more digging. Cheers and thanks for the input. :)

  • USB is more or less "automatic"...connect the USB Client socket to ethernet on pc, this will almost always "find" the connection as virtual ethernet - works for me on linux and the "other" OS
  • BBAI has connman already installed. Has anyone tried adding connman to the BBG?
  • I have used connman to configure many Kiwis, although occasionally I need to re-execute it after days or weeks of successful wifi operation
  • edited March 2020
    Andy !

    It has been resolved, but I'm not sure why.

    I think it must have been actually solved last week when I was rewriting the interfaces file with new numbers (wlan1). After doing that, I had not rebooted the beagle, but merely ran the ifup utility and that failed to initiate the dongle, returning the error message mentioned above in last week's post.

    Yesterday, I powered the beaglebone down and after about a minute of booting up, the green light on the wlan dongle lit up and started flashing. After a bit, the thing was able to connect via that interface and I disconnected the wired lan. I lost connection again until I replugged the wired lan, commanded the beagle to shut down, removed the wired lan and then the power plug. On powering up again, it all came back normally.

    There does seem to be some sort of weird interaction of networking between the different interfaces. The beaglebone seems sensitive to removing an interface while it is up and running.

    Thanks for your input, and sorry to take up time helping out. :smiley:

    My next problem is going to be getting a cleaner power supply. I bought a switcher with the kiwi/beagle from Martyn Lynch radio here in the UK. Since they were supplying the whole setup, I thought they must be confident that the switcher was clean. I have waves of repeating interference matching harmonics of a power supply. So I am going to explore a better source of 5v. If the pattern of interference changes with a different power supply, I'll be making my annoyance known to the sellers.
  • edited March 2020
    That's good news Tony... I ramble on so long with my replies that forgot to mention the re-boot which is necessary to restart network management after re-configuration

    I think the anomaly you mention regarding interfaces and connectivity is probably down to the kiwi/beagle deciding which of the interfaces has Internet connectivity. Given the choice of two network connections, by default Linux will "assume" the ethernet connection is the primary route to the outside world. Also USB wireless dongles can take a little time to establish a network connection, and if ethernet is connected as well the kiwi will default to ethernet as the route to the Internet

    You really need a linear power supply, but they are difficult to find these days "ready made", and expensive too. I did notice a reference to a 5 volt linear supply, either on this forum or the Perseus SDR group, from Ebay but the unit was close to £50.00 - made for audiophiles I seem to remember ! If I can find it I will drop a note on here.

    edit....I think this is the power supply 5 volts @ 3 A...need to specify the required output voltage - and check the DC output connector dimensions
  • Thanks Andy. I saw that one. Next week sometime, I am going to get out of storage a pretty clean recycled power supply I used to use on my Yaesu txceiver. It came out of a desk top computer that I scrapped and has several 5v lines tied together. If that puts up a different pattern of interference, I will know that the issues I am seeing are related to the power and not my neighbours. I'd feel a bit aggrieved if I spent another £50 and ended up with more of the same. :smiley: Am I tight? Maybe just retired.... :blush:

    Yesterday I changed the earthing of the coax where it comes into the house and saw a radically different pattern on the DC - 30 MHZ spectrum display. Clearly there was / is a common mode issue on the coax. If I disconnect the antenna outside, twenty meters from the house, almost every shred of noise disappears and the waterfall and spectrum just go black. This could be because noise from the house and my neighbours is being carried up the cable to the antenna and then back down, or it may be that the antenna is picking up heavy noise from the houses. I earthed the coax at the antenna end as well and it made no difference.

    To be honest, I am seeking the holy grail here. I've been looking at kiwis run by people like G8JNJ who has the cleanest setup possible more or less.

    G0bzb Tony
  • edited March 2020
    I am a fan of used Acopian Linear supplies. Industrial quality at a reasonable price. May you have access to them or similar in the UK
  • OK Tony.....a power supply from a desktop computer will be a switched mode type, however it's worth a try if it can be done safely.

    A properly designed linear supply will not cause any issues with interference. They are certainly expensive, but should last for ever. Unless one has the more expensive linear power supply components to hand in the proverbial junk box, then linear supplies are expensive to home construct, toroidal mains transformers are fairly pricey to buy new and together with a decent case the overall price soon ramps up

    Agree the "holy grail" of noise free HF reception. I use a loop with an LX1AQ head amp fed into the house with 50 metres of screened ethernet cable. Spatial separation from the noise source is vital, but not always a complete fix...take a read of Martin's, G8JNJ, posts on this forum and on his website for advice regarding the best way to connect the aerial to the receiver
  • I think this thread has veered far away from Wifi and this important topic deserves its own thread.

    Since my remotely controlled battery powered sites KPH and AI6VN/KH6 could not endure the inefficiencies of linear supplies, I found a $1 postage stamp size 1Mhz SWPSU ( mounted on a toroid (see attached photo) produces no noticeable RFI.


  • I had a finding when using the kiwi with wifi that might be useful to others.

    I have noticed that at irregular intervals the latency to the kiwi briefly increases to a few 100ms up to 1 sec.

    The background scanning was to blame. Connman scans for other wifi networks in the background by default. The "symptoms" depend very much on the used chipset/driver though.

    By setting "BackgroundScanning=false" in /etc/connman/main.conf , these delays are now gone.

  • @HB9TMC , Interersting find about latency. I assume in order to achieve this change to main.conf it will be neccesary to temporarily connect via ethernet to the Kiwi.

    When trying to make this change to an already wifi connected Kiwi this was refused.

    best regards,


  • It worked for me without using ethernet.

    After adding the line to main.conf, I reloaded the configuration with:

    service connman force-reload

    The wifi will interrupt for a few seconds, and when it's connected again, the modified config file will be used.

Sign In or Register to comment.