The KiwiSDR 2 online store is open for orders! Please visit kiwisdr.nz

Connecting Kiwi via WiFi

24

Comments

  • Just checked the one working on my Windows 7 machine.

    Hardware Rev E1 Firmware 5.10

    Windows driver version 1030.25.701.2017
  • OK...looks like the dongle now uses a realtek8192cu......the suffix letters have changed and the 'net reports the same lsusb report for this dongle as you see

    This could get more difficult ...not unknown in Linux. A search term "Debian DWA-131" returns several solutions to get the correct driver.

    Really need to identify the chipset used in the dongle

    Andy
  • RTL 8192EU
  • OK Martin....trying to identify the wireless dongle chipset

    need the lshw command, this breaks down to "list hardware"....software not installed...so

    apt-get install lshw

    When installed, (just installed on my kiwi)

    lshw -C network

    On mine this lists a detailed description of the network interfaces in hardware terms...including the wireless

    The lshw command takes time to enumerate the hardware

    Andy
  • This morning I am trying to document the minimum number of steps to reproduce the success Andy helped me achieve yesterday with several Realtek dongles.
    So far I have not been able to connect to them while running the Kiwi's standard 4.4.9 kernel.
    Yesterday's success came after upgrading to 4.4.155, so I'll report back after trying that
  • root@kiwisdr:~/Beagle_SDR_GPS# lshw -C network
    DMI SMP PA-RISC device-tree SPD memory /proc/cpuinfo CPUID PCI (sysfs) ISA PnP PCMCIA PCMCIA
    kernel device tree (sysfs) USB IDE SCSI Network interfaces Framebuffer devices Display
    CPUFreq ABI *-network:0
    description: Ethernet interface
    physical id: 2
    logical name: eth0
    serial: c4:f3:12:b9:fa:95
    size: 100Mbit/s
    capacity: 100Mbit/s
    capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=cpsw driverversion=1.0 duplex=full ip=192.168.1.107 link=yes multicast=yes port=MII speed=100Mbit/
    s
    *-network:1 DISABLED
    description: Ethernet interface
    physical id: 3
    logical name: usb0
    serial: c4:f3:12:b9:fa:90
    capabilities: ethernet physical
    configuration: broadcast=yes driver=g_ether driverversion=29-May-2008 firmware=musb-hdrc link=no multicast=yes
    root@kiwisdr:~/Beagle_SDR_GPS#
  • edited August 2019
    More....if lshw does not show the actual chipset number try...

    lsusb -vv -s 002

    Welcome to the wonderful word of Linux !

    Andy
  • root@kiwisdr:~/Beagle_SDR_GPS# lsusb -vv -s 002

    Bus 001 Device 002: ID 2001:3319 D-Link Corp.
    Device Descriptor:
    bLength 18
    bDescriptorType 1
    bcdUSB 2.10
    bDeviceClass 0 (Defined at Interface level)
    bDeviceSubClass 0
    bDeviceProtocol 0
    bMaxPacketSize0 64
    idVendor 0x2001 D-Link Corp.
    idProduct 0x3319
    bcdDevice 2.00
    iManufacturer 1 Realtek
    iProduct 2 Wireless N Nano USB Adapter
    iSerial 3 00e04c000001
    bNumConfigurations 1
    Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 53
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xe0
    Self Powered
    Remote Wakeup
    MaxPower 500mA
    Interface Descriptor:
    bLength 9
    bDescriptorType 4
    bInterfaceNumber 0
    bAlternateSetting 0
    bNumEndpoints 5
    bInterfaceClass 255 Vendor Specific Class
    bInterfaceSubClass 255 Vendor Specific Subclass
    bInterfaceProtocol 255 Vendor Specific Protocol
    iInterface 2 Wireless N Nano USB Adapter
    Endpoint Descriptor:
    bLength 7
    bDescriptorType 5
    bEndpointAddress 0x84 EP 4 IN
    bmAttributes 2
    Transfer Type Bulk
    Synch Type None
    Usage Type Data
    wMaxPacketSize 0x0200 1x 512 bytes
    bInterval 0
    Endpoint Descriptor:
    bLength 7
    bDescriptorType 5
    bEndpointAddress 0x05 EP 5 OUT
    bmAttributes 2
    Transfer Type Bulk
    Synch Type None
    Usage Type Data
    wMaxPacketSize 0x0200 1x 512 bytes
    bInterval 0
    Endpoint Descriptor:
    bLength 7
    bDescriptorType 5
    bEndpointAddress 0x06 EP 6 OUT
    bmAttributes 2
    Transfer Type Bulk
    Synch Type None
    Usage Type Data
    wMaxPacketSize 0x0200 1x 512 bytes
    bInterval 0
    Endpoint Descriptor:
    bLength 7
    bDescriptorType 5
    bEndpointAddress 0x87 EP 7 IN
    bmAttributes 3
    Transfer Type Interrupt
    Synch Type None
    Usage Type Data
    wMaxPacketSize 0x0040 1x 64 bytes
    bInterval 3
    Endpoint Descriptor:
    bLength 7
    bDescriptorType 5
    bEndpointAddress 0x08 EP 8 OUT
    bmAttributes 2
    Transfer Type Bulk
    Synch Type None
    Usage Type Data
    wMaxPacketSize 0x0200 1x 512 bytes
    bInterval 0
    Binary Object Store Descriptor:
    bLength 5
    bDescriptorType 15
    wTotalLength 12
    bNumDeviceCaps 1
    USB 2.0 Extension Device Capability:
    bLength 7
    bDescriptorType 16
    bDevCapabilityType 2
    bmAttributes 0x00000002
    Link Power Management (LPM) Supported
    Device Status: 0x0001
    Self Powered
    root@kiwisdr:~/Beagle_SDR_GPS#
  • Among all the other devices, 'lshw' shows me the Keebox USB wifi device as DISABLED:
    ....
    *-usb DISABLED
    description: Wireless interface
    product: 802.11 n WLAN
    vendor: Ralink
    physical id: 1
    bus info: usb@1:1
    logical name: wlan0
    version: 1.01
    serial: 1.0
    capabilities: usb-2.00 ethernet physical wireless
    configuration: broadcast=yes driver=rt2800usb driverversion=4.4.9-ti-r25 firmware=N/A link=no maxpower=450mA multicast=yes speed=480Mbit/s wireless=IEEE 802.11bgn

    It appears to me that linux has loaded the drivers needed for this chip, but they don't know how to talk to this version of it:

    root@kiwisdr:~# lsmod | grep ^[rm]t | sort
    mt7601u 75648 0
    rt2800lib 63194 1 rt2800usb
    rt2800usb 16465 0
    rt2x00lib 40316 3 rt2x00usb,rt2800lib,rt2800usb
    rt2x00usb 10547 1 rt2800usb
    rtl8192c_common 38293 1 rtl8192cu
    rtl8192cu 52250 0
    rtl_usb 8852 1 rtl8192cu
    rtlwifi 54277 3 rtl_usb,rtl8192c_common,rtl8192cu
    root@kiwisdr:~#
  • All that info and the chipset number is not revealed...here is a fragment of my listing for the Netgear

    root@kiwisdr:~# lsusb -vv -s 002

    Bus 001 Device 002: ID 0846:4260 NetGear, Inc. WG111v3 54 Mbps Wireless [realtek RTL8187B]
    Device Descriptor:
    bLength 18
    bDescriptorType 1
    bcdUSB 2.00
    bDeviceClass 0 (Defined at Interface level)
    bDeviceSubClass 0
    bDeviceProtocol 0
    bMaxPacketSize0 64
    idVendor 0x0846 NetGear, Inc.
    idProduct 0x4260 WG111v3 54 Mbps Wireless [realtek RTL8187B]
    bcdDevice 2.00
    iManufacturer 1 Manufacturer_NETGEAR
    iProduct 2 NETGEAR WG111v3
    iSerial 3 001E2AB0834A
    bNumConfigurations 1


    So we still have work to do !
  • OK next try

    dmesg | grep rtl

    This is my kiwi...

    root@kiwisdr:~# dmesg | grep rtl
    [ 7.191527] ieee80211 phy0: hwaddr 00:1e:2a:b0:83:4a, RTL8187BvE V0 + rtl8225z2, rfkill mask 2
    [ 7.213406] rtl8187: Customer ID is 0x00
    [ 7.214567] rtl8187: wireless switch is on
    [ 7.214870] usbcore: registered new interface driver rtl8187
    root@kiwisdr:~#
  • It returns nothing
  • Looking through the log without grep

    Shows these

    [32m[ 2.469231] [0m[33musb 1-1[0m: new high-speed USB device number 2 using musb-hdrc
    [32m[ 2.598092] [0m[33musb 1-1[0m: New USB device found, idVendor=2001, idProduct=3319
    [32m[ 2.598114] [0m[33musb 1-1[0m: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [32m[ 2.598124] [0m[33musb 1-1[0m: Product: Wireless N Nano USB Adapter
    [32m[ 2.598132] [0m[33musb 1-1[0m: Manufacturer: Realtek
    [32m[ 2.598141] [0m[33musb 1-1[0m: SerialNumber: 00e04c000001
  • I have to go to the shops Martin but will be back soon

    From research believe the chipset is the rtl8192eu, and several people have produced Linux drivers for this variation, discussed here http://forums.debian.net/viewtopic.php?t=132805


    https://github.com/Mange/rtl8192eu-linux-driver

    https://trollingheavy.wordpress.com/2016/09/25/d-link-dwa-131-rev-e-on-linux/

    https://askubuntu.com/questions/738911/install-dwa-131-wifi-dongle-driver-under-ubuntu-14-04-4

    so there are some routes to try

    Andy
  • Hi Andy,

    I can confirm it's a rtl8192eu chipset.

    I opened one of the dongles up earlier on, but I wouldn't recommend doing this.

    Perhaps catch up later, but don't worry as I'm out and about for the next couple of days anyway.

    Thanks,

    Martin
  • OK Martin.....researching the driver seems to indicate it's in the kernel

    So maybe remove the firmware-realtek driver

    apt-get remove firmware-realtek

    ..and try again

    Andy
  • OK it's removed, but what exactly do you want me to try again ?
  • I'm following along after receiving 3 D-Link DWA-131 dongles today - I have got the same results as Martin so far, no success.
  • Just boot and try

    ifconfig -a

    to see if either wlan0 or wlan1 is activated.

    My D-Link dongle came up as wlan1, it would not come up as wlan0 even though John jks says that the limited wireless support in the kiwi is for wlan0

    However Rob's (rrobinet) noname and Keebox dongles and my Netgear WG111v all come up on wlan0

    Now the chipset is positively identified as rtl8192EU....EU=Europe I guess....the correct driver or required kernel version should be available. My kiwi has kernel 4.4.9-ti-r25, Rob's post @ 2.31PM indicates a kernel upgrade maybe needed.

    Andy G3TDJ
  • I am in the midst of trying to recreate yesterday’s success. An upgrade to kernel 4.4.155 is not enough.
  • Unfortunately no, it's the same as before.
  • The driver wont compile here. Make is aborting at '/lib/modules/4.4.9-ti-r25/build: No such file or directory. Stop.' Suspect the kernel also.
  • FWIW (probably not much but indicates my interest) under 4.4.9-ti-r25 my ebay Chinese no-name dongle containing an RTL8811AU chipset (by examination) does the same as Andy reports using lsusb -vv -s 002. The Kiwi doesn't know it's chipset either and no wlan is installed per ifconfig -a. Interestingly it reports the same iSerial 3 00e04c000001 .

    Glenn n6gn
  • edited August 2019
    My success did not require recompiling the driver, just a kernel upgrade to 155 and then installing some packages. I'm now studying which packages were installed on the working Kiwi.
    See the list of known working BBB UAB wifi adapters at: https://www.elinux.org/Beagleboard:BeagleBoneBlack#WIFI_Adapters
    On my working Kiwi it can use the EDIMAX, D-Link DWA-121 and the Keebox
  • Will try to compile this driver in the kiwi

    https://github.com/Mange/rtl8192eu-linux-driver

    I won't be able test it, but will find out if it will build on the kiwi and if not hopefully why not

    It's a kernel module so will have to be loaded (automatically) at boot as the instructions describe, I did not see any rtl8xxx driver being loaded in your various listings Martin, so may not be necessary to blacklist the existing rtl8xxx kernel module (which out of interest is being used by my Netgear wireless dongle)

    Andy
  • edited August 2019
    Rob....would the bash_history file help to see which packages were installed - that's if you are not already looking at it.

    Not at all sure where it would be on the kiwi - just searching mine to see if I can locate it

    Andy
  • With my no-name dongle was supplies a CD full of documentation and driver source code from Realtek that seems to be dated around 2011. The provided Makefile allows cross-platform compilation: I386_PC, ANDROID_X86, ARM_S3C2K4, ARM_PXA2XX, ARM_S3C6K4, MIPS_RMI, RTD2880B, MIPS_AR9132, MT53XX, RTK_DMP and for a variety of Realtek chipsets, including at least:
    RTL8192CU, RTL8192CE, RTL8192DU, RTL8192DE, RTL8723AS, RTL8723AU, RTL8189ES, RTL8188EU, RTL8723BS, RTL8723BU
    and there is an install.sh that's supposed to be ready-to-go for PC-Linux target.
    Unfortunately though I tried to compile with this, it didn't make it all the way through, complaining about a non-existent member of a init_timer function.

    I was hoping that there would be a chance of compiling on the kiwi but since I'm not even making it through the more common case on an 'easy' path, I think I'm probably not man enough to proceed.
    Again, I'm not being very helpful...

    Glenn n6gn
  • I just checked the supplied drivers disk just in case, but it only contains Windows versions.
  • edited August 2019
    I was able to recreate a working installation, but it now fails after a reboot.
    I have a backup SD which works well and I am trying to search it to find what packages are needed by comparing the package lists of the working and non-working backups.
    To get a list of your installed packages run 'apt-cache search . > apt.log'.
    Since there are 374 packages installed on the Kiwi, you want to log its output
    I ran that on my "wifi-working" Kiwi and a "upgraded to 4.4.155" Kiwi where wifi didn't work.
    I then compared the apt.log files and found dozens of what appear to be minor difference and 3 packages I had added to the 4.4.155 Kiwi:

    firmware-misc-nonfree
    firmware-realtek
    connman

    Installing those on the non-wifi Kiwi got wifi working until I removed and re-inserted the dongle. Since then I can't get it working again, even after a reboot.
    There are dozens of other package differences and it isn't clear to me how that occured.

    As you all know this is a painful debugging effort and I do have an image which works reliably for my application using either the Keebox or my noname dongles.
    So I may take a rest from this effort for a few days.
    My experience suggests that there is a magic combination of packages on 4.4-115 which support the Realtek dongles. I have attached a log file with the list of packages on my working Kiwi if anyone cares to explore this further.

    Attachments:
    https://forum.kiwisdr.com/uploads/Uploader/d7/f2620d2135db2d742fe84d571646d2.log
Sign In or Register to comment.