Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (rx.kiwisdr.com, map.kiwisdr.com)

Please visit kiwisdr.com (documentation) and kiwisdr.nz (online store)

kiwirecorder.py using mode=IQ and --s-meter

@jks I would like to record the IQ wav file and the RSSI at the same time with the timestamp ( --ts).

It seems that as soon as I add "--S-meter=0", "--ts" the IQ wav file is not saved.

So:

python kiwirecorder.py -k 10 -s jnb.twrmon.net -p 8073 -f 1458 -m iq --tlimit=12

work fine - get the IQ Wav file and the long list of RSSI readings.

BUT when I add on the end --s-meter =0

 python kiwirecorder.py -k 10 -s jnb.twrmon.net -p 8073 -f 1458 -m iq --tlimit=12 --s-meter=0 --sdt-sec=3

I get no IQ wav file.

Thanks for any help.

Comments

  • When I add --snd

    python kiwirecorder.py -k 10 -s jnb.twrmon.net -p 8073 -f 1458 -m iq --tlimit=12 --s-meter=0 --sdt-sec=3 --snd

    then, I do get a wav file but is this an audio wav file or a IQ wav file?

  • I'll get to this when I can. Things are stupidly busy right now..

  • edited July 2023

    Thank you, much appreciated.

    I do need clarity on this and to be sure I am recording an IQ WAV file.

  • edited July 2023

    I have done a lot with kiwirecorder and I/Q wav files so I know that works. I have just not used your exact cli string

    I used

    ./kiwirecorder.py -k 5 -s $1 -p 8073 -f $2 -m iq -L 300 -H 3600 --ncomp --tlimit=$3

    with $1 $2 $3 added on cli

  • jksjks
    edited July 2023

    Just getting to this now. Yes, adding --snd is what you want.

    The file will be real (1-ch mono) or IQ (2-ch stereo) depending on the -m <mode> setting. Modes iq drm sas or qam will result in a 2-ch stereo file. Remember that the mode is reflected in the sound filename, e.g. "20230728T191504Z_10000000_iq.wav"

  • edited July 2023

    Thank you for confirming this.

    I just tried what @WA2ZKD gave:

    ./kiwirecorder.py -k 5 -s $1 -p 8073 -f $2 -m iq -L 300 -H 3600 --ncomp --tlimit=$3

    And it does work fine.

    But when I added --s-meter=0 with --sdt-sec=5 there was no iq wav file recorded but @jks has confirmed that I must --snd and the wav file recorded is a IQ wav file. QED. 🙂

    PS.. Still working on MW AM Modulation as time permits, so want to record the RSSI along with the IQ wav file.

    python3.7 kiwirecorder.py -k 5 -s xxx.net -p 8073 -f yyyy -m iq -H 5000 --ncomp --tlimit=120 --s-meter=0 --sdt-sec=10 --ts --snd

Sign In or Register to comment.