The KiwiSDR 2 online store is open for orders! Please visit

What went wrong with my KiwiSDR ? [corrupt kiwi.json file]

edited December 2022 in Problems Now Fixed

Hi all,

After v1.570 automatically updated, I encountered a problem as follow,

I can see this KiwiSDR and IP address in my router connected clients ...

But I cannot connect it with that local IP/port with Firefox

and I cannot connect it with for a local device surveying either,

I have no idea what happened to it ...

Should I recover Kiwi with SD card ? or try other method ...

Thank for your suggestion in advance.


  • Try clearing your browser cache or try another browser.

    It may just take a while to update fully, so I would leave it for a while before considering a recovery.

    Can you ping it or SSH into it ?



  • Hi Martin,

    Glad to see you again ~ this is the status :

    Try clearing your browser cache or try another browser. => Done, both Chrome/Opera (brand-new installed at PC) failed the connection too.

    Before issue happened, the firmware has been updated to 1.570 and worked fine one or two days.

    Ping it. => Got responses as can be seen below.

    SSH into it. => Serial-port connection to BBG ? I'm noob with EVB/Linux and never dd things like that before. . well i have to learn this a while and prepare for the worst.

    thanks a lot, anyway.

  • Hi Jimmy,

    That's odd.

    What happens if you ask for it's status using the webrowser as normal with /status after the port number, assuming you are using 8073

    Unfortunately that's about my limit with Linux too, but it looks like either the webserver part has stopped or the port number has changed.

    Have you tried a power cycle ?

    Otherwise it's over to more qualified folks to comment.



  • Isn't there an ssh available from the command line in Windows? Failing that, try the PuTTY application. So first try ssh root@ and use the Kiwi serial number as the password (written on the top of the Kiwi circuit board in the white box).

    Once connected try these commands:


    ps ax | gr kiwid


    Email the resulting messages to

  • Hi, jks

    Putty access for log was done.

    Mail sent and thank for your help in advance.



  • Hi Jimmy,

    Thanks for your complete and detailed email. It really helps me when people send me the info I ask for. You were correct. There was indeed an error parsing the configuration file kiwi.json We've seen this happen a few times in the past. It is not clear why this happens. Possibly a power failure at a bad time (when the file was being written).

    You should be able to get the Kiwi going again by using these commands after an ssh connection:


    cp unix_env/kiwi.config/ ../kiwi.config/kiwi.json

    Note the ".." (two dots) above. When the Kiwi server next restarts (in a minute or so) it should begin running normally. Your customizations will be lost, but it is much better than having to start over re-flashing using the sd card.

    If you happen to have a backup made using the admin page, backup tab function, then a more recent kiwi.json file with some of your customizations can be recovered. Let me know we need to do this.

  • Hi jks,

    These command lines are really powerful and work well ! Thanks a lot.

    As a record shown below is the ssh msg I see in this issue, and hope it can help someone too in the future.

    Enjoy KiwiSDR !



  • Eventually my kiwi revives with full hp tonight.

    Thank for jks & G8JNJ gurus' help.

    continue my noise reduction engineering ...

Sign In or Register to comment.