Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (,

Please visit (documentation) and (online store)

v1.462: MANUAL INTERVENTION REQUIRED to receive future updates

edited October 2021 in KiwiSDR Discussion


  • If your Kiwi is running v1.463 (or later) you're fine.
  • If running v1.462 you need to take manual action to force an update. Otherwise you'll never get v1.463 or any later version.

v1.462: On the admin page, "console" tab, connect and type the following shell command:


This will manually download and build the latest version (roughly 30 minutes to build). There are significant periods of time while this script is running when there is no output. Do not type ^C to stop this script prematurely!

When the build finishes (you get a shell prompt similar to root@kiwisdr:~/Beagle_SDR_GPS#) go to the admin page "control" tab and click the "KiwiSDR server restart" button. After the restart delay you should be running the updated version and automatic updates should work again. Verify by clicking the "check now" button on the admin page, "update" tab and see that you get a message saying "running the most current version".

If you're logged into the Beagle/Debian directly via ssh/PuTTY (instead of the admin page console tab) then use the commands:





  • What if I skip v1.462 ?

    My Kiwi is configured for manual updates and so has still v1.461 running. Now it is offering v1.463. Just to be sure: is it safe to click "Build now" in order to update? Or do I need to apply a manual fix before or after or instead?

    Thanks in advance!

    73, Manfred, DL7AWL

  • Oh, I think I can answer my own question. Logged in via SSH, I found a file named Beagle_SDR_GPS/update_fix, so it seems to be there always and not specific to step from v1.462 to v1.463 as I initially supposed. Thus, I think I can run it for update without harm.

  • You can use the update_fix script at any time. It's nothing special. But it must be used if your Kiwi is running v1.462 because the automatic update process (or even the "build now" button) is broken for that particular version.

  • edited September 2021

    I ran update_fix on one of the KiwiSDRs, worked fine. So I opened up three more browser tabs to do another three. They started to build, then stopped building (but still otherwise work). I gave them an hour or two, then restarted. Still stuck at 1.462. So I ran update_fix on them again, same thing, started to build, then hung part way through. I have not restarted them yet. Any ideas?

    EDIT: Going to ssh in and try manually rebuilding. I wonder if the web console connection dropped, and that is why the build aborted?

  • You have to look for error messages. Or cut-n-paste all the output and attach it as a file here.

  • edited September 2021

    No error messages, and the build did not abort, the output to the web console just stopped updating. So going with the lost connection theory for now. I'll let you know if manually building via an ssh connection works better.

    EDIT: The build is still going fine, I did open a console connection in via the web interface, and sure enough it dropped the connection part way though.

    EDIT: After the build finished, I restarted the KiwiSDR server on all three, they all were still on 1.462 when they came back online. So I then rebooted the Beagles, and now they're on 1.463. Now to repeat the process on the last two KiwiSDRs here.

    Hopefully this helps someone else if they run into the same situation.

    EDIT: Well that was strange, it took several (three? I lost count) tries to get the last two KiwiSDRs updated to 1.463. Twice the ssh connection to each KiwiSDR dropped, each time at the exact same point in the build process, at DRMReceiver.cpp. Coincidence? Anyway, they're all updated now, so it's all good.

  • update_fix to v1.463 ran smoothly without problems. Thanks again!

  • edited September 2021

    After downloading 1.463, the receiver broke down completely.

    I can log in to the admin panel, but all tabs are completely empty. The Kiwi page fires up but only a photo is displayed, the drop down bar has expanded to halfway, no waterfall, no clock. Yesterday I downloaded 1.462 but I downgraded my card to 1.461 because the effect was the same. I think the reason for the crash is an unusual font which I used in the Webpage / Public tab in the STATUS, Window / tab title lines, but the script in the Additional HTML / Javascript for HTML field works normally.

    I can also see some receivers on which after the update have bushes instead of names because they had some unusual fonts in PUBLIC / NAME.

    In previous updates, there was no problem with MS PMincho fonts. Should I now remove all "other" fonts before updating to make it work or wait for the update?

    The other two receivers are still working with 1.461


    Before updating the next Kiwi, I removed unusual fonts from the PUBLIC tab, namely Name and Antenna, only then the program starts. Emojis in the WEBPAGE / HTML tab are also not supported

    Please, move my threads to the problems section

  • So my guess is that the changes to make the config files more readable has not properly handled all the weird Unicode that some people insist on adding to their customizations.

  • Yeah, that's exactly what this is unfortunately..

  • I'll be the odd one out and tell you that my update_fix went perfectly here. I think I found your notice on the webpage just a few minutes or so after you posted and ran it right away. Came back in 40 minutes, all done so I reset the server - no problems seen since.

    May I add that I like this addition? I've gone from 4 receivers to 8, just in case I and others want to monitor COTHEN all day...

  • I also did not have a problem updating to v1.463.

    It took a little longer than half an hour, to download, but no hitches.

    Now I've got to figure out all this new ALE-2G stuff.

    -Zyg- AF4MP

  • This is going to be a mess to fix because it has left damaged data in everyone's configuration files that used UTF-8 (Unicode) sequences.

  • Just updated two Kiwi Receivers per instructions with no code modification, one took 44min the other 46 min, no problems at all.

  • After the update, will it say update complete? Will it say restart the system?

    73, Larry, WB8LBZ

    El Paso, TX

  • I'm back to a root@kiwisdr:~/Beagle_SDR_GPS#

    Is this where I reboot the system?

    73, Larry, WB8LBZ

    El Paso, TX

  • Yes. I have updated the first post to be more clear about this point.

  • Thanks a bunch.

    73, Larry WB8LBZ

    El Paso, TX

  • edited September 2021

    Now on the fourth attempt.

    KiwiSDR had auto updated to 1.462 some time overnight. Followed instructions. Watched console window. Process appeared to hang at always2 after about an hour. Restarted server ... no change. Rebooted Kiwi ... no change. When I run update_fix it tells me it's already up to date ... but then proceeds anyway.

    CONSOLE: open connection
    root@kiwisdr:~/Beagle_SDR_GPS# update_fix
     = [up to date]      master     -> origin/master
     = [up to date]      dev        -> origin/dev
     = [up to date]      drm        -> origin/drm
    Already up-to-date.

    Getting nowhere :(

    EDIT ...

    Finally!! after four attempts, success. Completed in 32 minutes and now at 1.464

  • It only has to sync the sources once. That's why you'll see "Already up-to-date" on subsequent runs. But it will always do a clean build from that point which takes 99% of the total time.

    Are you sure it's really hanging at the "always2" step? Those last steps take several minutes each and can give the appearance of something being wrong. If the total build time exceeds, say, an hour 15 then I would say something is up.

    Do a "df ." before building and check that you have enough free disk (flash) space.

  • I ran the update_fix twice and it still says "Installed version: v1.461, built Sep 16 2021 04:40:16

    Running most current version

    Noe what do I do?

    73, Larry WB8LBZ

    El Paso, TX

  • jksjks
    edited September 2021

    @WB8LBZ After running update_fix in the admin control window, is it possible for you to copy-paste the entire output contents and email it to ? I need to look for any error messages. Also, please send the result of running a "df ." command to see how much free space your disk has.

    When doing the copy-paste use the "select all" feature of your browser to select all those lines in the console window rather then trying to click-sweep the lines with the mouse (a very tedious operation).

    @VK2AAK Glad it finally worked. Wish I understood the circumstances of the prior failures though..

  • email sent with attachment.

    73, Larry WB8LBZ

    El Paso, TX

  • @WB8LBZ Fourth line in the file you emailed me:

    fatal: unable to access '': Couldn't connect to server

    So it's not downloading the v1.464 updates and just rebuilding the current version (v1.461) all over again. Can you access that exact GitHub URL using a browser on the same network that the Kiwi is on? We've seen a couple of problems in the past where DNS poisoning from ISPs has screwed up GitHub access.

  • I think the time has come to move to binary-only updates. This business of building from sources was convenient for development in the beginning, but is now more trouble than it's worth..

  • I have 2 Windows 10 and one Raspberry PI3 on the same network with the KiWi. I'm not sure how to proceed.

    73, Larry WB8LBZ

    El Paso, TX

  • @WB8LBZ If you type into the address bar of a browser what happens?

  • It takes me to the github page for the Beagle Bone SDR.


  • One of the KPH Kiwis was unfortunately set to auto update and now doesn't present an Admin page. I can ssh to it, but there is no 'update_fix' command. What should I do?

  • @WB8LBZ Okay, let's try something different. Connect to the admin page, console tab and type these commands. Be very careful in doing so. Stop if you get any sort of error and let me know.

    rm -f Makefile.1


    Stop if this says anything other than:

    On branch master

    Your branch is up-to-date with 'origin/master'.

    nothing to commit, working directory clean


    Stop if this says anything other than:


    mv Beagle_SDR_GPS B.old

    gclone Beagle_SDR_GPS

    Lots of output will occur here and command may take several minutes to finish.


    head -2 Makefile

    Stop if this says anything other than:


    VERSION_MIN = 464


    This should run without errors taking the usual hour or so. Use the "restart" button on the admin control tab after it finishes.

Sign In or Register to comment.