No Power when Cape attached

UPDATE: Works fine with another power adapter - go figure! I'll be getting a linear power supply anyway in a few days. Good to know the board was OK though - now for some fun!

 Hi, new owner here of the Beaglebone + Kiwisdr combo.

I have tried several 5V power supplies and none seem to power the device on. If I remove the cape, the Beaglebone does power-on fine (with the micro-usb cable). What pins can I check on the kiwisdr to verify if the kiwisdr cape is bad? Voltage levels? Open/Shorts?

Note: I have read the post related to power adapters not having large enough gage wire and I believe mine does, so I that is not the issue.

I'd just like to know what is a quick voltmeter/ohmmeter check I can try before I return it / buy a new one...




  • jksjks
    edited November 2017
    Yes, this a common and sometimes difficult to diagnose problem. Out of all the times it's been reported there has only been one case (that I know of) where the Kiwi board was bad and had to be replaced by Seeed. The Kiwi boards should be getting 100% factory tested by Seeed because they program the serial number into the EEPROM on the Kiwi board (so it is getting powered up in combination with the Beagle).

    Troubleshooting guide here that shows places on the Kiwi board where you can measure voltage actually being supplied to the Beagle after all the drops: Measure the "5VE" point (5V external).

    The other issue is rise time of the +5V at the Beagle's power management IC (PMIC). It has to be 50 milliseconds or less. Otherwise the PMIC can't properly sequence the various different output voltages to the Beagle processor (TI Sitara). Try plugging the power cable in to the Kiwi as opposed to powering up the supply if this is what you have been doing. It might be that large output caps of a linear supply are slowing the rise time. Or perhaps turn-on characteristics if you're using a SMPS.

    If the PMIC sees under voltage, over voltage or slow rise time it will not power up the Beagle even though you measure 5V on the 5VE pin with a voltmeter. You really need a triggered scope trace to see problems just at the moment of power on. A fast DVM can also catch the under voltage problem. That's how I first figured it out when the undersize AWG problem first happened to me. I was measuring 5V on the cable. When I plugged into the Kiwi there was a brief voltage drop below 4.8V as the PMIC tried to connect and pull current. Then it disconnected and the cable voltage went right back to 5V!

Sign In or Register to comment.