The KiwiSDR 2 online store is open for orders! Please visit kiwisdr.nz

DRM demod? [yes, external app Dream now working!]

2»

Comments

  • Hello to all,

    Can someone tells me how to configure "loopback" (Rogue Ameaba) version 2 and DREAM ?
    I'm on Mac OSX El Capitan and using Chrome with KiwiSDR.
    Dream is version 2.1.1

    Must I define an audio device for Chrome output so I can see it in DREAM sound card input ? I tried it but no results, Dream does not hear anything

    Thanks, regards
  • jksjks
    edited January 2019
    Here's how I do it with Loopback 1.2.1 (I haven't upgraded yet) and Dream 1.11. I was never able to get Dream 2.x to work on Mac (El Cap 10.11) because of missing CODECs. But that was a long time ago any maybe the situation is different now.

    The order of these steps is important.
    Start up Loopback. Only need to do once: If there isn't an entry for your browser in the left column then in the right column under "audio sources" click the "+v" button and select your browser from the list. An entry for it will appear in the left column. Check every time: Make sure its checkbox is checked. Make sure "monitor audio through:" is unchecked unless you want to hear the Kiwi audio in addition to Dream output (like while you're tuning for a DRM station).

    In OS X System Preferences, Sound section, select "Loopback FF" under "select a device for sound output:".

    Start Dream with the correct settings for IQ input. This is tricky. I can never remember how to do it from the Dream user interface. So I created a shell alias to start Dream from the command line (in a Terminal window). The command is:
    /Applications/dream.app/Contents/MacOS/dream -I 1 -c 5
    
    Replace "/Applications" if you put the Dream application someplace else. But the "dream.app/Contents/MacOS/dream -I 1 -c 5" part will remain the same. Use "-h" instead of "-I 1 -c 5" to see all the options. That's a "capital-letter-I one" as the first option which means sound device in #1. "-c 5" means IQ input positive, 0 Hz IF. With Dream 1.2.1 I can't even find in the Dream UI where you set this!

    Now Dream should show a signal in the evaluation dialog, "Spectrum > Input PSD" chart selector section. Of course the Kiwi needs to be set in IQ mode on the correct frequency (when zoomed in the passband should be symmetric around the DRM signal).

    Not optimal advice, but it's what works for me.
  • Thanks for your info... have some issue with the built-in microphone and loopback, I hear always background sound via the microphone even if it is not used as input.
    And yes, Dream 2.x miss codecs :(

    So, I continue my investigation, looking in loopback forum etc...
    I found this thread https://soundonsound.com/forum/viewtopic.php?f=19&t=62734 but I have to understand how to proceed
  • issues with the microphone come with the lasts versions of Dream :(
    I'm looking for version 1.11 which seems to be the best for me (osx 10.11) including the codec.
    Unfortunately the .dmg binaries do not exist anymore, have also check dl2sdr.homepage.t-online.de/files/Dream_1_11.zip , no luck.

    Is there somebody who can share/send the .dmg binaries for Dream V1.11 ?
Sign In or Register to comment.