New beta test KiwiSDR: try new features before release

The Kiwi at is running a beta test version of the software.

Please try connecting and see if you find any problems. Sometimes users experience problems that we don't see during development, probably due to differences in network environment, browser issues etc.

For v1.83beta:
Please try accessing the admin page at (password "x") as this is the latest problem we've been having. People report they only get a blank page and the Javascript console displays the error: Uncaught SyntaxError: Unexpected token )
Please let us know if this is still occurring for you.

Thanks very much!


  • I connected to the SDR and the ADMIN and all worked.  I run Chrome on El Capitan.

  • Had it failed for you on another (or your own) Kiwi previously during the v1.81 release?

  • John,
    fails to display on the Chromebook. 
    Version 57.0.2987.146 (64-bit)
    Platform 9202.64.0 (Official Build) stable-channel peppy
    Firmware Google_Peppy.4389.93.0

    and the Ubuntu running in a chroot on the Chromebook:
    Firefox 43.0

    The admin does load and display on the openSUSE Desktop, both Chrome and Firefox. 
    Ron - KA7U
  • Ron, could you try it again on your Chromebook please.
    If it doesn't work the very first time try doing an explicit refresh (shift-refresh).

  • John,
    I did the explicit refresh and also went to History and deleted the cache and hosted app data. Still the link will not display on this Chromebook.
    Ron - KA7U
  • Okay, I added some more debugging. Please try it again. If it fails please look at the javascript console of the browser. You should see messages of the form:
    "#### admin_js_debug=N" where "N" is a number. Please tell me the last/largest value of N.

  • JKS asked:
    "Had it failed for you on another (or your own) Kiwi previously during the v1.81 release?"

    NO, sorry, I thought it was a general request.

  • admin page does not load on Linux Mint / Chrome, did forced reload etc.
  • Sorry, Chuck. I should have been more specific.

    My last request isn't confined to Ron. Anyone who has a browser that failed to login to the admin page on a Kiwi that was running the previous v1.81 release: please try and, if it also fails for you, look at the Javascript console and tell me about the messages as described above.

    This seems to be a bug in older Javascript interpreters in certain browser/OS combinations. We've seen this issue before. That's why I can't reproduce it here. But I need to know what the messages say so I can figure out how to stop tripping over this bug.

  • FIXED. I found an old laptop with a Chrome that failed.
    Thanks everyone for your assistance and patience getting to the bottom of this. It was indeed a javascript interpreter inconsistency.

  • Hi John,

    Your running 1.83 works OK for me on the PC I previously had problems with when running 1.81.


  • works now
  • John,
    This version is opening in the Chromebook browsers. Glad you found the problem for this.
    Ron - KA7U
Sign In or Register to comment.