Wrong IP address with Virgin SuperHub2 (UK)

Hi Group,

This is probaby a longshot as I don't expect anyone will be using this combination of equipment. I have Virgin media Superhub 2 wired into my KiwiSDR.

The IP address for a local device should be something like 192.168.0.x (where x is a low number like 5)
But, it keeps going to I tried all sorts, reserving addresses, DHCP settings, but it keeps on going back to a stupid address. This prevents me from connecting at all.

I wonder if anyone else has found the tendency to jump to a strange IP address?
It does work, sometimes after about 10 power cycles.
I will test in another location with a different ype of router this coming weekend.

73s, Rob


  • Hi Rob, I have exactly the same configuration here, I think my router is the Superhub2. I have no issues, although sometimes after a power fail it will assign another low number, say between 1 and 10.
    I thought you could assign a port in that router to your hardware, I think I did that with mine in theIt'sd. Its not really an issue, we get maybe one power failure a year (if that) in the London area.

    Dave M0TAZ
  • Hi Dave,
    I tried forcing the IP address on the Beaglebone to but it bricked it until I re-loaded from micro-SD. Reserving a DHCP address in the router to the one that the Beagle goes to once every 20 power cycles doesn't help either. That's the real issue - I have to power the Beagle about 20x before it gets a vlaid IP address. Not doing the power connector any good!

    I suspect the Virgin box is the cause, rather then the Beagle, as my Macbook laptop also has problems getting a DHCP address.
    As promised I will report back in a few days when the unit gets tested with a PlusNet router at my parents house.

    73s, Rob
  • This was indeed due to a fault with my old router. Virgin will replace a router free if it's more than 3 years old, and they are satisfied there is some kind of hardware fault.
  • Good news, hopefully, thats resolved.
Sign In or Register to comment.