100% browser CPU, Firefox on x86 Linux Mint?

edited May 2017 in Problems and Issues
Is anyone having problems with Firefox using 100% CPU on Linux Mint distributions running on x86?
This problem may have started with the v1.78 release although it may have been earlier. Symptoms are super sluggish UI with slow waterfall or none at all.

If so, could you please open the javascript console in FF and then connect to a Kiwi and tell me if there are any error messages in the console?
Thanks. My only Linux here is Ubuntu 12.04 running on a Mac under VirtualBox which works fine.

Firefox amd64 52.0 OR 53.0 +linuxmint1+rosa

Linux version 3.19.0-32-generic (buildd@lgw01-43) (gcc version 4.8.2
(Ubuntu 4.8.2-19ubuntu1) ) #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40
UTC 2015


  • I have Ubuntu and openSUSE desktops here. Linux Mint will boot from a USB stick, so the Rosa version of Linux Mint could be downloaded and run from the USB stick. Rosa is not a current version, near as I can tell. 

    "about:plugins" in the URL box will list the Java applications loaded into Firefox and those plugins might need an update. Firefox might need an update too.

    If you think it would help, I will download and run Mint-Rosa from a USB stick, but Mint and Ubuntu are near cousins, so the problem is likely specific to Firefox and the Java plugins installed on a particular machine.
    Ron - KA7U
  • I tried Firefox v53  (64bit) with Linux Mint 18.1 (Serena) Cinnamon and I noticed no CPU increase.
    Frank - LX1DQ
  • Okay, thanks everyone. The person reporting this problem had tried updating from FF 45 to 53 with no improvement. A Mac on the same local network using FF worked fine, so this doesn't seem to be a network issue.

Sign In or Register to comment.