Static IP

Just got our first KiwiSDR and have it running fine on a dynamic IP but I need a static IP for this device.

I upgraded to the latest firmware and in the Admin screen I select Network and change it from DHCP to Static but this is not working. The device always uses DHCP even though Static is selected.

What am I doing wrong?


  • jksjks
    edited January 2017
    Well, it's always possible there is a bug. But we just tried it again on our development Kiwi and it worked.
    Here are a few things to check.

    After you change to static look at the log tab. The last line should be something like:

    Thu Jan 12 17:22:55 2017 0:01:17 .... [00] eth0: USE STATIC ip= nm= gw=

    Then before rebooting, login to the Beagle and look at file /etc/network/interfaces. The line:

    iface eth0 inet dhcp

    should have changed to:

    iface eth0 inet static

    assuming the new static ip set is etc.
    A backup copy of original file is saved in interfaces.bak

  • The v1.49 release fixes a bug: When you change the mode between DHCP and Static a cyan-colored button appears that says "Are you sure? Click to update interface DHCP/static IP configuration". The /etc/network/interfaces file isn't written until this button is pressed. The bug was that the button didn't appear when switching to Static mode under certain conditions.

  • I stopped using static IP in my devices and instead use MAC/IP locking in the router.
Sign In or Register to comment.