Please, I need some help! [startup problems]

edited March 2017 in KiwiSDR Discussion
My KiwiSDR has been working very nice since it arrived 5-6weeks ago. I have booted it several times, both with power button and removing and reconnecting power. When booting, the 4 leds are flashing in some kind of pattern and then the left led repeats a pattern - two short flashes and then dark for the double (?) time. This is repeated until power down.

I have tried to upload the backup from the supplied SD-card. Insterted the sd, held down the boot button above the sd-slot and applied power. Leds flashing back and forth and shuts down after about 4minutes. Booting again, but it ends up with two flashes described above.

Are there any information about the leds? 

Any help to get the KiwiSDR up and running again would be very, very nice! Thanks in advance!

Best regards
Karl Jan - LA3FY


  • You're not leaving the SD card inserted in the Beagle (except during software installation), correct?

    The only time you should see the "back-and-forth" ("cylon") LED pattern is when you boot with the SD card installed and the software installation process is running. This is what takes about 4 minutes. At the end all the LEDs will go on for a moment and then the Beagle will power down.

    During normal operation, with the SD card *not* installed, the LED assignments are:
    LED0 (closest to the outer edge of the Beagle PCB) heartbeat in a regular "double flash" pattern
    LED1 micro-SD card access
    LED2 off when Linux in idle loop
    LED3 on-board flash (eMMC) filesystem access

    You should *not* need to press the "boot" button to boot off of the micro SD card I believe. The only exception might be if you are supplying your own Beagle and it has an old version of Angstrom / Debian installed (actually the boot loader). I'm not even sure what the boot button does anymore.

    Try doing a fresh install from the SD card that runs to full completion with the Beagle powering off. Then remove the SD card and power up. You should not be getting a power down after a few seconds if the software install has been done correctly (assuming you are using a power supply that is supply sufficient current to not cause voltage sag at the Beagle).

  • Thanks for fast response!
    I don't have the SD card inserted, only during software installation.
    The "back-and-forth" is shown when installing software
    When booting, after sw installation, I think LED2 and LED3 are showing activity.
    I will do a fresh install once more, and I will check the power supply. I will return with more infor later.

    Karl Jan
  • Yes, during normal activity LED0 should be doing the "double flash" on a regular basis. LED2 will be on almost solid when the Kiwi server is running because it takes virtually 100% of the CPU. And LED3 will flash as the filesystem is needed. The patterns will be different during Debian startup of course.

  • New fresh install, automatic powered down. Removed SD-card and connected power again - same result as previous.
    When starting after installastion, all leds are light for some seconds and then led3/led0 indicates activity. After some time, LED0 shows hearbeats. The KiwiSDR does not show up in the DHCP lesae-list on the DHCP server :-(
    The powersupply is working ok, almost no ripple and no spikes.

    Karl Jan
  • jksjks
    edited November 2016
    From a browser on a machine on the same local network as the Kiwi, try looking for it with the scanner:
    You should run the scanner a couple of times as it doesn't always find the Kiwi on the first try.

  • I will, first "task" tomorrow morning :-)
  • I have used the scanner looking for the kiwiSDR - without any luck :-(, yes I have tried it many, many times.
    As mentioned before, I cannot find any request for an IP address in the DHCP server, and I suppose that's a problem when trying to scan for it.
    The RJ45 socket on the BeagleBone has two LEDs, are these programmed to show Link/Activity on the network when connected to a switch? These LEDs are dark, except for one very short flash (in the green one) during bootsequence.

    There is also no lights in the Link and Activity LEDs on the switch.

    I have tried to capture packets with Wireshark, and it seems that the BeagleBone is not sending anything to the network. I suppose I have to connect to the console port. What levels can be applied to the console port? Can I use an USB dongle with a Prolific PL2303 - 5V or do I have to find one handling 3.3V?

    I have been looking for an image-fil to make a new SD-card bootable and with the required software, but couldn't find. I only find how to do it with a BeagleBone. I'm stuck in Windows and hoped to find such an image-file. Is it available somwhere? I'm familiar with making these for Raspberry Pi, and I suppose I could do the same with a SD-card if I have the complete image-file.

    Best regards
    Karl Jan
  • jksjks
    edited November 2016
    Okay, so there is an Ethernet problem on the Beagle. You should have link lights (yellow and green) for sure soon after booting and they should stay on. Same on the switch. Your Kiwi worked fine earlier, correct?

    Yes, there is a Kiwi .img file that you can write to an sd card using the same procedure you use on Windows to make bootable sd cards for the Pi. We don't use Windows here so can't be more specific. We have used something called "Pi Filler" on our Mac to do the same thing.

    It's a 225 MB file compressed with XZ. The SHA256 checksum is: 59efbe9d880a328c2971d9db4ac305889bc1f2f09defe5ae73791ce805dd6337
    After downloading, on Windows use something like 7-Zip to decompress it to the .img file.
    Then write the .img file to an sd card.

    If you can't get this to work on Windows, but have another Beagle that works, then you can write the sd card using the Beagle as discussed on the quick start page:

Sign In or Register to comment.