Kiwi 1 won't update to Debian11 [fixed]

Hello, i tried to update my kiwi 1 BB/GB but still no luck. I have made the backup on a 64gb sd card. I downloaded the image and burned into a sdcard and other sd cards from 4 gb up to 64 gb.

Put it in the Kiwi 1 but it won't boot, everytime i get 1 flashing light.

Question: Why it won't boot, because when i put back the backup sd card it boots normally .

How can i see if i have the 2gb version instead of the 4gb version that would explain that it won't boot with the new Debian.

Hope there is an explanation.

(already posted this question in other discussion but i think that was wrong, hope te get a answer)


  • jksjks
    edited May 20

    First, there is no way you have a 2GB (eMMC) Beagle unless it's a BeagleBone Black you bought yourself back in 2014-2016. All "rev C" BeagleBone Blacks were 4GB and all BeagleBone Greens were 4GB. No Kiwi was ever sold with a 2GB Beagle since we only ever sold using BBGs.

    What do you mean "because when i put back the backup sd card it boots normally"?

    Do you mean if you make a backup sd card on the Kiwi-1, and then re-flash the Kiwi-1 with it, the re-flash works? It's only when you put the Debian 11 image on the sd card (downloaded from the website) that it won't re-flash the Kiwi-1?

    Are you holding down the boot button prior to applying power like the instructions mention? If the eMMC on the Beagle doesn't have the latest version of uboot then holding down the Beagle boot button is required to force the copy of uboot on the sd card to get copied to the eMMC on the Beagle. You only have to do this once when upgrading from an eMMC that has Debian 8 to a later Debian version.

  • edited May 20

    @jks Hello, thanks for answer, indeed i have made a backup of the Kiwi 1 according the manual. This sd card boots normally when i reflash the backup back. The everything works normal again.

    the image Debian 11 i write on sd card and i hold the boot button when i powerup. But sadly one blue light blinks and nothings happens further. after a few minutes the blinking stops. So i thougth i have a 2gb version.

  • Well, there must be something you're doing wrong in transferring the .img file to the sd card. Are you certain you followed all the instructions precisely? You decompressed the 756 MB .img.xz file to create the 3 GB .img file? And then used a program to copy the .img file to the sd card?

  • @tamasp How did you write the image to the SD card?

  • @jks @HB9TMC Hello Friends, i use a windows 11 laptop with RaspBerry PI imager and or BalenaEtcher, the image is 3 gb with and of course i use different sd cards. I think indeed there is a problem that it wont write the boot sector good. Could it have to do with windows 11.

  • The other possibility is to use the Kiwi-1 itself (running Debian 8) to create the Debian 11 re-flasher card (instead of using the Windows 11 PC).

    Follow the different set of instructions on Use the Kiwi admin page "console" tab or an ssh/PuTTY connection directly to a Linux shell on the Beagle. Check for there being enough free disk space: Yellow "disk free" button on the console tab, or type the "d." (dee dot) shell command. Look for at least 800M in the "Avail" column.

    Then type the "wget ..." command as shown in the instructions. Run the script as shown "bash ..." and follow the script directions.

  • edited May 21

    @jks Hello, after a while i realize that it could be that the beagle has not enough power, because i have a defect power on the Kiwi board ( the CMC is broken off by attempt to repair) so i dont know how to make a bridge at the moment. I took of the Kiwi board and then the update goes in progress. After the update i assembled the Kiwi board again and now it is starting with Debian 11.9. Thanks for helping.

  • Okay. Glad you got it working. Like I've said so many times, power issues are the root cause of many Kiwi problems. There will be much more attention paid to this design issue with future products.

Sign In or Register to comment.