v1.674 [ongoing issues with integrated antenna switch]

From the CHANGE_LOG file:

v1.674 April 24, 2024

  Antenna switch:

    Antenna selection specified in the DX label extensions field now works correctly.

    It is also possible to specify an antenna selection and an extension together, e.g.

    "ant,1&wspr,30m" "FT8,*&ant=loop" etc. Just as you would in a URL.

    "ant," and "ant=" are equivalent.

  WSPR extension now uses the same mechanism to upload wsprnet.org spots as WSPR autorun.

  This means the admin page, WSPR tab "Log spot debug info?" option works for both the extension

  and auto run modes. Unfortunately wsprnet.org doesn't seem to be currently sending any spot

  upload diagnostic information as it has done in the past.


  Admin config tab:

    RF attn slider is disabled for KiwiSDR 1 systems. This prevents the "Attn" annunciator from

    incorrectly appearing in the S-meter.


  • Hi John, I tested my ms_s7_web switch under v1.673 and now v1.674 but couldn't get it to work.

    I noted the new configuration possibility under 'Extensions' in the Admin interface,

    filled in the IP address of the switch and ticked some boxes - but nothing happens.

    Do I need to configure anything (backend etc.) through the console?

    No antenna can be selected or deselected - mixing ant 1,3+7 occurs at random

    Some screenshots attached.



  • edited April 24

    I don't know why it isn't working for you, but just a few observations. For the NC antennas (presumably means 'Not Connected') just omit any description and the buttons won't display, leaving just the actual antennas. Having 5 antennas with the same descriptor could cause issues. Why have you got the option of 'High side injection' ticked for Antenna 1? That is for frequency converters.

  • Hi Kai,

    I was not able to test with an actual ms-s7, so it's possible there's a bug in the backend script changes I had to make. Is it possible for me to connect as admin to your Kiwi? It would have to be Internet accessible. We can place it on the proxy service if necessary.

    Please email details to support@kiwisdr.com

    Thank you

  • Hi Barney, thanks for leaving a comment.

    I deleted all the 'nc' entries and deselected 'high side injection'

    but with no effect - ant 1,3+7 are still displayed as mixed.

    I sent John a mail.



  • edited April 25

    same problem here with kmtronics switch, no switching possible.

    When i connect to the switch directly with browser, i'm able to access it and switch.

    But from kiwiconsole unsuccesfull.

  • @on4iq It would be interesting to know if using the antenna switch scripts directly works or not.

    Something like:

    cda (change to dir /root/Beagle_SDR_GPS/pkgs/ant_switch)

    abi (alias for "./ant-switch-frontend bi" printing the backend information)

    as (get antenna status)

    a1 (switch to antenna 1)


  • Hi ON4IQ,

    also for my ms-s7, i can access it directly via the browser.

    Let's see what evolves...



  • edited April 25

    from console no switching possible

    CONSOLE: open connection
    root@kiwisdr:~/Beagle_SDR_GPS# cda 
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# abi
    kmtronic v2.0 8ch mix
    More info: https://github.com/OH1KK/KiwiSDR-antenna-switch-extension/blob/master/docs/ant-switch-backend-kmtronic.txt
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: g
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# a1
    Selected antennas: g
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: g
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# ^C
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# ^C

    via webbrowser from PC i'm able to switch, but not from the kiwi.

    Looks like kiwi frozen in G status (grounded i presume)

  • @on4iq Okay. If possible I would very much like to be able to connect to your Kiwi as admin and see if I can fix the problem. Please email details to support@kiwisdr.com Thank you.

  • ok mailed, and i cfm that the kiwi send G string to webswitch, just tried it

    via webbrowser i actived the relay

    via kiwi I selected an antenna and relays switch off

  • Thanks, checking now..

  • Thank you for your efforts !

    Very happy to see the possibility to control antenna switching without having to open another window.

    But I am missing the :


    Where I had all antennas grounded after a minute the last user left.

    When I from the browser try to ground the antennas:


    The logic is inversed and all antennas are switched in (mixing allowed)

    the same if I try "tg"

    I don´t now if it is firefox but i can not deselect an antenna i have to choose another also...

    So there are some gremlins in the code yet ;-)

    73:s de Kenneth / SM0OHC

  • jksjks
    edited May 13

    Important information missing in the above post.

    Which antenna switch device? None of the logic for grounding antennas was changed in any of the scripts. Does your antenna device ground any antenna that is not selected? Such that the correct action is to not select any antennas in the grounded condition?

    The "reset-to-default-antennas-when-no-users-online" script was removed because there is an equivalent option in the admin interface now: The switch that says "Switch to default antenna when no users are connected?". With "Default antenna" checkboxes added to each of the antenna description entries below.

    The problem with that of course is that there is no "Default antenna" option of "ground". So I need to add that. There is only the manual "Enable thunderstorm mode?" switch which does you no good in this case.

  • edited May 15

    Thanks for reply !

    I use the Arduino version, and the kiwi autoupdates, so now release v1.680.

    A suggestion is to have "default antenna" ground when no user as a tickbox, as you said.

    You can take a look at "ohc.zapto.org" how it behaves with the present settings:

    Deny antenna mixing? NO

    Deny multiuser switching? NO

    Enable thunderstorm mode? NO

    Switch to default antenna when no users connected? YES (no antenna ticked)

    I can switch antennas but selected or unselected antenna is not indicated

    If "Deny antenna mixing?" is set to YES I got a "green" but can´t unselect, and if another is selected that switches in ok but it does not unselect the previous and does not indicate that two antennas are:

    And with that setting eventually all antennas is set no matter what you do.

    73:s / K.

  • Good timing. Just moments ago I made that exact change: If none of the "Default antenna" checkboxes are ticked, and the "Switch to default antenna ..." is set to "Yes", then I now send the generic "ground all" command to the backend script. And the Arduino backend has an implementation for the "ground all" command. So hopefully it works.

    Will be in the next release (v1.681). Probably going out in 12 hours or so.

  • jksjks
    edited May 21

    Is there any followup to this? You folks that have antenna switches with a "set all antennas to ground" mode: Does that occur when "Switch to default antenna ..." is set to "Yes" and none of the "Default antenna" checkboxes are ticked? (and there are no user connections). You can verify this from a user connection or the antenna switch frontend script directly as follows.

    There are a number of new shell aliases that make it easier to run the frontend script. Bring up the Kiwi admin console tab. Type cda to go to the ~/Beagle_SDR_GPS/pkgs/ant_switch directory where the scripts now live. Type al | gr ant-switch to see all the aliases.

    So a1 to a9 and ag to select a specific antenna or ground all. as to see selected antenna(s). aa/ar to add/remove antennas from switches that support mixing. abi to see switch backend info. ah for help.

  • edited May 23

    Latest update to v1.682.

    Set to default and no antennas ticked seems to give ground as intended when the last user leaves !

    But still with deny mixing set to Yes, when switching from eg 3 to 1, antenna 3 is not unselected but only nr 1 is indicated, ie antennas mixed as in the last screensshot from my earlier msg. And the indicated selected do not take a deselect ie manually set to ground.

    With deny mix set NO you select and deselect but you do not get any "greens" but you have in text: selected antennas are now t1 but when toggling you don not have a visual other then the waterfall and of course audio.

    But in the example above the actual antenna is 3, still left from earlier selection

    It could be an idea to use the the maybe codewise more akward "1" or "-1" depending on after statuspoll and indicated flag green/no green rather than toggling ?

    As said earlier thank you for your efforts you are doing a fantastic job !!

    73:s de Kenneth / SM0OHC

  • What happens when you use the frontend script directly with the shell commands I mentioned earlier and completely factor out the Kiwi antenna switch interface? I am wondering if this is just a bug in the Arduino backend script.

  • edited June 9


    @jks I didn't notice earlier this thread and wrote about the same problem on another thread.

    I have same issues as SM0OHC described when using Arduino netshield.

    Tested with shell commands and all works fine so Arduino backend should be fine. Here are some commands I tired:

    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# abi
    arduino-netshield v2.0 8ch mix
    More info: https://github.com/OH1KK/KiwiSDR-antenna-switch-extension/blob/master/docs/ant-switch-backend-arduino-netshield.txt
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: 1,2,3,4,5,6,7,8
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# a1
    Selected antennas: 1
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# a4
    Selected antennas: 4
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: 4
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# aa 1
    Selected antennas: 1,4
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# aa 6
    Selected antennas: 1,4,6
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: 1,4,6
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# ar 4
    Selected antennas: 1,6
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: 1,6
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# ag
    Selected antennas: g
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: g
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: 1
    root@kiwisdr:~/Beagle_SDR_GPS/pkgs/ant_switch# as
    Selected antennas: 1,3

    Arduino sets gpios according received commands and replies status back. If I change antenna on Kiwi user page by typing as the status is corresponding. The problem is only when antenna mixing is enabled when you click any antenna selection all buttons will get white. However if you are clicking buttons commands are sent to arduino just status which antennas are selected isn't seen. If you reload the user page you will see the curent status until you don't change antenna.

    If mixing is disabled all works fine.

    If trying to select Beagle-gpio variant the above problem isn't present and works fine. Don't have others to try.

    Last problem is if you select to allow antenna mixing after Kiwi reboot the setting isn't saved. Returns to not allowed state.

    Sorry to write again mostly the same I did in another thread but better to have all in a single discussion...

    For me this problem isn't urgent since have still to make the switching hardware which will take some time 😃

    73 Andrej - S57RW

Sign In or Register to comment.