Filesystem is full! ["clean logs" button in v1.671 admin console tab]

One of my KIWI's is stuck at 1.664 and I get this message trying to force an update:

My other 3 have updated just fine. As usual, a search hasn't shed any light on this so it must be something wrong here?


  • Try reclaiming some log space using this command in the admin console:

    journalctl --vacuum-size=10M

    After that check the "Avail" column from the d. command.

  • The next release now has a new button in admin console (next to "disk free") called "clean logs" that will do this more easily.

  • Maybe it would be a good idea to limit the log file size (/etc/systemd/journald.conf)

  • Maybe. It begs the question of what value to choose. And if it's too low you just know someone would be unhappy if their WSPR/FT8/user-login information is getting deleted.

  • Well as usual nothing works for me. A friend checked on his KIWI and the command works fine. I even copied and pasted so to remove those errors. It doesn't work on another of my KIWIs either. I am on Debian 8.5.


  • @ve6jy Looks like you were typing journalct1 instead of journalctl

  • "ctl" as in "control".

  • That is ctl on my font, and it was copied/pasted from the guy who tried it on his system and it worked. But not here.

  • edited May 4

    A second KIWI (8175) has become full at v 1.671 and can't update. All are running the original Debian 8.5

    The first KIWI (8174) I mentioned in previous posts was reflashed from an older SD card and was able to update to 1.676. It has run for 12 hours and is at 81% full.

    Based on that success I attempted to reflash 8175 but nothing seemed to work. I left it running overnight and someone how it updated to v1.676 with 94% full. I tried to save the configuration but after multiple attempts, even with brand new cards, it said no SD card. This was with the original 4gb card and a new 32 gb card (32gb has worked on another KIWI here). I don't have an 8 or 16gb card to try. So if this one ever glitches again I won't be able to reflash it. Yes I know how to insert the card and it feels quite normal. I just finished doing this on the first KIWI a few hours earlier.

    Other cards I tried brought the no SD card error up far quicker, this one took over 8 minutes. Not sure if that is significant.

    The other SDR's are sitting at 81, 54 and 86 %. As shown above I cannot use the vacuum option to reduce the Usage%.

    So my question(s) are - why is there so much difference in %usage?

    All the KIWI's are configured very similarly. All are 8 ch mode. All are (now) at v1.676. All are running FT8 on preemptable ch 2-7. All are set to not log decodes. Only 1 doesn't have GPS connected. (it's at 86% and has updated fine).

    And how can I prevent them from filling up again?

    And is there anything I can do to make 8175 read the SD card again?

    Thanks for any advice....

    Don VE6JY

  • jksjks
    edited May 4

    journalctl: unrecognized option '--vacuum-size=10M'

    There's your problem. It seems that option is not available on the stock Debian 8.5 journalctl. But it is present if you do an update to 8.11 (I just tried it here).

    That other problem looks like a bad sd card to me. The card is found in the output of the lsblk command in the script (as mmcblk0). But later on the erase step fails. Just after that happens try using the dmesg command. At the end of the hundreds of messages that are shown will be messages if there are problems writing the sd card.

    Another thing you can do to analyze who is taking up space is to use the du. "du dot" and du aliases. du. prints how much the space is used in the current directory and du shows a sorted list of the size of each subdirectory. These aliases won't be available until after an update if you reflash using the factory sd card (Debian 8.5).

    root@kiwisdr:~# du

    4.0K build.log


    34M  kiwi.config

    107M build

    430M Beagle_SDR_GPS

    758M KiwiSDR_v1.665_BBG_BBB_Debian_11.9.img.xz

  • jksjks
    edited May 4

    So with Debian 8.5 you could go to the log directory and see if there is a problem:

    cd /var/log
    root@kiwisdr:/var/log# du
    4.0K	btmp
    4.0K	dmesg
    4.0K	ntpstats
    4.0K	syslog.2.gz
    4.0K	syslog.3.gz
    4.0K	syslog.4.gz
    4.0K	syslog.5.gz
    4.0K	syslog.6.gz
    12K	fsck
    12K	syslog.1
    16K	alternatives.log
    16K	debug.1
    16K	user.log
    24K	faillog
    28K	user.log.1
    32K	auth.log.1
    64K	auth.log
    68K	bootstrap.log
    84K	syslog.7.gz
    84K	wtmp
    92K	daemon.log.1
    112K	debug
    144K	apt
    252K	kern.log.1
    268K	messages.1
    288K	lastlog
    356K	dpkg.log
    928K	daemon.log
    1.8M	messages
    2.0M	kern.log
    2.9M	syslog

    Here the log files messages and syslog are only a couple MB in size.

Sign In or Register to comment.