The KiwiSDR 2 online store is open for orders! Please visit kiwisdr.nz

KiwiSDR failed after software update?

One of my KiwiSDRs seems to have stopped working after a software update about 10 days ago (yes, I just noticed it), the other four are fine.

I've tried ssh'ing in and doing a manual build with ./up several times, I don't see any errors, but I still can't connect via a browser, either to the normal KiwiSDR page or the admin page.

One thing I did notice, running ps -aux only shows the kiwid service running:

root   6865 97.3 5.9 135364 29760 ?    RL  12:41 15:55 /usr/local/bin/kiwid -use_spidev 1 -bg -v 1.665

While on a working KiwiSDR I also see kiwi.leds running, not sure if this is a clue or not:

root   32445 84.5 23.2 248004 117340 ?    DL  Mar11 24542:28 /usr/local/bin/kiwid -use_spidev 1 -bg -v 1.665

root   32462 0.0 8.4 169604 42608 ?    S  Mar11 18:24 kiwi.leds      -use_spidev 1 -bg -v 1.665


Any ideas? I haven't tried going back to an SD card install yet, still hoping I can recover without losing all the setup info.

Comments

  • edited March 31

    Well this was interesting... I restarted it several times from within the ssh shell connection, no luck. Then I tried shutting it down, cycling power, and it came up!

    Something I will remember (or try to) for the next time this happens. 😀

Sign In or Register to comment.