Problems setting static IP address [fixed in v1.666]

edited April 20 in KiwiSDR Discussion
This discussion was created from comments split from: KiwiSDR 2 shipping status.


  • edited March 5

    Received on time, as expected. Initial boot up, no problems.

    However, When I set to static IP as I have done with my 7 other KIWI,

    I have now lost the ability to connect to it.

    My network routing table does not show it even taking an address.

    Complete shutdown the kiwi, removed power, rebooted my router and flushed the cache.

    Cannot find it now.

    any suggestions welcome. Next step is ill connect to a laptop with a cat5, set laptop with an IP in the same range to see if it will ping the ip address i assigned to the kiwi.

  • jksjks
    edited March 5

    You must have made a mistake in entering the static address. Like an incorrect netmask or gateway. There's just no other explanation.

    Might be easier to just re-flash and start over.

  • Im fairly confident i didn't miss anything. i took a screenshot before I clicked the yellow banner, i also noted that now its only a 10 second cycle to switch to Static.

    I have now crated a flash from the instructions, completed after 5 and half minutes it powered down and it is still not taking an IP.

  • Re-flashed several times now and I cannot get it to take a new address.

    any suggestions?

  • Given the fact that you're the second one with a similar problem.. I wonder if you can change the IP address if you keep the default port.

  • I had an old BBG from another kiwi which i had switched out with a BBAI.

    I took the SD flash which i used to try to reflash the BBG provided with KiwiSDR2 and that flash worked with the old BBG.

    The old BBG defaulted back to DHCP and is currently updating to kiwi version 1.664.

    Once that completes, i will again try to set this BBG to Static IP. I will screen shot each step.

  • I do have the same problem. Got the Kiwi2, installed it and changed to static ip with port 8074. There was also public access to the SDR.

    After a reboot caused by a power outage i can not access the RX anymore. Not by the ip address or or It is simply not found anymore on the network not even by my ip scanner.

    Is there a way to reset it?

    73 de Roland, DF3LZ

  • I checked the blue led on the board. The code says that the Kiwi is in DHCP mode but the ip address has a problem ( can't really say if it is 32 times flashing as content or 16 times).

    What can i do to get access to the Kiiw again?

    73 de Roland,

  • jksjks
    edited April 14

    @DF3LZ If you were running a version prior to v1.666, and then changed to a static IP but left both the DNS fields blank, then the Ethernet becomes unusable (the static IP is not set correctly).

    Out of the box a Kiwi-2 runs a version prior to v1.666. And the automatic software update to the latest version (currently v1.667) does not happen until the first overnight update period.

    About the only thing you can do at this point is download the distro image onto an SD card and re-flash the Kiwi. Then wait for the update or force the build manually (admin page, update tab) before you switch to a static IP.

    Instructions for re-flashing are here:

    The post describing the problem is here:

  • Thanks for your reply. Which version of Debian 11 i have to download? I am not familar with the typ of OS.

  • jksjks
    edited April 14

    Please read the instructions I referenced. You don't download a generic Debian 11. You have to download a specific image for the Kiwi/Beagle from the website that has everything pre-configured and customized:

  • My kiwi is online again. Thanks for your help. Lets see if it will stay stable until tomorrow.

  • jksjks
    edited April 15

    It should be okay. This was a very unfortunate bug with Debian 11. Apologies for the trouble.

Sign In or Register to comment.