The KiwiSDR 2 online store is open for orders! Please visit kiwisdr.nz
Today's v1.694 update is hopefully a working version of the failed v1.691,692 release of a few days ago.
See the first post of the "v1.694" thread below for the CHANGE_LOG notes.
Please visit kiwisdr.com (documentation) and kiwisdr.nz (online store)

Automatic add of NAT rule on firewall / router: no device found [fixed]

I have two kiwi's running as follows:

  • Unit #1 is ethernet connected to the router and passes on the NETWORK 'tab' test ===> Check if your external router port is open: Both respond yes
  • Unit #2 connects wirelessly through a GL-MT300N-V2 wireless module to the same router used by unit #1 above BUT fails the NETWORK test ===> Check if your external router port is open: the first address responds NO and the second responds YES. The kiwi NETWORK tab page test result says check DNS

Here is a screen capture of the router 'port' stuff ===>

where the "YT1" is the wireless device associated with the Kiwi Unit #2

The second 'address' is the same one used by Kiwi Unit #1

What am I missing in the setup?


Dick/w7wkr

«1

Comments

  • The second kiwi will need its own (external) port, for example 8074.

    I'm surprised that the router would let you assign two devices to one port.

  • Hello


    Thank you for the suggestion. I will try it and see if it works.


    73 Dick/w7wk at CN97uj

  • HB9TMC


    I tried your suggestion and at the NETWORK "Tab" ===>

    changed the 8073 for the two ports to 8074 and restarted the device.

    NOTE: The screen capture displayed above was taken from the kiwi that still works.


    One minute later discovered I can NOT connect to the device any more! Now, I have managed to "basically" make my 2nd kiwi a 'brick'.


    The device still shows up on my router as a wirelessly-connected device. Something with the

    8073-to-8074 change has me locked-out.


    What do I do now to access the device?


    Dick/w7wkr

  • jksjks
    edited March 1

    For the second Kiwi you'll have to now connect to it on port 8074

    whatever:8074 and whatever:8074/admin

    versus whatever:8073 for your first Kiwi.

    This assumes you're connecting from the same local network as the two Kiwis.

    If that works now you can change your router mapping so they are both separately accessible from the Internet:

    public_IP:8073 => local_IP_Kiwi1:8073

    public_IP:8074 => local_IP_Kiwi2:8074

    Note that since local_IP_Kiwi1 is different from local_IP_Kiwi2 that is sufficient to differentiate them. So you could have given them both a local port number of 8073. That's why the Kiwi admin network tab has values for both internal and external port number (so they could potentially be different).

    I.e. a mapping of:

    public_IP:8073 => local_IP_Kiwi1:8073

    public_IP:8074 => local_IP_Kiwi2:8073 (note 8073 vs 8074 above)

    (the public port number must always be unique since the public IP is the same in both cases)

    But sometimes it's easier just to give them distinct port numbers.

  • jksjks
    edited March 1

    One last question. You said your second Kiwi is using a Mango wireless module. Does its local subnet match the subnet of the wired (or wireless) network the computer running the browser is using? I.e. both subnets are 192.168.1.xxx or 10.0.1.xxx or similar.

  • Hello JKS !

    I have tried to connect to my second kiwi after changing the two "8073" ports on the kiwi admin 'network-tab'.

    then after entering 10.0.0.120:8074


    the system times out. I can not access my kiwi after making the changes.


    Is there another way to access the device and look at the 'Network Tab' again? I THOUGHT the two changes were correctly made but I may have made a typing entry error and 'saw' what I

    'wanted' to see.


    In any event, I now have a brick.


    Dick/w7wkr

  • Visit my.kiwisdr.com and clear any entries there with the clear button.

    Restart the second Kiwi (unfortunately by pulling the power and reconnecting).

    Wait a minute or so, maybe two. See if a new entry appears on my.kiwisdr.com If you get one you should be able to click the link ending in /admin to get to the admin page.

  • jksjks
    edited March 1

    When I connect to your public IP address, port 8073, the browser tab says "w7wkr-k2". Is that the "second" Kiwi or the "first"? (i.e. is the first Kiwi an older Kiwi-1 or something). I get no response on port 8074.

    I don't see anything in the my.kiwisdr.com database for either of your Kiwis. Which is strange. Unless you specifically disabled that feature they should show up.

  • Hello again


    OK, I cycled the power to the kiwi and waited for it to start blinking-out an address.


    The address is 192.168.8.154


    So I entered 192.168.8.154:8074 and the system timed-out.


    I tried using the my.kiwisdr.com and received this response ===>

    ========================================

    ========================================

    The connections to both kiwi's is thru a smart switch connected to the house router through an ethernet cable.


    The working kiwi blinks-out 10.0.0.110 and responds to 10.0.0.110:8073 while the 'non responsive' one blinks-out 192.168.8.154 when power-cycled and connected to the smart-switch. It does not respond to 192.168.8.154:8074


    Getting no-where slowly.


    Dick/w7wkr

  • Let's try something simple. Connect to the .110 Kiwi, admin page console tab. Then type ping 192.168.8.154 (ping doesn't care about port numbers). Does it show a response? Type control-C to stop the ping.

    If the ping works, try ssh debian@192.168.8.154 and use the .154 Kiwi's serial number as the debian account password when it asks. If it asks something about a fingerprint say yes.

    If that works use these commands on the .154 Kiwi:

    cdk

    ja

    You'll see a whole bunch of configuration values. But the ones you're interested in are:

      "port": 8073,

      "port_ext": 8073,

    Those are the two values you set on the admin network tab for internal and external port number.

  • OK, I tried this ===>

    ===============================================

    sshdebian@19===============================================

    so it looks like this failed

    I will be away from the keyboard for TWO days so will read replies on Sunday - Thanks



    Dick/w7wkr

  • This makes no sense. You typed the ping command, it showed the correct IP address it was going to use, and then nothing? No success or failure messages like the output from your other ping commands show? Did you not copy/paste all the output? This doesn't tell us anything!

  • @jks when i ping an IP with no route, i also get no error until i press ctrl-c.

    But it's weird, 192.168.8.0/24 would be the BBG/BBB default network for SoftAp. Where does that come from? That doesn't make sense.

    Since the kiwi it's new, it's probably the easiest to load a fresh image and try again ...

  • jksjks
    edited March 1

    Well, that was one of my questions that was unanswered. Why are there two different subnets involved? My wireless bridge here maintains the same subnet across the bridge. Like it maps by MAC address or something.

    And it worked before, right? So subnet routing must have worked at some point.

    Maybe the Mango device is no longer bridging? What a mess..

  • Hello again folks - finally back home from visit to Seattle.


    The kiwi I had been using with the admin-page 'network' tab set to 8073 has been working for years. When I checked to see if the remote access address ports were working and found both responded NO, it was suggested I change the two entries of "8073" to "8074" and add that info to my main ROUTER port to allow remote access.


    I made the two changes to 8074 and was instructed to restart the kiwi for the changes to be set.


    Since then it is not possible to access that kiwi. It is presently blinking-out 192.168.8.153. Prior

    to the change this kiwi had been responding to 10.0.0.120:8073 AND showed up at that address on the router's "connected" devices when relayed THROUGH a portable "GL" wireless device.


    jks - to answer your question, YES, I screen-captured everything that the PING command started.


    Dick/w7wkr

  • Does the LED on the ethernet port still light up?

  • jksjks
    edited March 3

    Okay, so this entire problem has to do with the Mango device (or possibly something else) changing the subnet that Kiwi is on from 10.0.0.xxx to 192.168.8.xxx. And now that 192 subnet is unreachable from your main 10.0.0.xxx subnet on the "other side" of the Mango (wireless side).

    This is likely because the Mango is no longer acting as a transparent bridge (or whatever it's called). Can you remove it from the picture temporarily and wire that Kiwi with an Ethernet cable directly into your router? Once you get that working you can try and figure out why the Mango is misbehaving.

    Simply changing the Kiwi internal/external port from 8073 to 8074 has absolutely nothing to do with the subnet getting changed.

  • OK, I should have described the configuration more clearly ---


    At the present time the kiwi blinking-out address 192.168.8.154 is directly connected to a smart-switch and house router via ethernet connections. It is presently DISCONNECTED from a GPS 'puck' and has no GPS input due to physical location inside my house/


    The 'working' kiwi responds to 10.0.0.110:8073 on the same smart-switch/router network and is reporting decodes OK.


    Where do I go from here?


    Dick/w7wkr

  • jksjks
    edited March 3

    Your "smart switch" is horribly misconfigured. Both Kiwis need to be on the 10.xxx subnet.

    Try another Ethernet port on the switch.

  • OH,, regarding the LED's on the ethernet port the one on the right side is OFF and the one on the left side is blinking.


    Dick/w7wkr

  • jks


    OK, I tried to ping '192.168.8.154' using a different smart-switch port and new ethernet cable

    and got the same results - NO contact.


    Next I connected the kiwi to a DELL E6510 laptop (used daily to run an ANAN-7000dle)

    and used a command-line 'ping' 192.168.8.154 and got the same result - no contact with the

    kiwi.


    Now what to do ??


    Dick/w7wkr

  • jksjks
    edited March 4

    You need to figure out who is handing out 192.168.x.x addresses to the Kiwi and why.

    The only other possibility is that the Kiwi has somehow flipped from DHCP automatic IP assignment to static IP assignment and that 192.x address was the last static IP configured. I have no idea why any of that could have occurred.

    But since you can't connect to it you can't see if that's the case. About all you can do at this point, if you can't figure out the DHCP issue, is to start over by re-flashing the Kiwi. Instructions in the online documentation..

  • One last idea: You could use a laptop or other device, assign a 192.168.8.x address manually to it, and connect it directly to the kiwi.

    But without explanation why the kiwi has a 192.168.8.x address it's hard to say if this will work.

  • Good morning to JKS and HB9TMC


    Here is a detailed history of the kiwi with the problem:


    1 - When I bought it years ago it was used by connecting it directly to a DELL E6510 laptop using an ethernet cable to connect to it at 192.168.8.154:8073 and wirelessly to the internet via the DELL wi-fi link to the house router

    2 - Then I wanted to use it remotely in a quiet QTH away from local man-made noise

    3 - Bought a portable wi-fi module and connected the kiwi to the module

    4 - I wanted to connect to the kiwi remotely at the quiet QTH through a Starlink satellite system

    5 - KG7RDR set up the routers at my CN97 and CN98 QTH's to have identical 10.x.y.z addresses with port forwarding to allow the portable kiwi to be accessed by the resident router. This required him to change the kiwi addresses in both kiwi's from 192.168.X.Y to one that worked in the 10.x.y.z:8073 range

    6 - Finally, after having both kiwi;s working locally at addresses ===>

    kiwi-1 at 10.0.0.110:8073

    kiwi-2 at 10.0.0.120:8073

    neither could be to remotely because both responded "NO" to the Check if your external router port is open: test on the kiwi NETWORK TAB, so I set the router to accommodate remote access and tried to connect to both devices

    7 - I was able to connect to kiwi-1 at 10.0.0.110:8073 but not to the kiwi-2 unit

    8 - It was suggested I change the port number on kiwi-2 to 8074 from the initial 8073 settings (screen capture shown below is from the kiwi-1 network-tab screen)

    so, on its NETWORK page I entered 8074 in both places and restarted the kiwi. 60-seconds later the kiwi was unresponsive

    9 - At this point kiwi-2 is DEAD in that it will not respond to the address it is now 'blinking-out'


    So, you suggest I install the micro-memory card into the dead kiwi to install original SW - is this correct ?


    Dick/w7wkr

  • The simple way is to reflash the kiwi, but you can try to recover it:


    So that old 192.168.8.152 address is still lingering around somewhere on the kiwi and for whatever reason, the port change reactivated it.

    It will not respond to that address, because 10.0.x.x is a different subnet with no route to the 192.168.8.x subnet.

    The host from which you connect to this kiwi does need to have a 192.168.8.x address too, to be able to connect to the kiwi.

    So you would need to change the IP from your PC or laptop to 192.168.8.10 for example, and connect it directly to the kiwi. Then you should be able to connect to the kiwi and try to fix the issue.

  • jksjks
    edited March 4

    Okay, so there was more to this story. When you guys don't tell me the whole story at the outset we go round and round with the post and emails before getting to the heart of the matter. Makes it very difficult for me.

    So a static 192.168.x IP was configured at some point with the direct connection to the laptop. And somehow it's been reactivated again keeping the Kiwi from communicating with the 10.x network it's now connected to.

    At this point I would just re-flash given that you have the original flasher sd card. This will put the Kiwi Ethernet back into DHCP IP assignment mode. After re-flashing the Kiwi will do a network update. This update (from v1.2 to v1.664) will take a very long time. Over an hour. So don't interrupt it otherwise you'll have to start all over again.

  • JKs and HB9TMC


    OK, sorry about not including the baby-steps taken to get the kiwi to the 10.0.0.120:8073 address.

    I will use the original micro-memory card and start over. and let it 'get smart' all over again

    WITHOUT interrupting the process.


    Thank you for your TIME and suggestions.


    73 Dick/w7wkr

  • I have misplaced the microSD card. I see it is possible to make a back-up file on a microSD card from a functional kiwiSDR.


    I have formatted a card and can insert it in the functioning kiwi.. Do I power-down the kiwi and then insert the blank card and power-up the unit


    OR


    Insert the microSD card into a running kiwi?


    Dick/w7wkr

  • jksjks
    edited March 4

    You might be in for a bad time depending on your experience level. Follow these instructions using the "Linux" sub-section on your other Kiwi using the admin console tab.

    Someone else needs to take over here please. I have to get back to working on the next release and my mountain of emails..

  • Greetings EVERYONE !!


    After a tremendous amount of support from "JKS" and HB9TMV, I have been able to restore a kiwi that refused to respond to access efforts.

    After examining ===> http://kiwisdr.com/quickstart/#id-net-reflash I was uncertain about

    my ability to successfully perform the steps needed to install new software (am I debian 9 or 11, etc or ??) so opted to try downloading SW from a working kiwi.


    I formatted a microSD card and downloaded the SW. After more reading of the above website information, successfully installed the SW on the 'unresponsive' kiwi. It is now working.

    Now, for whatever reason and related to my original problem of getting to "YES", the response to ===>

    BOTH kiwi's now respond YES without my having made any changes to the main router after the original effort to change port numbers to 8074 on one kiwi. Both kiwi's are using 8073 successfully now.


    I want to thank the kiwi-community for service beyond what I deserved !! Net result is I learned a LOT and am now more comfortable 'messing with' software.


    73 Dick/w7wkr

Sign In or Register to comment.