The KiwiSDR 2 online store is open for orders! Please visit kiwisdr.nz
Today's v1.694 update is hopefully a working version of the failed v1.691,692 release of a few days ago.
See the first post of the "v1.694" thread below for the CHANGE_LOG notes.
Please visit kiwisdr.com (documentation) and kiwisdr.nz (online store)

v1.652 problem updating [READ 10TH MESSAGE FOR FIX]

I tried to update one of my kiwis that had been at v 1.622. It started the update, I was monitoring in the console tab, but when it restarted it would not return back online. I waited about 40 minutes and manually power cycled.

It is still not reachable via web interface. I can however putty into it. It is a BBAI.

Any suggestion on how to restore?


Regards,

Tom

Comments

  • edited January 7

    same for me with 2 of my 4 AI based systems (edit: only my 14ch ones)

  • Updating a BBG based Kiwi went without problems. In order to check if v1.652 fixes the TDoA current problem perhaps the hosts running this versions could be included as well to the TDoA map in addition to the pre-v1.647 hosts currently shown.

    best regards, Ben

  • jksjks
    edited January 7

    @benson v1.652 won't work that way for TDoA. It has special tunable parameters that only I will be able to use. So adding it to the current pre-v1.647 list of TDoA hosts won't help.

  • @jks I see anyway thanks for the quick reply and your work on this.

  • Well, I don't know. Compiles and works fine on a BBAI here using Debian 9.13 (also BBG, BBAI-64). The changes were pretty trivial.

    Let me know here what mode you run your BBAI in. rx4? rx8? rx14?

    Someone please email ssh login details to support@kiwisdr.com so I can sort this out please.

  • Oops, never mind. There's a problem with rx14 mode.

    Hang on..

  • Remote access information sent.

  • with both my AI 14ch hosed up, I'm going to take the opportunity to upgrade the Debian version. Is there an image that I can download that is known to work. I don't expect that image to contain kiwi code too but that would be a bonus!

  • jksjks
    edited January 7

    Okay, here's how you can fix this problem which only occurs on systems running in rx14 mode.

    You'll need to ssh/PuTTY into Debian running on your BBAI/BBAI-64. If you don't know how to do that send an email to support@kiwisdr.com and I'll try and talk you through it.

    Type these commands. Even as the Kiwi server is starting and crashing in a loop as it should be doing. Be extremely careful to get the sed command correct. Watch the single and double quotes carefully.

    DON'T GET THIS WRONG.

    cdk

    sed -i -e 's/"firmware_sel": 3/"firmware_sel": 0/' admin.json

    After this, and waiting for a few moments, you should be able to get a Kiwi admin connection. Now go to the control tab and click the restart button to force an update to v1.653 (assuming you have automatic updates enabled, click build now on the update tab if not).

    After the build completes, and you can connect as admin again, select rx14 on the mode tab and restart.

  • @WA2ZKD Don't bother. In a few weeks I'm going to have a new Debian 12 platform for all the Beagle platforms.

  • edited January 7

    @jks I have all 4 kiwis phyically disconnected right so would be happy just to get the 2 bad actors fixed. I had a password issue with one so thus the offline. As you may recall, I have mine in one X4 structure

  • actually all I really need to do is overcome my lost password... and do the procedure above

Sign In or Register to comment.