Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (,

Please visit (documentation) and (online store)

v1.649: Long-standing adjacent channel aliasing problem finally fixed

I'd like to thank @Christoph for finding a way to implement the CIC compensation filters (FIR) given the very limited FPGA resources we have. Please see

From the CHANGE_LOG file:

v1.647,648 January 2, 2024

  Finally fixed the long-standing problem with adjacent channel aliasing into the passband.

  Fixed with Christoph's addition of FPGA CIC compensation filtering which you can read about here:

  See Kiwi forum for further discussion.


  Updated HFDL system table to version 52.



    edited January 2

    We are having some problems with v1.647 here. It may be the cold weather also, -23 below zero outside and unheated cabin. One user is ok. Two users and waterfall goes black and audio disappears. Same problem with two KiwiSDRs here in Finland this morning.

    Would you think the cold, below -10 in the cabin would have that affect?


  • Tested some other KiwiSDRs here in Finland with same firmware. None of them had any waterfall and sound issues with two or more users. So...maybe it is the cold temperature.

  • I have also seen short audio drops 1-1.5sec on my KiwiSDR ( But only when all 4 users are active. My KiwiSDR is standing in +23.

  • edited January 2

    I have also intermittently black waterfall and audio drop outs on a full WF channel.

    8 channel config, with 3 waterfall users. The drop outs appears to happen less often and shorter, if i close the AF waterfall user.

    Another thing: I think that the RF signal levels are showing to be a few dB lower now with this update. I don't know if that's an issue though.

  • edited January 2

    I'm seeing the same problem with v1.467. One user is OK, but when a second user arrives RX0 sees a black WF and audio muting for several seconds at a time. Seen this on two Kiwis here. 4WF config.

  • Unfortunately the same here.

  • The amplitude reporting, S-meter and dBm field, do seem to be several dB down from previous code. I just checked and found this to be true on both noise and coherent signals so I doubt there's a substantive SNR change.

  • I'd agree the new filtering has improved the general performance, but I think it has also messed up some other unintended functions, SNR reporting and maybe TDoA too, but I haven't been able to confirm the latter.

  • Well, I guess this was predictable. We didn't see this in all our testing. But it's possible the additional delay of the FIR filtering is somehow causing a problem with the realtime response. Although a calculation of the timing was done and it didn't seem to be a problem.

    Levels and TDoA: I was actually wondering about this as I was falling asleep yesterday. Adding an FIR can change the overall gain (up or down). So the filter probably needs to be re-scaled to match the previous response.

    In the past when we've changed the passband filtering on the Beagle side we had to measure the audio path delay to recalibrate TDoA. Maybe that needs to be done again.

  • The problem occurs only in the 1st channel (RX0) and unfortunately I cannot reproduce it in my setup.

    Signal levels: the gain of the FIR filter is 1, so the change in levels comes from the fact that the 2nd CIC filter has half decimation rate w.r.t. before and therefore has less gain.

    TDoA should be fine, except when mixing a 14-channel KiwiSDR with any of the others (3,4,8-ch).

  • I'm also having problems with the "spec" noise filter not always working after update.


  • The dead audio/waterfall/SNR problem should be fixed in v1.648.

    We'll address the gain issue later.

  • Am afraid I pushed the wrong button. Instead of "build now", I hit "check now" first & it eventually came back with "Git clone damaged!"

    It was on 1.620 & I believe I didn't do anything wrong from admin console "re-clone sources", but it failed saying remote end hung up unexpectedly.

    As I've got the anti-Midas touch today, I reckon I should ask what I should be doing instead of merely trying again....

    73, VR2BG.

  • Is v1.648 only a rollback? So no FIR filtering?

    73, Pekka

  • jksjks
    edited January 3

    I just now deleted my previous comment. v1.648 fixes the silent/blank audio/waterfall problem. v1.649 should fix the signal level problem. The FIR filtering is present in both cases.

  • Oh, and I see now v1.649 also. 😊

    73, Pekka

  • @VR2BG Give the "re-clone sources" another try and see what happens. We've had trouble in the past with ISP's mucking with DNS lookups causing problems with access. If that is the case here I have something else you can try.

  • Okay, have tried several times.

    Cloning into 'Beagle_SDR_GPS'...

    remote: Enumerating objects: 37534, done.

    remote: Counting objects: 100% (37534/37534), done.

    remote: Compressing objects: 100% (9695/9695), done.

    error: RPC failed; result=18, HTTP code = 200MiB | 30.00 KiB/s   

    fatal: The remote end hung up unexpectedly

    fatal: early EOF

    fatal: index-pack failed

    It seems to be able to ping fine.

    Okay, what next?

    73, VR2BG.

  • I'm assuming this is your public, proxied Kiwi. If so, probably easiest if you set a different, temporary admin password and email to Then I can take a look directly and see what's up. Thanks.

  • Done. Tnx.

    73, VR2BG.

  • Are you subject to getting squashed by the great firewall? Because the transfer from is getting consistently, inexplicably shut down after 51% of the files transfer over. I've never seen anything like that.

    I could try zipping up a copy here and placing it on and moving it over from there. Not sure that would work but I don't know what else to try.

  • Nope, not aware of anything more than the occasional thing that gets the national insecurity coproaches' knickers into a twist, which if demands to remove go unheeded they have to get all ISPs to protect us from.

    I just see more & more websites refuse me presumably due to my IP. Nothing the other way around.

    73, VR2BG.

  • Ugh. Don't restart your Kiwi. I have a download running. But the estimated completion time is six hours. The file is compressed, but it's still 320 MB..

  • R

    73, VR2BG.

  • It's 21% done with 2:45 estimated remaining, so that's some improvement (you know how lousy these completion time estimates are, lol)

  • In better news, here's some evidence the v1.649 signal level fix may be working. graph of HB9VQQ/K Wsprdaemon 10m and 15m noise levels. You can see the 3 dB dive after the update to v1.647 and the recovery after updating to v1.649.

  • Opportunity to hoover out some computers & create a new bootable hard disk for one of them, so down time put to good use...

    73, VR2BG.

  • 75% done now. And I tested the scheme on a Kiwi I have here. It should work. At least to get you running v1.649. Hopefully updates after that.

  • I tried doing several TDoA's today on different KiWi's, but I keep on getting an Octave:index-out-of-bounds error.

    Not sure if this is related to the updates or some other problem.

    Anyone else seeing this ?



Sign In or Register to comment.