Second build has shipped. Message will appear here when store is ready for third build ordering.

Kiwisdr stopped working [fixed]

edited January 16 in Problems Now Fixed

Hi can anyone give me a hand?


I was using my kiwisdr for months, I unplugged it to do some cable managing and when plugged it back in it doesn't work.


I tried flashing it with the microsd card, putting the image file there and so forth but nothing.. it shows as connected to my superhub but when I check my.kiwisdr.com nothing shows there, I also noticed one of the blue lights is flashing on and off I think it is D1 or D2


Any help??

Comments

  • When you re-flashed from the sd card you got the documented "back-and forth" LED pattern for roughly 5 minutes ending with the Kiwi powering down?

    After you've re-flashed to software v1.2 on the original sd card, and the Kiwi has an Internet connection, an online update to the current software version will occur. This can take almost an hour.

    The problem here is that v1.2 doesn't have all the nice little features that were added over the years. Like my.kiwisdr.com, the special kiwi LED pattern showing the IP address, the build log file, etc. v1.2 dates from 2016.

    About all you can do is ssh into the Beagle e.g. "ssh root@kiwi-local-ip-address" or maybe "ssh root@kiwisdr.local" if your computer supports it (there is no root account password with v1.2). Then run "top -c" to view the build progress. You should see a process running called "/usr/local/bin/kiwid" and then other stuff running as the build progresses.

  • Yes I downloaded the debian 10 file and flashed that onto the sd card, then plugged it into the kiwi and it gave me the following lights and turned off after about 5 minutes.. that's the right file to flash right?

  • Okay, well it's slightly different if you downloaded the Debian 10 image (v1.486) onto an sd card instead of using the factory sd card that was in the original Kiwi shipping box (v1.2)

    v1.486 does have some of nice build monitoring tools. I tried a Debian 10 image re-flash here just now and it worked fine.

    After the re-flash the running system here did start an update. It did make an entry at my.kiwisdr.com. I was able to connect to the admin page, go to the console tab and type m blog to follow the build progress.

    I was also able to "ssh debian@kiwi-local-ip-address" and run "ht" (a better vertsion of "top -c") to monitor the build. Use the Kiwi serial number as the debian account password.

    You might just try the re-flash again and see if it works a second time.

  • I have tried flashing multiple times today to no avail, one time it showed up on my.kiwisdr but never again, have tried multiple sd cards so perhaps it is the flasher software I'm using to flash the image onto the sd card?

    Every time it shows up with an ip in my router settings but nothing else happens

  • jksjks
    edited December 2023

    You have to wait several minutes after powering up again (after the re-flash finishes) before the my.kiwisdr.com entry will appear. It takes that long for the server to start up.

    The one time it did appear did you try clicking on the link to take you to the admin page?

    What about trying the "ssh debian@kiwi-local-ip-address" from another computer. Did you try that?

    It is not a problem with the flasher software. I just downloaded it from kiwisdr.com and ran it exactly as the documentation describes and it works fine.

  • Hi again, I have tried using putty to access it and flashing with an sd card again and I'm not getting anywhere.


    Would you be able to remote into my computer if I sent you the details privately, perhaps you can see what is going wrong

  • Yes. Are you able to open a port on you router for ssh? (either port 22 or some other port number).

    If so, then please set that up and email your public ip address and the serial number of your Kiwi to support@kiwisdr.com (the Kiwi serial number will [likely] be the password for the Linux debian account).

    If your ISP blocks incoming connections though then this procedure may not work.

Sign In or Register to comment.