Second build has shipped. Message will appear here when store is ready for third build ordering.

Kiwi not appearing in the public lists [fixed with software update]

fbxfbx
edited December 2023 in Problems Now Fixed

Hi, following a crash+reconfig, I am not able anymore to have my Kiwi listed in http://kiwisdr.com/public/ , nor viewable in the TDoA map.

What can I do? The "public" tab says "rx.kiwisdr.com registration: successful"

My URL is http://88.163.155.169:18073

Thanks for any hint

Fabrizio F4VUK

Comments

  • Even though your Kiwi responds at that URL above, your Kiwi is telling kiwisdr.com that its URL is "http://http://tdoa.kiwisdr.com:18073" (note the double "http" and "tdoa"). So check the configuration on the admin connect tab and make sure the "check open port" button works on the network tab.

  • Thanks jks for the debugging info.


    This is my connect page, I can't see anything wrong with it, what do you think?


  • What does the network tab say when you use the "check open port" button? Show me the two URLs displayed next to that button.

    If it looks okay then restart your Beagle. See if that clears it up.

  • Here it is:


  • Well you changed something, because now the public registration URL is being received by kiwisdr.com as "http://:18073" Note the complete lack of a domain name or IP address.

    What did you change?

    There must be something you're not telling me about your network setup. It's also possible that this is related to you running v1.601. Please try and update to the latest version.

  • Also, why is the Kiwi's local IP address in the self-assign IP range? (169.254.x.x) Isn't there a DHCP server someplace to assign it a proper local-space IP address?

    I'm not sure what effect using a self-assigned IP for a public Kiwi has. I don't test for this case.


  • Uhm, I changed the URL to empty in the TDoA server settings. Apparently it's using this to register as its own address?

  • I don't understand. You changed that where? On the admin, extensions, TDoA page?

  • Extensions -> TDoA -> TDoA server URL

  • Well, maybe this is a bug in v1.601 we never caught. That changing the TDoA URL (which you should have no reason for doing) somehow clobbers the public registration URL.

    Please update to the latest version (v1.640) and let's see if this problem goes away.

  • So this is a bug with old versions of the code. It was fixed in v1.616 on 9 July 2023. I can't remember stuff going back that far..

    After updating to the latest version you may have to re-enter "http://tdoa.kiwisdr.com" in the "TDoA server URL" field on the TDoA tab. And then on the admin connect tab change the 5-item menu at the top to some other item, then back to the one you want.

    That should reset those two fields. The bug was that there was a namespace collision with those two fields prior to v1.616 that wasn't being handled correctly by the configuration code. You triggered the bug when you changed the TDoA server field (which most people never do).

  • Gosh, could it be that the upgrade fixed it?! I can see myself now

    Thank you very much for the help, man, and keep up with the good work, I love my Kiwi, it's an unique thing and an unique ecosystem

    Fabrizio F4VUK

  • jksjks
    edited December 2023

    Apologies for doubting you in the beginning. I just can't remember all the little problems that have occurred and been fixed along the way. I think this bug was originally uncovered because I had changed the TDoA server field for some reason (probably SSL testing) and noticed that my public registration broke.

Sign In or Register to comment.