Can't connect to admin

Greetings from a new kiwisdr user having just bought a second hand one. All is fine apart from the fact I can't connect to admin when I do I get a page just saying

No admin password set. Can only connect from same local network as Kiwi.

Client ip =

Simply how do I change the password ?


  • jksjks
    edited August 2023

    Is the Kiwi connected on the same local network as the computer/device you're running the browser on? For example, if the Kiwi is on Ethernet and your laptop is on WiFi do they both use the same 192.168.1.* subnet?

    Do you know the IP address of the Kiwi or are you connecting by a method that doesn't tell you that? (for example by using "kiwisdr.local:8073"). You can also go to the page "" and your Kiwi should be listed there with a link to it and the local IP address.

    Try doing a browser page reload or restart the Kiwi. Sometimes the Kiwi has trouble determining its local IP.

    The reason this check exists is that you don't want some random IP address from the Internet to be able to connect to the admin page if an admin password hasn't been set. But you obviously needed some way to get in from the local network. But the Kiwi requires it be the same local network as a security precaution.

  • Thanks... Doh that's all it was a simple reboot sorted it but now I need to add a port for public access is this right ?

  • There are a couple of issues to consider in making your Kiwi publicly available. The website documentation discusses all this.

    First, you need to know if your ISP blocks incoming connection setup. This is generally true for residential ISPs, but it varies. Then you need to know if your public IP address gets changed periodically by the ISP. If it does then there is an extra step you must take to get around that issue. Usually you have to just setup the Kiwi and see if these issues are going to be a problem or not.

    Second, your router needs to be configured to map port 8073 from your public IP to port 8073 of the local IP of the Kiwi. If you don't know how to change the NAT port mapping on your router then on the Kiwi go to the admin page, network tab, and set Auto add NAT rule to firewall/router? to Yes. If you get a green confirmation message then it worked. If not then if you know how to get into your router try and find a setting that enables UPnP. Then try the Auto add... again.

    On the admin network tab you can use the button Check port open to see if the Kiwi can be seen from the public Internet (from specifically).

    All of this is a little complicated. But unfortunately that's the nature of networking.

  • Thanks yes all sorted now the auto add NAT option worked the only sight issue is that I can't connect to the public ip just my personal one buy I'll leave it as it is for now. I am the only Brighton UK kiwisdr which is proving to be quite popular

    Thanks for your help

Sign In or Register to comment.