Network connectivity issues after static IP [fixed with Debian 10 upgrade]

edited July 2023 in Problems Now Fixed


I'm having a kind of weird problem with one of my Kiwis.

I’ve changed a router to a new one, in that process I’ve thought it would be good idea to set a static IP in the Kiwi, previously I’ve done this in the router settings with bind the Mac to a dhcp address that the router hands out.

But this time I’ve set a static address in the gui of the kiwi itself. However I’ve must done something wrong, or something happened in the process. Because now I can’t connect to the Kiwi. I can see the IP of the kiwi in the router, it says it’s connected but I cannot access it.

if I run a network scan it comes up with the same IP that the router tells me, however it not accessible. If I try to ping it, it comes up as all packets loss. If I run a port scanner it doesn’t find any accessible ports.

I even tried a different router with just the kiwi and a laptop on it, and the same situation there.

Is there a way to reset the board a start over again with dhcp?


  • can you ping it? or ssh to it?

  • If I ping it it comes up as all packets lost. SSH doesn’t connect either.

  • Could it be that you chose the wrong subnet/netmask for the kiwi?

    Or that the PC is in a different subnet than the kiwi, respectively.

    You could access the kiwi through a usb network interface:

  • edited July 2023

    I remember a similar issue recently. I had tried to switch from DHCP to a fixed IP and filled in the related fields, but the kiwi was again in DHCP mode after rebooting, and I could still contact it under the "old" DHCP-assigned IP. (After trying it some times without success, I accepted the situation for the time being and didn't investigate it further, so I'm sorry I can't help anymore on that.)



  • I had no luck to connect it with the usb cable. So did a reinstall with the supplied sd card.

    Now it gets an IP via DHCP, I can connect to it, how ever now it says “Software upgrade in progress “ and has been doing so for the last two days.

    If I go to the admin page it says version 1.2 upgrade to 1.620 in progress.

    Anyone have any ideas? It seems it doesn’t upgrade like it says?

  • Problem solved. Upgraded to Debian 10. Thanks!

  • Just for the sake of completeness: My problem mentioned here has been cleared up in the meantime - it was only my own stupidity. I was used to the fact that most setting changes take effect as soon as the cursor leaves the respective input field, and had overlooked the yellow button in the top left, with which the change of the DHCP/Static IP configuration has to be confirmed explicitly. That's all.

Sign In or Register to comment.