Kiwiclient & Python 3.10.4 on Linux

Hi,

after an OS upgrade I'm now facing this problem trying to run any of the kiwiclient utilities:

Traceback (most recent call last):
 File "/home/giuliano/kiwiclient/kiwiclientd.py", line 20, in <module>
  from kiwi import KiwiSDRStream, KiwiWorker
 File "/home/giuliano/kiwiclient/kiwi/__init__.py", line 8, in <module>
  from .wavreader import *
 File "/home/giuliano/kiwiclient/kiwi/wavreader.py", line 11, in <module>
  class KiwiIQWavReader(collections.Iterator):
AttributeError: module 'collections' has no attribute 'Iterator'

Any idea? Last resource would be to revert python back to a previous working version.

Thanks a lot.

Comments

  • jksjks
    edited September 23

    In the file kiwi/__init__.py comment out (add a "#" to the beginning) of the line that says:

    from .wavreader import *

    i.e. make it:

    #from .wavreader import *

    Not a real solution to the problem, but should be enough to get you going as kiwi/wavreader.py is not used for normal operation of the kiwiclient tools.

  • It works again.

    Thanks a lot, really.


    Giul

Sign In or Register to comment.