Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (,

Please visit (documentation) and (online store)

Trying to update from v1.548 [fixed]

edited September 2022 in Problems Now Fixed

When I select UPDATE check now, I get the error Error determining the latest version -- check log.

Copy the end of LOG: [00] ADMIN connection closed

Wed Sep  7 22:30:20 00:36:06.142 ........     [00]   PWD isLocal_if_ip: flg=0x18 fam=2 socktype=1 proto=6 addrlen=16
Wed Sep  7 22:30:20 00:36:06.142 ........     [00] L PWD isLocal_if_ip: TRUE IPv4/4_6 remote_ip ip_client ip_server[IPv4] nm /24 0xffffff00
Wed Sep  7 22:30:20 00:36:06.145 ........     [00]   TLIMIT exempt local connection from
Wed Sep  7 22:30:20 00:36:06.145 ........     [00] L PWD admin config pwd set FALSE, auto-login TRUE
Wed Sep  7 22:30:20 00:36:06.146 ........     [00] L PWD admin ALLOWED: no config pwd set, but is_local
Wed Sep  7 22:30:20 00:36:06.146 ........     [00] L PWD admin admin ALLOWED: from
Wed Sep  7 22:30:31 00:36:17.328 ........          L UPDATE: force update check by admin
Wed Sep  7 22:30:31 00:36:17.332 ........          L UPDATE: checking for updates
Wed Sep  7 22:30:33 00:36:18.886 ........            UPDATE: fetch origin status=0x00008000
Wed Sep  7 22:30:33 00:36:19.600 ........          L UPDATE: Makefile fetch error, no Internet access? status=0x00008000 WIFEXITED=1 WEXITSTATUS=128
Wed Sep  7 22:30:33 00:36:19.604 ........            task update_task:P3:T002((1000.000 msec) TaskSleep) exited by returning

Looking at the update history on the forum I read we go from version 545 direct to ver 552, nothing about version 548 that I am using now.

What can I do to clear my problem?


  • Versions without anything of interest to users don't get a forum post.

    Use the console tab (or ssh/PuTTY to the Kiwi directly) and look at the file /root/build.log Post here or email to

  • jksjks
    edited September 2022

    A less painful alternative, if your Kiwi is accessible on the Internet (public or not), is to set a temporary admin password and email it to and I can take a look.

    Recent versions have more comprehensive error log messages when a build fails (they identify some specific failure cases e.g. disk full, git clone corrupted etc). And there are some pre-programmed buttons on the console tab to help diagnose and repair build issues.

    Of course you have to get updated to the more recent versions first -- Catch-22!

  • CONSOLE: open connection
    root@kiwisdr:~/Beagle_SDR_GPS# cat /root/build.log
    ======== checking for update
    Thu Sep  8 10:34:07 UTC 2022
    error: object file .git/objects/3f/7b3d555500eda9712486c39a2f2335ad0835ae is empty
    error: object file .git/objects/3f/7b3d555500eda9712486c39a2f2335ad0835ae is empty
    fatal: loose object 3f7b3d555500eda9712486c39a2f2335ad0835ae (stored in .git/objects/3f/7b3d555500eda9712486c39a2f2335ad0835ae) is corrupt
    fatal: The remote end hung up unexpectedly

  • jksjks
    edited September 2022

    Okay, so your Git clone of the Kiwi sources is trashed (for whatever reason, power failure at inopportune time etc). Please try this from the admin page, console tab:


    mv Beagle_SDR_GPS B.bad

    gclone Beagle_SDR_GPS



    Build will take 20 - 30 minutes.


    Then click the restart button on the control tab. Should be at the latest version now and able to receive future automatic updates if you have them enabled on the update tab.

  • Yes. All is good now.

    Small correction to your instructions. "...admin page, control tab." should read the Console tab.

    Thank you for the help.



  • I wanted to repair my receiver but I get this:

    Debian GNU/Linux 8 Debian Image 2016-05-13


    default username:password is [debian:temppwd]

    Last login: Thu Nov 3 18:40:27 2022 from

    root@kiwisdr:~# cd

    root@kiwisdr:~# mv Beagle_SDR_GPS B.bad

    mv: cannot move 'Beagle_SDR_GPS' to 'B.bad': Read-only file system


  • Hi @ArturPL !

    Usually Linux file system mount like read-only if it has errors. You can try to check and fix it with fsck utilite or full re-install this BBG from microSD card.

    73! Yuri

  • I already tried to restore from SD but it loops and again cannot start from the local address via http (ssh works), probably the backup was already overwritten with an error in 1.566

    I can try from a working 1.567 kiwi card or from the original one that has never been used, which is better to choose?

  • Ok, I'll write what came out of this later

  • Managed to. I created an SD card from flash and the Kiwi came alive.

    I also found the culprit - the power supply

    I am surprised, however, that the other two of my Kiwis started from it without any problems. Currently, I used an emergency ZHAOXIN RXN-305D, I set him a current of 5A with a voltage of 5.3V. It works very steadily and, surprisingly, does not interfere with LF / MW like typical switch mode power supplies.

    Thank you for your help!

  • Glad to hear you fixed it!

Sign In or Register to comment.