v1.554: misc improvements: TDoA results, GPS clock correction, antenna switch, admin console

From the CHANGE_LOG file:

v1.554 Aug 15, 2022

  Admin page

    Console tab: added buttons with common commands, e.g. monitor build progress, disk free,

      check github.com reachability, ping kiwisdr.com sites.


    Config tab: "Downconverter high-side injection" checkbox will be disabled if antenna switch

      extension is in use since the switch now has per-antenna high-side injection control.


    Config tab: "GPS correction of ADC clock" is now a menu instead of an on/off switch.

      New options prevent corrections from disturbing WSPR-2 and FST4W reception.

      On the GPS tab, the correction count color after the displayed ADC clock frequency

      indicates if updates are currently allowed (green) or not (red).


  TDoA extension:

    Add "show all results" checkbox. If set this will cause the green markers displaying the

    most likely lat/lon positions to accumulate across successive runs.

    The "clear old results" button will erase all but the most recent likely position marker.


Comments

  • I was able to upgrade two of my kiwiSDR to 1.544. The third one reports as version 1.544 but the config page is not the same as the other two. It does not show the GPS modulo configuration nor the high side injection menu item.

    I tried updating it a couple times and have power cycled it as well.

    The radio seems to run fine and I haven't found any other issues with it.


    Steve KD2OM

  • edited August 15

    Interesting addition in v1.554 to the TDoA extension where it is now possible to show the results of previous runs on the map display.

    Makes it easy to visually compare the results of several runs with the same or different kiwi nodes and spot outliers, thus increasing the reliability of the target station position estimate.

    Another application would be to map the location of similar stations in range e.g. the French Navy Stanag 4285 transmitters or trying to locate the HF chirp sounders that are still active in the Asia Pacific region.

    Thanks John.

  • One of mine doesn't seem to want to update.

    Installed version: v1.553, built Aug 12 2022 11:50:54

    Error determining the latest version -- check log

    And the log shows

    Mon Aug 15 17:33:36 00:01:10.902 ....      L UPDATE: force update check by admin
    Mon Aug 15 17:33:36 00:01:10.906 ....      L UPDATE: checking for updates
    Mon Aug 15 17:33:37 00:01:12.165 ....        UPDATE: fetch origin status=0x00008000
    Mon Aug 15 17:33:38 00:01:13.175 ....      L UPDATE: Makefile fetch error, no Internet access? status=0x00008000 WIFEXITED=1 WEXITSTATUS=128
    Mon Aug 15 17:33:38 00:01:13.178 ....        task update_task:P3:T003((1000.000 msec) TaskSleep) exited by returning
    


    The other at the same location was fine.

    Regards,

    Martin

  • jksjks
    edited August 15

    @G8JNJ Type in admin console:

    git fetch origin

    git show origin:Makefile | head -n2

    What do you get?

  • jksjks
    edited August 16

    @sesykes71 Could you please email the URL and admin password (change it to something temporary) to support@kiwisdr.com? I think you did this back in January for a similar issue with update problems.

    It's easiest if I can login and poke around to figure out what's up.

    Thanks.

  • Hi John,

    I've sent an email, as I can't seem to post the console output on this forum.

    Regards,

    Martin

  • Replied to your email..

  • edited August 16

    John, I tried to update it again this morning and it got through it. I have no idea why it didn't work yesterday but I tried a couple times then.

    The url is http://www.ecsykes.com:8075

    73

    Steve KD2OM

  • Thanks John,

    I have replied back.

    Regards,

    Martin

  • @sesykes71 Steve, on your Kiwi, admin page, update tab you have the Automatically check for software updates? and Automatically install software updates? both set to NO. How long has that been the case? The log indicates this is why you're not receiving any automatic software updates!

Sign In or Register to comment.