I couldn't upgrade from factory version 1.2

I was able to run my new KiwiSDR at Kiwisdr.local:8073 but it had no audio on Google Chrome as documented and my attempts to solve this through updating and reinstalling all failed: it didn't update nor reinstall. Updating never happened by clicking the buttons on KiwiSDR user interface at: kiwiSDR.local:8073/admin and in all reinstalling instances, the lights stayed flashing and never powered off throughout the four minutes sessions as well as an hour session, so there was no way to know how long reinstalling would take or if reinstalling was completed. And consequently, the KiwiSDR remained stuck on version 1.2 which didn't work for me.

Any advice and enlightenment on this?

Thanks!

Comments

  • Most everyone who has problems initially clears them by re-flashing using the sd card and then waiting long enough for the full update over the network. We have seen this many times.

    So insert the sd card and power up (with the network disconnected). It's only working if within 30 seconds of power up you see the 4 LEDs display a back-and-forth scanning pattern. If they ALL flash together quickly then a read/write error has been detected with the sd card or the eMMC flash on the Beagle.

    Within 5 minutes ALL the LEDs should come on and stay on for a little while. Then go dark as the board powers down.

    Remove the sd card and reattach the network cable.

    Now power up. Within 15 seconds or so you should see random activity on the LEDs. To monitor the progress of the long network update (that is hopefully taking place) try a PuTTY (Windows) or ssh (Linux/Mac) to root@kiwisdr.local e.g. ssh root@kiwisdr.local It should let you in without a password, even as root.

    Now run the command top -c At the top of the screen should be the commands from a bunch of stuff running. It may be hard to spot, but kiwid should be there. And then you should see a bunch of commands appear and disappear as the update proceeds. A lot of them will involve stuff call apt, dpkg, git and clang

    If it looks like not much is changing on the screen then it's likely there's some kind of problem, possibly with the network connection.

    When the build is completely finished, kiwid will be running on the top line with greater than 90% showing in the CPU column.

  • Also, I have to ask: This is a genuine KiwiSDR board (not a clone) running on a BeagleBone Green or Black, right?

  • Thanks! I have accumulated uptime for over ten hours now and my KiwiSDR hasn't started to update on its own. I did attempt to update it with Debian version 11.3 but it failed as it never powered off, even after an hour.

    I am working on a kit, of the genuine KiwiSDR board on Beaglebone Green ( AM3358 ), still stuck with version 1.2.

    I have got audio now on Firefox by changing the default setting but couldn't do the same with Google Chrome or Microsoft Edge, just yet.

    Will try and repeat re-installing and root with debian command lines but for now two of my

    SD cards have been corrupted in Balenaetcher flashing and reinstalling attempts.

  • edited August 7

    Maybe easy re-flash your BBG from new image from QS http://kiwisdr.com/quickstart/#id-dload? Debian 10 should work fine.

  • I did attempt to update it with Debian version 11.3 but it failed as it never powered off, even after an hour.

    You can't do this! You can't run random Debian images and expect the Kiwi software to work. There is NO validated D11 for BBG/BBB that has the Kiwi server ported to it (BBAI-64 is the exception). Each Debian version has a slightly different procedure for setting up the I/O from the Beagle to the Kiwi board. This is due to the numerous changes the Beagle guys have made to Beagle I/O over the years. That's why Kiwi software is released locked to a specific Debian image.

    You say "never powered off even after an hour", but there is no power off associated with the hour-long network update step. It's only after the 5 minute re-flash from sd-to-eMMC step.

    PLEASE start over and follow the reinstallation instructions EXACTLY. There is no reason you should have any problems.

Sign In or Register to comment.