LSB Passband Not Working [fixed in v1.543]

edited June 18 in Problems Now Fixed

I am having an issue with the LSB passband settings. When choosing LSB you get a passband of -560 to -300.. I have reset the passband settings in the admin web page, but that doesn't fix it.


I SSHd into the kiwi and took a look at the kiwi.json file and see "last_lo" and "last_hi" set to the incorrect passband that I am seeing. I tried to edit the json and restart kiwi, but it just overwrote what I had changed. How do I reset this?


** EDIT -- I was able to fix this! I stopped the kiwid service, edited the kiwi.json and the service auto started (must be a watchdog service watching kiwid) and all is fixed! Is this a bug? Why would "last_lo" and "last_hi" be the settings it uses instead of "hi" and "lo"..

1) Edit the file, but don't save yet

2) /etc/init.d/kiwid stop

3) Save the file

4) Wait for it to restart the service or do /etc/init.d/kiwid start


Comments

  • jksjks
    edited June 17

    What software version? I just tried this with the latest version (v1.542) and it all works fine.

    Try typing / in the frequency box to reset the current passband to the default (or the keyboard shortcut ctrl-p).

  • v1.542 -- I was able to fix it already if you look at my edit

  • Despite the timestamps I posted before refreshing the page and seeing your edit.

    So yes, this is a bug. But only under unlikely circumstances. I'll fix it.

    Don't know if it's worth explaining or not. last_lo/hi are used to save temporary per-mode passband changes you make during a user connection. So for example if you change the usb passband, flip to lsb and flip back to usb your changes will still be in effect. Session changes to the passbands are not supposed to be applied on the next connection (i.e. they are not saved in a browser cookie/local storage). But the bug is that under certain circumstances the last_lo/hi values are written to the kiwi.json configuration file (1st bug) and then incorrectly applied on the next connect (2nd bug).

    last_lo/hi are stored as part of the overall passband data structure. This data structure was added to the saved configuration as part of making the default passbands editable from the admin page, config tab. last_lo/hi went along for the ride even though there was never any need to. But how can a change to them from a user connection make it to the stored configuration? That should only happen from an admin page connection, right?

    Well, consider what happens if you do one of permitted admin operations from a user connection, either by supplying the admin password or as a result of being connected on the local network (e.g. DX label edit or one of the admin-restricted entries in the right-click menu). In that case the configuration from the user connection does get saved, including the unnecessary values of last_lo/hi.

    The second bug is that these values are used initially on page load instead of the passband defaults as set in the admin page, config tab. As part of a configuration save from an admin connection last_lo/hi always tracked these default values. So this 2nd bug went unnoticed..

  • Excellent, thank you for the explanation. I tried a bunch of things before posting here just to verify I was indeed seeing a bug. Different browsers, using incognito/private mode, clearing cache/cookies, and then once I tried it from a work computer that has never connected to my Kiwi before, I knew something was up. I had not even changed the default passband. Then I saw in the forums someone post how to see the json and that is where I saw the passband settings I was seeing in the client! I am glad I could at least bring this bug to light so it can be fixed. I was not even aware you were a developer. Thank you for support and awesome SDR development, I love the Kiwi!

  • Always good to ask here before spending too much time trying stuff yourself. My stupidity knows no bounds sometimes 🙄

Sign In or Register to comment.