Possible bug with public facing GUI [fixed in v1.523]

edited May 13 in Problems Now Fixed

Hi

I do not operate a kiwi but I am a frequent user and I've notice some odd behavior with the user GUI. I thought I'd offer the info to the forum here and let the developers run the issue down.

On my iPhone (IOS 15.4.1) and on my laptop's (Win7) Chrome & Firefox browsers I've been seeing the same issue: After going to the main KFS quad kiwi page at....

http://kiwisdr1.kfsdr.org:81/

....I have experienced the following:

Selecting any of the four kiwis brings up a page that has a blank frequency box and even though I type in a frequency and hit return nothing happens. On Chrome and on IOS it reloads to display the "Play" arrow icon in the middle of the screen. The screen also does not populate my ID in the name/callsign box as it used to, probably based on a cookie.

The problem seems to come and go. The ham radio page at http://websdr1.kfsdr.com:8901/ seems to always function normally for me.

I don't want to send more emails to the KFS crew unless I can provide something useful.

Another user on a forum I frequent said this:

"I can confirm this happening to me on Firefox for Windows 99.0.1, Windows 10.

I noticed this morning that if I closed that browser tab and open it again a few minutes later (I went to get a coffee), it opened with 10 MHz WWV in use (as usual) and that may have been because someone in Switzerland had swooped in and grabbed the RX0 position. I don't know if that Swiss user had to do some extra gymnastics to get it to go to 10 MHz or not.

I don't use KFS that often (because it is quite popular) but by chance I used it last night (the first time in probably at least a month) and I noticed something similar. (I accessed the Omni from a saved bookmark, not from the "top level" menu you posted) and the first thing that I noticed is that the frequency input was not responding to changes. I ended up going somewhere else.

I have noticed similar weird behavior on certain Kiwis lately. (E.g., not responding to frequency changes.) It's random and not 100% repeatable. I have not made notes about which ones and when."

Short discussion is here: https://www.hfunderground.com/board/index.php?topic=96723.msg306943;boardseen#new

I also notice that if I get the blank frequency box I can just keep hitting refresh until I see the box properly populated.

Thanks to all of the kiwi operators out there. I hope this information is of some use to discovering the root cause.

Jim

Comments

  • Wow, there's something really strange about all 4 of those Kiwis. They're all running v1.509 which is a little old but should be okay. If you look at the javascript console (from the browser) on page load it thinks the variable "cfg.passbands" doesn't exist. That comes from the saved configuration file. Yet if you type "cfg.passbands" into the javascript console input field it appears just fine.

    So I don't get it. One of them has been up 10 days, but another less than 24 hours. Maybe they should try updating to the latest software version and see what happens. You'll note there is no waterfall either because of this problem (because the javascript aborts before the page can completely load).

  • jksjks
    edited May 5

    Also, it looks like they've modified the Kiwi index.html file directly to get their custom top banner. That's probably why they don't have auto updates turned on. Because an update would wipe out that change. A custom banner can be done with the admin page, webpage tab, "additional HTML" field. They may not realize this.

    So if they've modified that file it makes me wonder what else they've done that might contribute to this problem.

  • Hi John,

    I have been busy busy with WD 3.0 that I have barely looked at the 5 Kiwis at KFS: :8074/5/6 and 8083.

    I have just instructed all of them to update to the latest Kiwi code, but I'll wait to hear from others if they are still experiencing problems.


    Rob

  • Hi Rob,

    Same problems using the same IOS on my iPhone 10 plus a new problem

    When I try to type in a frequency it does not invoke a QWERTY keyboard. Instead it displays a mobile phone 10 digit keypad. I can enter numbers without a decimal point and there's no way to hit "ENTER" to load the numbers

    Accessing via Chrome on the laptop is still presenting the same problems.

    Thanks for looking into the issues.

    Jim

  • On iOS the 10-digit keypad should show the word done at top right you can touch to submit the entry. I get this on my iPhone 6S running iOS 15. If you don't see this I'd like to know what iOS version you're running and a screenshot of what you're seeing. It's possible we have to revert to a different keypad for earlier iOS versions.

    It's yet-another-bug that iOS isn't using the 10-digit keypad that includes a decimal point. I'll fix that in the next release.

    I don't know what's up with the KFS Kiwis. It looks like Rob updated them to v1.519. And that version runs fine on all the other Kiwis I tried. But the KFS Kiwis have this weird problem that looks like a Javascript timing bug of some sort. The KFS Kiwis still fail to load completely for me using Safari, Firefox or Chrome.

  • jksjks
    edited May 9

    Update: Yeah, it's something about timing. While trying a bunch of times with Firefox, and flushing the cache each time, I got it to load exactly once.

  • jksjks
    edited May 9

    Okay, problem understood. It's a race condition in the code. For some reason the network/timing conditions at KFS are slightly different and the race is frequently triggered. I was able to reproduce it by introducing some artificial timing delays. All I have to do to fix it is add some proper locking that should have been there in the first place.. 🙄

  • IOS 15.4.1

    You are correct that I can use "Done" but there is no decimal point with that entry GUI. So I have to enter 4095 and then have to press the plus signs and steer to the right number of hertz. Before this I always had the Qwerty keyboard which was much more useful.

  • I have just started to upgrade all 5 of the KFS Kiwis from 519 to 522

    The KFS site is connected to the Internet by a microwave link which is heavily used by WebSDR listeners as well as by one of the wsprdaeon.org backup servers. I am working both the reduce the network impact of the WD server and to increase the subscription bandwidth of the link.

    On a perhaps related subject, in recent versions the Admin pages which I leave open continuously have started to report 'Server has closed connection' after some time. At KPH I have some 473 Kiwis and some 522 Kiwis and that 'Server has closed connection' page only appears on the 522 Kiwis. However the 473 Kiwis appear to silently terminate communications after some hours or days.

    It would be helpful if those Admin pages were as stable as the listening sessions. But it is almost better to get the 'Server has closed connection' page, so I then know to refresh the page to see current status.

  • @rrobinet Okay, this all makes sense now. If that microwave link is inducing differential delay between the HTML load of openwebrx.js and the sound connection web socket then this issue will occur. It could easily do that because of limitations in how they buffer connection traffic (e.g. a large MTU). The race window is only a few hundred milliseconds wide. I don't honestly understand why we haven't seen this problem before given all the varied network connections Kiwis use.

    Re "server has closed connection". I added this recently because previously you had no indication when the connection closed, either because the server restarted or the connection dropped for some reason. The result was that you could happily type into the admin page and it would look like it was accepting your input. But the reality was the page was "dead" and nothing was being transmitted to the server. This is a source of extreme confusion. At least for me.

  • jksjks
    edited May 9

    @rrobinet Okay, v1.523 should fix the page load problem at KFS. Also, I added a reliability improvement to the admin server close code. I don't know if it will make any difference, but it might.

    @teotwaki The decimal point in the 10-digit keypad for iOS is available again in v1.523

  • I have initiated a build of 523 on all 5 of the KFS servers

  • Thank you to all who helped to decipher and resolve the issues at KFS, especially the volunteer staff there! (I have donated in the past and will do so again.) It has been fascinating to see how the issues I identified have been discussed and before long to see normal operation restored.

    I believe that prior to this I was able to use the IOS mobile interface and be able to adjust the receive bandwidth (green passband symbol) in order to eliminate close in signals. Now I cannot adjust it. Was that a change in the mobile user interface software a while back?


    Jim

  • Yeah, there's something up with that. I'll look at it.

  • In the next release I think this is fixed.

Sign In or Register to comment.