New update, SAM WAS broken! [SOLVED]

My Kiwi just updated, and after the reboot, Synchronous AM is no longer working as it should. When I tune to a station, it only works for a few seconds... then the audio gets VERY distorted, and eventually disappears. I've tried several stations. AM works, but SAM does not. If i "force" it off-tune about 1KHz, the normal tone is heard that "swoops" until it re-sync's with the carrier... but the tone and swoop are now distorted. Once the carrier locks, the audio will again distort, then disappear over a few seconds. SAM is my favorite listening mode! :( (Note: I am connecting directly via my LAN.)

Here is the STATUS page from the Admin account, snapped after the reboot was done:

Config: v1.512, 3 SDR channels, 12 GPS channels | Uptime: 0:02:05 | UTC: 22:23 | Local: 18:23 America/New York (EDT)

GPS: acquire yes, track 3, good 0, fixes 0

SNR: All 0 dB, HF 0 dB

Comments

  • Dunno, tried a bunch running v1.512 and they all behaved fine.

    On the audio tab what PLL speed are you running? (DX, med, fast). Are the carriers of the signals you're listening to weak and/or fading significantly? What other unusual setting do you have? (de-emphasis, noise blanker/filter, non-standard AGC). Do you accidentally have channel nulling turned on?

  • Channel nulling? Hmmm... that must be new!

    I tried turning various pre-emp, noise, etc, on and off. Nothing had any effect. The signals are strong. Some weaker ones also do this. This only started happening after I installed this recent update. I will have to look for "channel nulling" and try turning that off... that MIGHT be it! (A new feature, I'm guessing it defaulted ON.) I will check back here in a few.

  • The "channel null" menu appears in SAM mode (only) on the audio tab, bottom left. It should say "normal" when disabled.

  • OK, Channel Null only has 3 settings, and I tried all of them. There is no "OFF" or I would try that. Stronger signals get distorted, VERY strong signals (Over S30) fade out to very low volume & distorted. I tried "med" and "fast" PLL speeds. The only difference is how quickly the "swoop" happens as the carrier is synchronized. Nothing I've tried so far, has restored my SAM ability.

  • I have an idea... my SDR is "semi private", accessed online via my ISP's IP address. I would e-mail it to you, so you can log in an check out what's happening. I don't want to post my IP openly, for obvious reasons. ;)

  • What about the noise blanker/filters? Are they both off on the audio tab?

  • Sure, support@kiwisdr.com

  • Noise blankers are all off.

  • I sent you an e-mail. Did it go through? I'm using AOL. No matter what I try, I cannot get SAM working like it used to before the update. BTW, I rebooted the SDR earlier today, because I couldn't select any mode, AM, SAM, etc... it was just "stuck" in AM. After the reboot, I noticed the new "DX Label" edit features (nifty!) but that's when I also noticed the SAM issue.

  • My apologies... I didn't realize that I sent you the WRONG IP! It copied the LOCAL. I just re-sent you an e-mail with the actual Internet IP.

  • OK, I saw that you were on the receiver... any ideas? :)

  • All sounds fine to me. I tried Firefox, Safari and Chrome.

    Try restarting your browser, and try another browser for comparison. Which one were you using anyway?

  • In very rare cases I've had to restart the computer running the browser to clear strange audio issues. But probably only two or three times in the last 9 years. Mostly it's the browsers that get confused. Also possible is VAC or other audio manipulation programs.

  • edited April 21

    OK. Call me a Monkey's Uncle! :o Restarting the browser did not fix the issue. Deleting all of the cookies for the SDR, did!! THANK YOU! :) It's working perfectly, again! :D

    (Firefox under Linux.)

  • No, there is nothing related to the update causing problems because of cookies. That's a reach on your part. If you put that idea into people's head I'll never hear the end of it..

  • OK, comment edited... clearing my cookies made my browser happy with the SDR. :)

  • Just a little update: It did the same thing again. Rebooting the computer didn't work, but clearing the cookies did.

  • cookies or cache?

  • What browser? What browser version? Desktop or mobile?

    Have you tried other browsers? Other computers? Problem seen on more than one computer?

  • Firefox 88 under Linux. My main desktop computer. No, I haven't tried others, yet... 99% of the time I use the SDR, the Internet, etc, it's from this machine, using Firefox. :)

    WA2ZKD: Cookies, not cache. I have a "plugin" in Firefox that allows me to clear all cookies for the current site, without affecting others. As soon as I did, "Poof". The strange behavior was gone. It may very well be related to THIS machine, THIS sound card, THIS browser, THIS version of Linux... but I have only experienced this twice, now.

  • Next time it happens I'd be interested to know what happens if you do a temporary "disable all plugins" in Firefox and try it again. And then with and without a few times to see if the behavior tracks.

  • Also, Firefox 99.0 is current. You might want to try updating if you're really running 88.

  • Hmmm... looks like I have a conundrum! I can't get anything beyond 88 for this version of Linux. (Mint 18) So, it looks like a MAJOR upgrade is going to have to happen. :( I only have a handful of plugins, like the one that lets me delete site-specific cookies.

    I'll try firing up my test version of Linux Mint 20, and see what happens... it just doesn't have ANY of my apps, settings, etc in it, yet.

Sign In or Register to comment.