Network Check Port open fails - no map visability

Hi wonder if someone can help, I'm setting up a kiwisdr and am having issues getting the Network Check port open tests to pass I think this is the cause of the SDR not being visible on the map.. Our Kiwsdr is visible on the net via 123.255.47.67:8073 also via zl2vh.hopto.org:8073.

73's

Simon ZL2BRG

[jks edit: ip 123.355.47.67 => 123.255.47.67]

Comments

  • edited February 9

    Hi Simon, what do you see on your "Log" tab? You see info about registration?

    "Public" tab looks like?


  • edited February 9

    Hi Simon,

    Your 0-30 Spectrum is filled with a strong 11 KHz picket fence of switching power supply noise which is most likely introduced by ground loops in the wires connected to your Kiwi. I would work on eliminating that RFI before sharing your site.


    Rob

  • jksjks
    edited February 9

    kiwisdr.com sees no registration registration requests at all from this Kiwi. So I agree with @rz3dvp

    I can do a curl 123.255.47.67:8073/status and get back good info, so that's not going to be a problem.

  • Hi, Yes we are aware of the noise issues and will investigate on the next site visit. ( the sdr is at a remote site on the end of a ubiquiti microwave link) The public page registration says successful but looking in the logs I see  "_reg_public: sp == NULL?" and "TIMEZONE: timezonedb.com curl errors" so maybe we have a gateway / dns resolving issue ?

    73's

    Simon ZL2BRG

  • Yes, probably DNS.

    Connect to the admin page. On the security tab make sure "Restrict console connections to the local network?" is set to "No". Now go to the console tab and click connect. You should get a shell prompt ("... #") in the upper window. In the lower text entry field type stuff like ping kiwisdr.com ping 1.1.1.1 etc. and see what happens (type control-C to stop the ping program).

    Are you using a DHCP assigned ip address or static assignment (setting on the network tab).

  • Its a static ip , need to check the firewall rules I think. Cheers

    73's ZL2BRG

  • Thanks folks. Sorted it. Needed to enable masquerading on the gateway port. Registration will be off til the noise issues are fixed.

    Thanks for your help.

    73's Simon ZL2BRG

  • @clitang The body of your message is missing. But I'm going to guess you have a similar problem. If the check port open button on the network tab is not returning "YES" for either result then it might be that your network connection can't get to kiwisdr.com Check the other thread for how to run the ping command to see if you have an Internet connectivity problem.

    If the port open button is okay, but you're just not appearing on the map, note that it takes some time (up to 30 minutes) before this happens after a successful public registration shown on the public tab. Also, check rx.kiwisdr.com to see if you're listed there.

    On the public tab, when you set the register on rx.kiwisdr.com? switch to YES do you eventually get "rx.kiwisdr.com registration: successful" in the kiwisdr.com registration status field? As it mentions this can take up to several minutes in some cases. It is not instantaneous.

  • In the first instance with port checking, I got this error msg

    Check if your external router port is open:Check port open

    Does kiwisdr.com successfully connect to your Kiwi using these URLs?

    If both respond "NO" then check the NAT port mapping on your router.

    If first responds "NO" and second "YES" then domain name of the first

    isn't resolving to the ip address of the second. Check DNS.

    http://BH4AEN.proxy.kiwisdr.com:8073 :Error checking port status

    http://112.81.196.2:8073 :Error checking port status


    though my registration was successful:

    Register on rx.kiwisdr.com? YesNo

    kiwisdr.com registration status:rx.kiwisdr.com registration: successful


    So where should the debugging, and troubleshooting go about this?

  • I have sent you a private message.

Sign In or Register to comment.