KiwiSDR won't complete upgrade. (SOLVED)

edited June 2021 in Problems Now Fixed

One of my radios won't complete the upgrade from 1.441 to 1.460. Two others upgraded just fine but the third just hangs. I can ping the address and the Cloud9 ide opens up. The Kiwi never starts. I have waited for at least 20 minutes, unplugged power waited to see if it would boot pulled power again, same result, The receiver never boots.

I should mention the receiver is on an AI.

Any ideas what to do next?


Steve KD2OM


  • Is it accessible from the Internet? If not, please email and I'll send you a proxy key which is the easiest way to get it on the net.

  • edited June 2021


    It is accessible from the internet.


  • Well, it doesn't seem to be answering.

  • I can ssh to it but of course don't know the password, I need to label the cases I guess. Perhaps the only solution is to reload the system?

    Would opening a port for you help?

  • Unless you changed the Linux root password (unlikely), it is either the Kiwi serial number or the Kiwi admin password if you had one set in the past.

    Opening an ssh port would help, but only if I can login as root of course.

  • I left it as the serial number and recorded it but just can't remember where I recorded it. It is not very difficult to reload it so that is probably best route.


  • If you haven't made a lot of customizations then yes, reloading from the sd card is easy. Just remember the initial network update takes almost an hour.

  • sd card? I don't remember doing that when I initially installed or will that be required because I can't login to root?

  • Thank you for your support John. I will go through the procedure. Strangely on the other kiwi's that upgraded fine, I can't log in via port 22 ssh using the serial number which the admin page shows.

  • jksjks
    edited June 2021

    If you had a non-empty Kiwi admin password at the time the Linux root password security patch was released (v1.354) then that would have been used. Using the serial number was the backup strategy when the Kiwi admin password was blank. This is all discussed in an announced forum post on here.

  • I haven't touched these radios for months, they are doing wspr keeping me usually #1 in the US sometimes close to that world wide.

    I have some reading to do to catch up.

    Again Thank you.

    Steve KD2OM

  • Problem solved.

    This morning I removed the chassis from the rack and took it apart to get the serial number for the non responding kiwi. After I got logged in and since I figured I would have to reload the KiwiSDR software anyway I did the normal apt-get update and upgrade. After the reboot, the KiwiSDR came up running just fine.

    I have no idea what happened or how it was fixed but am happy it is.


    Steve KD2OM

  • Yeah, I don't understand how doing a Debian upgrade would have unstuck a Kiwi that wasn't updating (or even responding as occurred later on).

Sign In or Register to comment.