Guidance wanted on setup

HI, i Can access my kiwi locally.

Try as I might, I am unable to see it appear on the receiver list publicly.

I have done the following

Updated the sotware

I am using a 4G TP Link router.

i have Used the DUC, and have checked that the parameters are correct.

Is their a check list of steps to follow.

Thanks David


  • jksjks
    edited May 2021

    On the admin page, did you fill-out information on the "webpage" and "public" tabs? Including setting the "Register on" switch to "YES"?

    There is a link to the documentation at the top of the public tab. Which goes here:

    Also, what's the URL the Kiwi should be reachable from? (the noip DUC URL)

    Is your uplink really a 4G cellphone (data) network connection? If so we might have to use the Kiwi proxy service because cell providers will not route initial incoming connections (i.e. they don't want you having a server on their network).

  • HI Yes, have filled out the webpage, public tabs, and set to yes.

    The reason for the 4G router is the location will not have any internet access.

    the noip DUC URL is http://herts.hopto:8073

    I havent tried the kiwi proxy service as yet.


  • jksjks
    edited May 2021

    Okay, please send an email to and we'll send you a user key for the proxy service. (I think you meant BTW)

  • Hi. Sorry I am still having a issue

    I have entered the user key for the proxy service.

    When I check on the admin to see if the route port is open I get a Yes from the proxykiwi sdr . But a No from the other IP address.

    I am now wondering if I still have not got the setting in the tp link router MR6400. Set correctly.

    or whether to buy another 3G router.

  • jksjks
    edited May 2021 is seeing your Kiwi sending public registration requests. But from its perspective the api key (proxy user key) appears to be blank. Please check that it is really set to the 29 character key I sent you, click the "re-register" button, and then restart the Kiwi.

    The logs show that the key was correct when you first pushed the "re-register" button, so it was correct at one time.

  • Also, it looks like the proxy saw a successful connection starting about an hour ago when the host name "g8gporx" was being used (it's "g8gpo" at the moment as you know). So you're almost there. Unless of course your provider it taking severe action to stop even the proxy service which I think we've seen once in the past.

  • Hi. I have checked the correct key is entered.

    When using the url it brings up the kiwi. website.


  • I see from the server logs your Kiwi restarted about 90 minutes ago. Was it a software restart or a complete hardware restart? Please try the latter by using the "Beagle reboot" button on the admin "control" tab. Maybe the proxy client software is stuck.

    As the documentation says, you always have to specify port 8073 with a proxy URL. Without a port specifier the connection defaults to port 80 and you are taken to the home page because that's the only reasonable thing to do. So in your case it would be which is similar to nearly every other Kiwi URL (e.g. it might have been had the proxy not been necessary).

    But that's not going to work because the server still doesn't see a complete proxy connection request. All I can see from here is what's in the logs. Here is what I see:

    2021-05-15 10:16:44: (mod_fastcgi.c.2702) FastCGI-stderr: proxy: user=22f62a1ce80e99163a9ef5c196e33 host=g8gporx status=0 existing account already registered

    2021-05-15 10:53:34: (mod_fastcgi.c.2702) FastCGI-stderr: check open port: port=8073 ip= status=0x1

    2021-05-15 11:08:39: (mod_fastcgi.c.2702) FastCGI-stderr: check open port: port=8073 ip= status=0x1

    2021-05-15 11:16:56: (mod_fastcgi.c.2702) FastCGI-stderr: check open port: port=8073 ip= status=0x1

    The first entry says the proxy "re-register" button was pushed with the host name set to "g8gporx". But the second and third lines say the "check port open" button was pushed with the host name having been changed to "g8gpo" but WITHOUT the necessary click of the "re-register" button to get the proxy to use the host name change. Finally, the last line says the host name field was changed back to "g8gporx" where other log info says it remains.

    The actual proxy registration log info is here: - [15/May/2021:16:26:51 +0000] "GET [REDACTED]?url=[REDACTED] HTTP/1.1" 200 18 "-" "Wget/1.16 (linux-gnueabihf)"

    This is what the proxy sends to to get started. The host name field is "g8gporx", but the user key field is blank. That's what the "x" after "apikey=" means. It doesn't mean you've put "x" in the field, it just means the software thinks the field is blank.

    Remember from yesterday there was a short period of time when the proxy startup was successful. So it has worked. There is just something still not right.

  • I have done a reset. But will wait to see another user locally to see if they can help to solve the open port issue.

  • jksjks
    edited May 2021

    Okay, I've spotted a few things that are not right.

    From the server side it appears that on the admin page, connect tab, on that large menu at the top of the page, you have the "Domain Name" entry selected. Change it to the third entry "Reverse Proxy". Then go to the control tab and click server restart.

    Second, please forget everything I said about the user/api key. I was looking at the wrong one. Apologies for that. The one I quoted is the old deprecated one from the debacle. Not the one associated with the proxy. So it's quite likely the proxy key you've set is fine.

    But the reverse proxy setting definitely needs to be changed.

Sign In or Register to comment.