The KiwiSDR 2 online store is open for orders! Please visit

Location not set issue

One of my radios is not setting the location correctly. It has this error. It became more evident when I tried to update it. It never started the upgrade, if I run the upgrade check it says pending.

It seems to work fine otherwise. It is an AI installation running 8 channels.

IPINFO: failed for stat=7 
Mon Mar 15 16:37:54 00:00:57.409 01234567          IPINFO: failed for stat=7 
---- 201 lines not shown ----
Mon Mar 15 17:58:52 01:21:54.957 0.234567          TIMEZONE: curl error
Mon Mar 15 17:59:04 01:22:07.665 0.234567          /users REQUESTED from
Mon Mar 15 17:59:52 01:22:54.957 0.234567          TIMEZONE: lat/lon from admin public config: (42.970001, -77.430000)
Mon Mar 15 17:59:55 01:22:58.281 0.234567          TIMEZONE: curl error
Mon Mar 15 18:00:55 01:23:58.281 0.234567          TIMEZONE: lat/lon from admin public config: (42.970001, -77.430000)
Mon Mar 15 18:00:58 01:24:01.593 0.234567          TIMEZONE: curl error


Steve KD2OM


  • Is this Kiwi available on the Internet? If so, what's the URL?

  • Yes,

  • 8074 and 8075 are responding for me, but not 8076?

  • 8074 and 8075 are both running v1.429 but have auto updates turned off. Is this intentional?

  • Yes because I am running wsprdaemon. I have rebooted and now I can access the receiver with my phone so you should be able to see it now.

  • I imagine this has something to do with it.

  • I get no response from


  • jksjks
    edited March 2021

    "(incomplete information)"

    So that Kiwi is completely misconfigured! Read the documentation please.

  • John

    I figured that it was something I have done but it is configured exactly like the other two Kiwi's I have. I have matched each page, I will check again.


    Steve KD2OM

  • Have you set up port forward on your router for 8076 to

    Unless you are using Plug and Play that is an external step.


  • edited March 2021

    Yes Powernumpty, it was already forwarded. The issue was that for some reason the radio couldn't get the public ip address from the router. I set the network to static now Public IP is filled in. When I asked for upgrade if found it.

    After the upgrade I set the network back to dhcp, restarted and everything seem ok now. The location issue is fixed and the radio is registered on kiwisdr.

    It must have been something NQR with my initial installation on the AI, it had been fine when running on the BBG.


    Steve KD2OM

  • I've had the static/dhcp suddenly OK issue before, right pain to recreate. The networking on the AI does also seem to have some initialization steps that can confuse things (well me) too.

    It didn't like you "looking at it" that way and gave in.



Sign In or Register to comment.