The KiwiSDR 2 online store is open for orders! Please visit

BBAI backup showing error 15

While trying to backup from a Kiwi BBAI installation to a 16Gb micro-SD card the process halted at rsync: / -> /tmp/rootfs/ with each time showing writing to [/dev/mmcblk0] failed... Tried another 16 and then 48 Gb card with the same result. These cards have only been used for backups mostly for KIwi BBG installs and should not have any bad sectors.

Any suggestions what else can be tried? Thanks.


  • I seem to remember hitting this and just copied the Kiwi directories off using SCP or even WinSCP.

    At one stage I did wonder if there was some way to direct the backup to a sshfs (fuse) mount instead, that way I could have a single Linux box (or NAS) with a bunch of backups.

    I know that is not a particularly clever answer but I often want to "make a backup now, learn the proper fix later"

  • I never tested the backup function on the AI. It's possible the script doesn't work since the AI runs Debian 9 instead of Debian 8 like most Kiwis.

  • edited February 2021

    With almost everything working so well now using Kiwi BBAI, it is easy to forget that so far the project status is still alpha. So fair enough for backup I will just use something along the lines Stu mentioned. Thanks.


  • jksjks
    edited March 2021

    From the admin console tab (or an ssh login) do you see this if you do a dmesg | tail -n 100 ?

    [ 1941.352411] mmc0: Timeout waiting for hardware interrupt.

    [ 1941.357840] mmc0: sdhci: ============ SDHCI REGISTER DUMP ===========

    [ 1941.364312] mmc0: sdhci: Sys addr: 0x00000000 | Version: 0x00003302

    [ 1941.370782] mmc0: sdhci: Blk size: 0x00000008 | Blk cnt: 0x00000001

    [ 1941.377252] mmc0: sdhci: Argument: 0x00000000 | Trn mode: 0x00000013

    [ 1941.383722] mmc0: sdhci: Present: 0x01f00206 | Host ctl: 0x00000010

    [ 1941.390191] mmc0: sdhci: Power:  0x0000000f | Blk gap: 0x00000000

    [ 1941.396661] mmc0: sdhci: Wake-up: 0x00000000 | Clock:  0x0000ffc7

    [ 1941.403131] mmc0: sdhci: Timeout: 0x00000002 | Int stat: 0x00000000

    [ 1941.409600] mmc0: sdhci: Int enab: 0x027f000b | Sig enab: 0x027f000b

    [ 1941.416069] mmc0: sdhci: AC12 err: 0x00000000 | Slot int: 0x00000000

    [ 1941.422538] mmc0: sdhci: Caps:   0x25e90080 | Caps_1: 0x00000f77

    [ 1941.429007] mmc0: sdhci: Cmd:   0x0000333a | Max curr: 0x00000000

    [ 1941.435477] mmc0: sdhci: Resp[0]: 0x00000920 | Resp[1]: 0x1d8a7f80

    [ 1941.441947] mmc0: sdhci: Resp[2]: 0x5b590000 | Resp[3]: 0x400e0032

    [ 1941.448416] mmc0: sdhci: Host ctl2: 0x00000000

    [ 1941.452880] mmc0: sdhci: ADMA Err: 0x00000000 | ADMA Ptr: 0xbcd8d208

    [ 1941.459349] mmc0: sdhci: ============================================

    [ 1941.469627] mmc0: error -110 whilst initialising SD card

    That's what I'm seeing. But the sd card connector on my AI is severely damaged from the fan blowing lots of dust and salt air through it for a long time. I could hardly insert the card properly so this error might be the result of mechanical/electrical issues.

    There might also be read/write errors recorded on the dmesg log.

Sign In or Register to comment.