Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (,

Please visit (documentation) and (online store)

SDR not showing on listing

Hi, my SDR is 'registered', but is not showing on
What else do I need to do please?


Andy EI2HH


  • jksjks
    edited August 2020
    The last time saw a registration request from was on August 18. Are you sure this Kiwi is running and has a connection to the Internet? What happens when you use the "check port open" button on the network tab of the admin page?

    Also, is this simply a case of your ISP having changed your public ip address? (since you've taken no measures it seems to guard against that possibility).
  • The IP has changed since then as I moved the location slightly. The new permanent IP is

  • You have severe local networking problems. From your Kiwi I can ping your router, but nothing beyond that. Not even numerically (e.g. ping which should work). Given that fact I don't understand how incoming connections are even working.

    For example, from the Internet you can visit and get the correct response. But your Kiwi cannot contact at all because it can't even reach its own DNS server!

    So this is not a Kiwi problem and you'll need to find your own solution.
  • OK a routing issue I guess. I will check routes in the router.
    Thanks for checking.
  • Actually can you tell me how to initiate a ping from the Kiwi, so I can check if its working?
  • Admin page, console tab, click "connect" button.
    In "enter shell command" below type "ping" or "ping" (or or something).
    Type control-C to stop command if no response.
  • I get "only available to local admin connections". And I'm not local to it!
  • Did you mean to write "am local to it" instead of "am not"?

    Is your device running the browser on the same subnet as the Kiwi? That's what it is checking for.
  • This stuff is so complicated now that even I forget how it works.

    If you are connecting to the admin page of a remote Kiwi over the Internet (i.e. not from the same local network as the Kiwi) then the "console" tab functionality is disabled as a security measure. The rationale was that if your Kiwi admin password was leaked or guessed then it would be better if all the bad guy could do was change your Kiwi configuration rather than also have Beagle root shell access.

    The better solution is to use ssh as the transport mechanism for the admin console tab. I worked on that for a while but had implementation problems and never finished the work..
  • Hi, yes I am NOT on the same subnet as the Kiwi. The Kiwi is in a field a mile from my house!
    Is there anyway I can do a ping, or see if the outgoing route is working remotely?
    How is the Kiwi registering if it cannot see the outside world?

  • Going back to my very first post in this thread: Try the "check port open" button on the admin page network tab. If after a while you get an error (e.g. "Error checking port status") then you know the Kiwi cannot communicate with due to the issue.

    How is the Kiwi registering if it cannot see the outside world?
    It's not registering. Isn't the whole point of this?
  • Has this Kiwi ever registered since it's been at its remote location? I.e. since August 18th when last saw it? Or was Aug 18th the last time it was at your local location hooked up to your local network?
  • 18th was the last time the unit was at my home QTH. The admin control panel shows that it IS registered! (see screenshot attached).

    I will try to check the routing in the router today.

    Thanks for your help.

  • The admin control panel shows that it IS registered!
    That seems to be a bug. I switched registration off, then on again. It sat there for many minutes (like it wasn't able to connect to then finally said the registration was successful. But there was this error message in the log:
    Thu Aug 20 17:26:29 10:14:12.510 0... _reg_kiwisdr_com: sp == NULL?
    So this particular error condition is not being reported properly on the admin page. The logs on show absolutely no incoming connections from this Kiwi's ip address (from the new remote location).
  • jksjks
    edited September 2020
    This is one of the craziest things I've ever seen. From I can do a: curl And it will connect and return the expected data.

    But if you initiate even the simplest connection from the Kiwi (TCP SYN) it will stop dead on the second hop. I don't see that 10.x.x.x local network in the reverse (incoming) direction if I do a traceroute from the outside. This is definitely some horrible network misconfiguration. Is this site on the end of a wireless link or something? Who is Is this their fault?

    Traceroute to a well-known DNS server from Kiwi:
    root@kiwisdr:~/Beagle_SDR_GPS# tr -n
    traceroute to (, 30 hops max, 60 byte packets
     1  0.289 ms  0.138 ms  0.091 ms
     2  38.615 ms  45.488 ms  45.495 ms
     3  * * *
     4  * * *
     5  * * *
     6  * * *
     7  * * *
     8  * * *
     9  * * *
    10  * * *
    11  * * *
    12  * * *
    13  * *^C

    Traceroute from to Kiwi:
    root@proxy:~# tr
    traceroute to (, 30 hops max, 60 byte packets
     1 (  0.619 ms (  0.590 ms (  0.828 ms
     2 (  0.400 ms (  0.384 ms (  0.446 ms
     3 (  1.727 ms  1.854 ms  1.882 ms
     4 (  3.432 ms (  1.881 ms  2.293 ms
     5 (  3.412 ms (  2.897 ms (  2.526 ms
     6 (  18.755 ms  18.873 ms (  3.363 ms
     7 (  29.012 ms (  19.029 ms  19.092 ms
     8 (  29.065 ms (  40.411 ms (  40.173 ms
     9 (  40.526 ms (  40.500 ms  40.500 ms
    10 (  60.203 ms (  52.424 ms (  59.545 ms
    11 (  58.563 ms (  59.454 ms  59.529 ms
    12 (  66.400 ms (  73.043 ms (  73.576 ms
    13 (  142.258 ms  142.419 ms (  73.710 ms
    14 (  148.775 ms (  142.375 ms (  150.014 ms
    15 (  150.000 ms (  148.640 ms  148.662 ms
    16 (  149.505 ms (  150.230 ms  149.426 ms
    17 (  149.848 ms (  150.121 ms  149.952 ms
    18 (  150.682 ms (  149.320 ms  154.713 ms
    19 (  150.321 ms (  150.036 ms (  150.093 ms
    20 (  150.729 ms  150.112 ms (  150.377 ms
    21  150.951 ms  150.349 ms  150.321 ms
  • Another case of missing default gateway?
  • Another case of missing default gateway?
    Doesn't seem to be?
    root@kiwisdr:~/Beagle_SDR_GPS# route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 eth0     U     1000   0        0 eth0 U     0      0        0 usb0   U     0      0        0 eth0
    root@kiwisdr:~/Beagle_SDR_GPS# ifconfig -a eth0
    eth0      Link encap:Ethernet  HWaddr 40:bd:32:e5:40:4b  
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::42bd:32ff:fee5:404b/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2434885 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2667825 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:170826774 (162.9 MiB)  TX bytes:1951438253 (1.8 GiB)
  • are the ultimate internet connection. But the connection is actually like this:
    Kiwi connected to a Mikrotik LT AP (, which has a cellular SIM. Because the cell company do not give a static IP, I have a VPN set up so the Mikrotik uses the cell connection to tunnel to the VPN server (at Airwire), which gives me a static public IP.
  • It seems as if there is a problem with an outgoing route in the Mikrotik. Its hard for me to check as I'm not local to it, I will ask the admin of the VPN (who is a friend) to check it from his end. He may be able to see where the route is missing. I will report later!
  • As I tried out on security tab set to enable restrictions on console on local to "no" and restart server should work.

    However I am not familar with the specific syntax yet. Where to learn? Thx.

  • Are you asking what the syntax is for Linux shell commands you enter in the admin console window?

    Well, that's not a topic we can teach you about here really. If you are new to an operating system like Linux, or a Linux distribution like Debian, then that's something you'll have to study yourself. It's a huge topic that has nothing to do with software radios directly.

    Maybe I misunderstood your question?

  • Thanks for insight, but basically I do not know, wether I am "landed" on "root" correctly. How does the prompt looks like correctly. I presume the procedure will be similar to some router configuration. And of course, some commands in order to get on to the system memory (ROMMON) cannot performed remotely. The "send break" command for instance. On temninal programs like TeraTerm or PuTTy you can perform "send break" only connected physically to the console port of the router on working place. This prevents from misuse. On KiWi's console one uses the LAN-Port connected to local as a console port. This is a great advantage and prevents from potentially misuse.

    For instance for some routers I have to change level from router#> to level lower by typing "enable". Only then I am on the programming level. If this is not necessary using KiWi, we do not have any concearn.

  • Okay, so I did misunderstand. Sorry.

    The admin console tab always gives you a privileged root shell. Not an unprivileged one that you might get from a login to the "debian" account.

Sign In or Register to comment.