New KiwiSDR is non-functional after upgrade from 1.2 to 1.383 [fixed, but root cause not understood]

edited April 2020 in Problems Now Fixed
I have a new KiwiSDR (V1.2) that when powered up I can connect at kiwisdr.local:8073/admin. I am also able to ssh to the device and login as root. When connecting to kiwisdr.local:8073 the web page indicates that the device is currently being upgraded since auto-upgrade is enabled by default. Once the upgrade is complete, I can no longer connect to either web page. I can however connect by ssh and log in. I am able to restore the V1,2 image from the SD card and the entire process repeats on reboot.

Is anyone else having a similar problem? The out-of-box experience for me with this new hardware is non-functional as an SDR. Any thoughts very much appreciated.



  • Hi Jeff,

    If you visit the "Kiwi Problems now fixed" section you may see some other users that have seen this but it is rare, (Unless there is only one Kiwi sold evey few months).
    Normally John (jks) the designer will respond and fix it.
    I personally think there should be a place to download a later image for people who can write the image to SD card.
    if it comes to it I'll wipe out the config, and image one of mine then send you a (off-forum) link.

  • edited March 2020
    Hi Jeff, you can test img from Dropbox? I downloaded it and see it's have more newer version than in KiwiSDR box - 1.46...
    And be patient first upgrade need lot of time ~45-60 min
    Hope it's helpful...
  • The power supply needs to provide 5v + at 2.1 amps or the KiwiSDR fails to start after an upgrade. So check that. Sometimes a power supply is adequate but the power cord has small wire and drops the voltage.
  • Wow, thanks for all the great suggestions. Stu, I really appreciate your offer to send an image. rz3dvp has provided a dropbox 1.46 link which I will give a try. With regard to the power supply it is capable of 5V at 5 amp and the wire gauge is sufficient. I have checked all the voltage test points on the board and they are all within 1% of the listed values. I tried building Beagle_SDR_GPS on the device myself. The result was identical to the automatic upgrade.

    make git (which does a git clean -fd; git checkout .; git pull -v)
    make install

    I will pull the dropbox version 1.46 kindly provided by rz3dvp and see if I can make some progress. I am a firmware developer by profession and I can figure this stuff out given enough time, but I am new to SDR and so there will be a steep learning curve on this project for me up front, so I appreciate all the suggestions and replies.

    Kind regards,

    Jeff - ko7m
  • kiwisdr and upgrade are usually PnP but that first one got problematic along the way
  • Hi guys it’s John from Kiwi SDR. I am sorry but I just had major surgery and it will be difficult for me to reply in detail for the next several days or perhaps a week. Before this happened I upgraded the distribution image discussed on the user guide webpage to version 1.383 instead of version 1.46. If you download the new were version you might have better luck getting things working . Kind regards, John
  • Hope you get better John....
  • Feel Better John.

  • All the best John, get well soon.

    Jeff, to be honest it was a timely reminder and good exercise for me, I installed original 1.2 to a BBG, let it upgrade to latest before backup to SD card and then copied that image on my Windows machine with Win32Disk Imager. 7-Ziped it down to about 440M. I do sometimes take backups but having a clean recent image with no personalisation did make sense, until I learnt the Dropbox image is now the latest.
  • Ok folks, I checked out hash a9076e394466847f5e08ad70c3f072c9fe694bbe from github and built it without problems and am up and functional, so something in the last couple of commits has broken things, at least for me. I will try and narrow down exactly what is going off the rails.

    Cheers, and many thanks.

    Jeff - ko7m
  • edited March 2020
    @jks get well soon, take care!

    About official img file on Dropbox, - could anyone download 1.383 version? I seen info about it's update and URL look like new but on my PC it's still download version 1.46 file KiwiSDR_v1.46_BBB_Debian_8.4.img.xz.
    Off course I check SHA256 - "ff1f4b97173ccfe82823e1a5e9cf3f44695209ed3d89b33f0f8d78dbc2a97acd" and it's 1.46 CRC, new IMG should have SHA256 "df55707fcb2da2c2cc52c80db2c6f7e2e8888e829de5d378d1ec668de926a580"...

    P.S. I try use wget, like in bash script, and it's downloaded file and named him KiwiSDR_v1.383_BBB_Debian_8.11.img.xz but unfortunately it's real 1.46:

    Correct SHA256 for IMG's:
    v1.383 - "df55707fcb2da2c2cc52c80db2c6f7e2e8888e829de5d378d1ec668de926a580"
    v1.46 - "ff1f4b97173ccfe82823e1a5e9cf3f44695209ed3d89b33f0f8d78dbc2a97acd"
    v1.2 - "59efbe9d880a328c2971d9db4ac305889bc1f2f09defe5ae73791ce805dd6337"
  • edited March 2020
    I did checkout hash e90f87d18c4275bd297763d89439c352b6de8acd from github and built it and found it to be functional as well, so it seems the last commit is the culprit for me. Thanks everyone for all the help.

    I did get bit by the root password policy between whatever OS version is in 1.2 and the version in 1.383 or 1.46. By restoring 1.2 and ssh-ing in as root immediately and stopping the kiwid.system service (systemctl stop kiwid.system) the update process aborted. Since the root user account is now configured to no longer able to be logged in, I created my own admin account (adduser username; usermod -aG sudo username) so that I can log in after the upgrade. I see that debian account exists, but the default password didn't work for me, so I created a new account. I then checkout whatever git hash I want, build it and install the new build. Reboot and Bob's yer uncle...

    73's de Jeff - ko7m
  • edited March 2020
    >>I see that debian account exists, but the default password didn't work for me...
    Before software update user debian had temppwd default password, after update, - serial number of your KiwiSDR board.
    73! Yuri
  • Thanks Yuri, that worked for me. I looked for that information online and I found a link that purported to be a forum entry where that information is found, but it only linked back to the same page, so I missed it. Thanks for providing clarification.

    73's de Jeff - ko7m
  • jksjks
    edited March 2020
    Okay, there seems to be a couple of issues going on here.

    1) I got screwed over by dropbox. :/ The v1.383 img.xz file has the correct filename, contents and SHA on my laptop dropbox directory. But even after a dropbox sync a fetch of that file from dropbox returns the contents of the previous v1.46 img.xz file (as pointed out by Yuri) for reasons I don't understand. I used the usual procedure to get a dropbox file URL to insert into various places (e.g. Kiwi website, script, etc.) But I didn't actually check it because it's never failed before. I think it's okay everywhere now with one exception: The file Beagle_SDR_GPS/tools/ in the distro on your Kiwi will have to wait for an update to a v1.384 release to be corrected.

    2) Jeff mentions he had to manually install a github commit (e90f87d) which is one commit (91cbe70) before the full v1.383 release. But that last commit has to do with the changes to the flasher script and I can't see how it would influence the normal running of the system in any way. But I also have one other complaint in email of an update to v1.383 failing (no details known yet). So more investigation is needed. [update: it was just filesystem corruption that prevented an update from v1.374 to v1.383, and after a manual rebuild it now works fine]. I always test the full release on a bunch of beta Kiwis of different configurations to try and reduce the chances of bricking the world.

    The password changes are bit subtle. You have to read the explanation topic on the forum carefully to decide if the password has been changed to the Kiwi admin password (if you have configured one) or the serial number of the Kiwi (written in black marker pen in the white box on the Kiwi PCB, also in the "network" tab of the admin page if you can get there).
  • v1.384 is out which applies the dropbox fix to the tools/ file.

    A few dozen sites have successfully updated to it and a freshly re-flashed v1.2 Kiwi here updated to it successfully in one go (it takes almost an hour due to the installation of all the new required packages and the first-time compilation of the cached DRM code which takes forever).
  • edited April 2020
    Thanks John, hope you are feeling better. Take it slow. Happy to work with you on understanding what might be happening on my device. Let me know how I can help. For now I have turned off automatic updates and have checked out hash e90f87d18c4275bd297763d89439c352b6de8acd which I build and install manually. This is working for me at this point. Right now I don't have any way to directly have you connect to the Kiwi, but I can certainly do a TeamViewer session or something similar if that would be helpful.

    I have not installed any image files other than the 1.2 version from the SD card that came with the device. All my updates have been by building the github repo.

    Glad you are feeling better.

    73's de Jeff - ko7m
  • With regard to password changes, I was looking at the quickstart guide at which include the following:

    Beagle root password:

    Did your Kiwi not have a Beagle/Linux root password set and now it's asking for one?
    Recent security changes have automatically applied a password to any root or debian account passwords that were blank/unset. To find out what the password was changed to please
    see this forum post.

    The "see this forum post." is just a link back to the quickstart at No worries, got it all sorted.

    73's de Jeff - ko7m
  • jksjks
    edited April 2020
    Re: links on pages to forum for more info about password changes. You're absolutely right -- these links are totally broken. Were they ever set correctly in the first place? I don't know. It almost looks like I had set a placeholder link and then forgot to go back and edit the content. I'm always pretty good about checking links in hand-edited html because they are so easy to get wrong. Anyway, should be good now.

    If you haven't already started making customizations to your Kiwi configuration and you want to try the regular install procedure then just do this: Re-flash to v1.2 using your sd card (with the Ethernet disconnected just for good measure). Then after the re-flash powers down remove the sd card, reconnect Ethernet and power up.

    You should be able to ssh in using the root account and a blank password since the v1.2 image will be running for the hour it will take for v1.384 to be installed. Upgrading from v1.2 doesn't have a nice log file you can follow to see the process. But you could do a successive "ps ax" (or your favorite variant) and get a rough idea of what's going on. There will be an initial period of apt-get activity as many Debian packages are installed, the largest being the Clang compiler suite. Eventually clang will get invoked on the Kiwi sources and that will take the balance of the time. Things will be very slow during the compilation of the DRM sources as they are written using true, extensive C++ constructs which cause the compiler no end of heartburn (me too as I was trying to wade through that stuff, lol). At the very end a bunch of time is spent coalescing all the data files (.js, .html, .jpeg et al) into the in-memory image file which is done via a pearl script that generates these huge inline C data files. After that the usual "make install" behavior that moves all the binary files into place.

    Then a reboot to (hopefully) v1.384 when the one-time password changes will be applied where the root password will be set to the Kiwi serial number since there was never a point in this whole sequence where a Kiwi admin password was set manually. Same for the "debian" user account password.

    I have done this procedure a number of times now and it's always worked. So I'd be keen to understand any case where it doesn't.

  • Very good John... I am game, and will have some time on my hands as I received a furlough notice from work today. Oh sigh... But more time to play radio. I will probably get to this in the next few days, but will be sure and report on results.


    Jeff - ko7m
  • Hello John,

    I have checked out master branch, make git; make clean; make; make install; reboot and all appears to be well in that world. I will attempt the v1.2 upgrade scenario soon and let you know what I find.


    73's de Jeff - ko7m
  • The upgrade from V1.2 works now as expected. Thanks all for all the help.
  • Okay, thanks for the confirmation and pointing out the website problems earlier. I guess we never really discovered the root cause of the failure to upgrade from v1.2 initially.

    But others have had similar problems. Sometimes it was because the filesystem or package system had become corrupt for whatever reason. Other times, like yours, it was not clear.
Sign In or Register to comment.