Possible DNS issue with one of two Kiwis on same network

Totally at loss here, maybe a no-ip DNS issue but I’m raising the issue here. I have two Kiwis set up to a fiber connection yesterday. I set up address/mac binding, virtual servers ok on a tp-link router. Everything in both kiwis are identical apart from name and port no. they are arcticsdr.ddns.net:8073, and kongsdr.ddns.net:8074. I had an old account with no-ip which was reactivated. For at least 48 hours everything worked well, then I got message that kongsdr was unaccessible. I checked at no-ip and found that the IP/Target was wrong: the correct public ip is the one associated with arcticsdr (see attachment) I corrected this, but after refresh the wrong IP (77-etc) returned. There is a short period (seconds maybe) when external connection is ok after actions like rebooting Beagle, and after I changed IP in no-ip, and after I deleted kongsdr from no-ip, and added it anew. No-ip tests show that ports are open, but “check port open” in Kiwi “Network” returns “NO” and “YES”. So, according to the Kiwi GUI: “If first responds "NO" and second "YES" then domain name of the first isn't resolving to the ip address of the second. Check DNS.”. Public IP has not changed since the Kiwis were put online.
The strange thing is that occasionally, often after reloading several times, external connection is made. Those who have actually logged in, are not affected by any action I make, except of course the Beagle reboot. The other Kiwi, arcticdsdr has no issues at all. So far!
Maybe I have to go back to proxy.



  • No-ip.com support is looking into it. However, it looks eerily similar to a problem I had with a 4G modem/router in September 2017. There as well, there seemed to be nothing wrong with DNS. After lots of work for finding the error, John set up the proxy server for me.
  • edited November 2019
    I wonder if off-setting the ddns.net refresh could help, E.G a setting for "odd or even" minutes? (or weird refresh times)
    Or even more out-there a "Total Kiwi", and "this kiwi number" so 1of4 sends at different times to 2of4 3of4 etc.

    Only other thing I can think of quickly is some network buffer that is caching your request. so you send the update, it fails due to timing or network load/conflict, the ISP server at "wrong address" resends?

    --oh and why do you need two DUC addresses anyway if they are at the same IP?"--
  • The connection is lost between refreshes. If I refresh or restart DUC, connection is back for seconds or minutes. So, it's what happens between refreshes. I could of course refresh every 15 seconds or so, but that seems rather extreme.
    I didn't quite grasp the intention behind the last sentence - take into consideration I am quite uncomfortable with networking, that kind of anyway ;-)
  • jksjks
    edited November 2019
    Okay, I've looked at this for a long time now and I think I see what's happening.

    I first disabled the Kiwi built-in DUC client on both Arctic and Kong and made sure there was no DUC process running on the Kiwis.
    Then I went to noip and manually set the target ip to 213.161 ... (via the "modify" button) for both Arctic and Kong and observed that the "last update" time shown on that page (the last time noip received an update request from any DUC client with the proper credentials) was 21:00 CET.
    So far, so good.
    But at 21:19 someone sent an update to noip for Kong with an ip of 77.222 ... The 21:00 update for Arctic remained from before.

    So the issue is who is doing this? A check of the Kiwis again showed no DUC clients running.

    Did you ever download from noip a DUC client to run on a Windows or Linux box that might still be running with the 77.222 address configured?
  • I'm going to try running two DUC-enabled Kiwis here (on different ports obviously) and see if it works okay.
  • Bjarne have you ever got rid of a router with that service enabled?
    Related have you considered changing the password for no-ip? If another user / piece of hardware tries to update that address it should fail if it has the wrong password...

    Ghost DUC, haunted Kiwi obviously....
  • Yes, ghost DUC might be a good description! Here is the last response from no-ip support:

    "Thank you for information. After noting that behavior and pulling further logs, it appears as if the hostname is receiving updates from two sources. It's either there are multiple DUCs on one network, or the network device has the hostname kongsdr.ddns.net configured within it.

    No-IP is receiving the dynamic updates for the hostname and resolving it appropriately to the supplied IP as shown by the attached logs. Sometimes our ticketing system has issues with attachments, so if what I've sent doesn't make it, I can send it separately.

    Take a look at your network configurations and let me know if you have any further questions or concerns."
  • edited November 2019
    John, I think the Target/IP is a remnant from when we tried to connect in 2016 or 2017! Please look at the attached log from no-ip, the first entry there is Nov 1 but I didn't connect the Kiwi until Nov 15! After we replaced no-ip with proxy (on the same name), I let my account at no-ip run until it expired due to non-payment. I reactivated the account on Nov 1. So apparently, kongsdr is still somehow calling or giving that old IP. Maybe a change of name would be all that needed to be done? It is the same physical device as well, but when I set up the kiwi I started from scratch with the SD card.

    Edit: I didn't notice John's question: The DUC I downloaded from no-ip only shows 213.etc. If I refresh the NUC, the Target/IP goes back to 213.. but then changes back to 77...

  • jksjks
    edited November 2019
    Edit: I didn't notice John's question: The DUC I downloaded from no-ip only shows 213.etc. If I refresh the NUC, the Target/IP goes back to 213.. but then changes back to 77...
    What does this sentence mean? What's a NUC? An Intel NUC SBC? So you did download a DUC client from noip and run it on a non-Kiwi computer? I think this must be the source of the problem then. Is it configured to update noip using "fixed" ip (namely 77...) instead of using the current public ip it's finding on the network? Please disable all non-Kiwi DUCs and let's see if this cures the problem.
  • edited November 2019
    OK, I have uninstalled the DUC (not NUC...!) I don't do any refreshes on no-ip.com. I had 2-3 instances of kongsdr running and was beginning to smile. However, it went back to being non-accessible. After I restarted the Kiwi DUC, it came back. I still think there is substance in my assumption that the 77... address is from when we tried it out in 2016/2017. As I stated before, the standalone DUC always returned the correct Target/IP 213... during manual or auto refresh. Which is probably why people could get in if they clicked the link at the right time window (a minute or so). But then, "something" changed it.
  • jksjks
    edited November 2019
    There is no occurrence of the string "77.222" anywhere in the /root directory tree of either Kiwi (except in the shell command history file on Kong which doesn't matter). Nothing in the crontabs etc. Updates to noip for 77 are not coming from the Kiwis..

    I would say create a new account on noip and remove your old one to try and shut-out the ghost DUC. You can't just change the account password because if the ghost DUC is persistently connected it may not get booted just because the password changed. Also, before you do this, leave the DUC on both Kiwis disabled and don't enter the new account info at first. Configure the public ip for Arctic and Kong using the web interface at noip and see if it stays good for a while. Then enable the DUC on one of the Kiwis and see if the ip stays good.
  • OK, so I set up a new account. Deleted kongsdr from the old one. DUC on kiwi disabled (NO to enable DUC on startup and restarted kiwi). Set up the hostname on the new account. And what Target/IP meets me there?! I have never (lately at least) suggested that 77 is in any Kiwi, I think it's somewhere in the no-ip system. As I mentioned before, 77 showed up in no-ip two weeks before I set up my Kiwi with DNS. At any rate, I changed the Target/IP before connecting the kiwi and am now testing kongsdr from a new account. I should have encountered the error by now, but things are running fine. If this doesn't help, I need to use another name (which is a shame because I like it!). A preliminary thank you - I feel that I'm maybe not out of the woods yet.
  • I am reviewing the noip DUC code again to refresh my memory about how it works.
  • jksjks
    edited November 2019
    I found Kong had been stopped, but made some tests anyway. I ran the DUC manually in debug mode and watched it exchange info with noip. Everything looked okay. After a while I brought Kong back up and enabled the DUC as usual. An hour later it seems fine. So I'm not sure what to think at this point.
  • Thanks John. I'm afraid there's something that might eventually make the error return. If that is the case, I am not sure that I want to go on with no-ip. The proxy was at least extremely stable.
  • John (or others), a shot in the dark: Could it be that two Kiwis on the same no-ip account simply do not work? Anyone tested this? After I moved kongsdr to a new account it has been running fine (fingers still crossed).
  • Assuming the old account is still valid you could check if it is being updated. As John found something updated that account I personally doubt it is anything to do with the KiwiSDR(s), more likely a device with DUC capability enabled that has been forgotten.
  • The old account is still active with the arcticsdr kiwi, running with no issues since NOV-15 when it was first set up. But the kongsdr kiwi just couldn't cut it. I have had nothing else on the account, unless somehow the old 4G modem/router (a TP-Link MR6400) put some traces there. Anyway, if it continues to work, I'm happy.
  • That was then. After a while no-ip stopped working, the problem was not solveable and I had to go to proxy like I mentioned earlier in the thread.
  • jksjks
    edited November 2019
    Could it be that two Kiwis on the same no-ip account simply do not work?
    No, it works fine. I'm running it now with two Kiwis on ports 8073 & 8074.
  • Ah, yes you mentioned. I forgot.
Sign In or Register to comment.