Second build has shipped. Message will appear here when store is ready for third build ordering.

I can't get the firmware to update from 1.230 to 1.345 [fixed, had filesystem corruption]

edited November 2019 in Problems Now Fixed
I've had the KiwiSDR running for a couple of years now. Last Sept I noticed the firmware updates were lagging behind so I tried with forcing the update routine or new build routine to function. And eventually this was successful and ver 1.23 could be seen as installed.

Since then I've had trouble with the WSPR window hanging and the left hand audio traffic indicator drops to zero a minute or five after I've restarted an instance.
The hang causes the program instance to freeze and the only way to regain control is to present the address again and press enter. Annoying!

A new more thorough investigation today showed that firmware ver 1.345 was available but I couldn't get a download to work or a rebuild to make any difference.

I have had auto update selected for the last two years, and it worked up to Sept last year. Since then no updates.
73

Comments

  • Hi Peter,

    We had an update a while back that broke the update process and required manual intervention to get going again.

    Can your Kiwi be accessed from the Internet? (doesn't necessarily mean it's a public Kiwi, just that port 8073 is open to the Internet). If so, please email the ip address or URL to support@kiwisdr.com and I'll fix it.

    Regards,
    John
    Peter
  • Okay, I fixed it and a couple of other public Kiwis that were stuck running v1.2xx versions. In all cases they had filesystem corruption of the source files that prevented any further updates. Setting those files aside and doing a fresh git clone was all it took to get running again. There are a variety of causes of filesystem problems including improper shutdown, power failure, etc.

    These v1.2xx versions were before v1.287 where there was a software problem causing further updates to fail. So it is unrelated to that issue.
    G0LUJPeter
  • Bueno! It runs fine now and I have a whole bunch of new controls and labels to learn about.
    The WSPR decoder runs ok, or doesn't freeze now but for some strange reason isn't finding many signals tonight. I'll watch this over a few days to see how it goes.
  • I'm reminded that we had some fairly close lightning strikes and power failures last autumn while I was away. Maybe there is a connection?
Sign In or Register to comment.