Firefox 66.0.3: Kiwi audio/WF stops when other tab opened (workaround in v1.283)

edited April 2019 in Problems Now Fixed
It's been observed that in more recent versions of Firefox the Kiwi audio and waterfall will stop when an action is taken that opens another tab/window. For example, use the right-click menu and select one of the services like "LW/MW database lookup". This didn't used to happen and does not currently happen with other browsers.

A workaround is to open the Javascript console window (Mac: cmd-alt-K, Windows/Linux: ctrl-shift-K). The audio/WF will resume and will continue to run after the console window is closed.

I'm pretty sure this is a Firefox bug rather than some API change because there are other cases where the Javascript stops when it seems it shouldn't.


  • jksjks
    edited April 2019
    So this seems to be a problem with Firefox audio getting stuck under certain conditions (other windows/tabs being opened). This in turn causes the waterfall to stop since the waterfall update is locked to the audio stream so the two update simultaneously. So this is not a problem in general with Javascript stopping.

    Firefox audio problems are not new. There is watchdog code in the current audio javascript that catches a specific case of Firefox audio going "silent" for unknown reasons. This issue was first discovered by Pieter-Tjerk de Boer, PA3FWM, creator of the original WebSDR ( project. He filed a bug report with Firefox but I forget what the resolution was.

    I'm hoping a modification of the watchdog code can catch this new problem and get the audio going again. I find that it happens on Mac and Windows with Firefox/Quantum 66.0.3 and .2 and the 67.0b13 developer edition, but not with Firefox ESR 60.6.1esr So that's even more of an indication that this is truly a Firefox issue.

    I just checked and found this problem also occurs with when you click on a link that brings up a new window/tab.
  • Okay, v1.283 has an automatic detect and workaround for this problem. Hopefully it will not have unintended consequences, but due to the nature of the audio code that is always a possibility.
  • Not 100% sure if it worked before but under RDP (set to "play on this computer") it shows the FF watchdog indicator a couple of times but does not run.
    I only spotted it as clicked to run the local Kiwi under the wrong desktop and spotted the flag, I'd normally just close it on silence and open locally.
    If the RDP connection is set to "Play on remote computer" it starts OK.

    This may not be worth looking at as running it under RDP, with remote audio, is a bad idea but thought I'd flag the change.
  • Whatever this "FF watchdog" thing is, it shows up here even when I don't do anything to the browser - appears to have caused all my Kiwi-based FT8 monitoring to have fallen over twice today.

    73, VR2BG.
  • How to downgrade the Kiwi's software? I want to go back to a version without the FF "fix". Can't seem to find anything about how to do it.

    73, VR2BG.
  • Easiest thing to do (in the short term at least) is to not use Firefox.
  • In v1.284 there is a new admin option to disable the Firefox workaround. See the v1.284 thread.
Sign In or Register to comment.