Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (,

Please visit (documentation) and (online store)

Who runs Linux for their main OS/Browser [how to run Dream on Linux]

edited November 2017 in Problems and Issues
I am daunted by jack, jackd, and qjackctl

Anyone else run this stuff?


  • I run Linux almost exclusively. I don't use Jack if I can help it. I use Alsa and Pulse Audio.
    I'd be happy to work with you to get that working. We can get Jack working too, but it will take more effort, so why bother?
  • I haven't found anyone yet that likes or feels comfortable with jack.

    I run Mint 18 (ubuntu/debian in effect) and have failed to get things like DRM etc working with Chromium connections to my local kiwi.

    The latest DRM stuff reignited my interest

    Thanks for your offer to help.
  • I did not mean to discourage your use of Jack. Jack offers real time audio connections and Pulseaudio introduces latency through the connection chain. Pulseaudio is built into a lot of desktop applications and they will not run without it. So if you need real time audio connections, such as mixing sound sources for a recording, then Jack is the Linux answer, but if you are connecting sound from one app to another such as from Chromium or Chrome to DRM software, then Pulseaudio is the way to go. You can use Pulseaudio with Jack if you need to have both capabilities on your Linux desktop. This link is much more eloquent than I am.

    Pavucontrol is the Pulseaudio mixer application. This youtube video is actually informative: 
    The producer doesn't mention that the "recording device" would be your DRM software, but it would be. ALSA is the kernel level audio device and in the video he does show how to access the setup for ALSA. 

    Jack is a set it and leave it connection tool. If you connect it to DRM software and then end the program, Jack will forget all about it and you will need to reconfigure next time you start the DRM software. So best used where the settings are static.
    Hope this makes sense and helps you to get started.
    Ron KA7U
  • The attached screenshot shows Chrome running KiwiSDR on a FAX line and Multipsk printing the FAX and Pavucontrol set in the "Recording" tab with the device select pull down window open to show that a "monitor of built in audio analog stereo" is being sent to MultiPSK.  DRM software would be shown in the same way and it would be configured the same way. You could have Multipsk and DREAM software running at the same time and both could be a monitor of the audio. Each one would have a set of controls on the "Recording" tab.
    Ron - KA7U

  • got fldigi and pavucontrol running, not just need to configure those

  • I have found that letting pavucontrol, audacity, fldigi, chrome run overnight causes chrome to lock up, even though audacity was not recording
  • Are you using Google Chrome or Chromium? I think Google Chrome is less likely to hang up with memory management problems. You can get it here:  The directions are a bit cryptic, so if you want it and need some direction for the install, I'll help.

    Or you might find that Firefox is more dependable and uses less memory. 

    I'm curious why you are learning Linux? I personally enjoy it and have for many years, but it can be frustrating.
    Ron - KA7U
  • When you get ready to run DREAM to decode the DRM software, you will want to send the KiwiSDR audio to DREAM, but not have to listen to it in your speakers. This link should open a thread on this subject that might help you to configure your system to enjoy DRM.!topic/gqrx/r3ImfrWedm0
    Ron KA7U
  • In the examples given above a sound sink is created and then a monitor of that sink is used to feed audio to DREAM. The linked examples aren't using commands that Pulse Audio will accept in my version of Pulse Audio. The following commands will however.
    You can add a "sink" with the following.
    pacmd load-module module-null-sink sink_name=MySink pacmd update-sink-proplist MySink device.description=MySink

    You can add a loopback device with the command

    pacmd load-module module-loopback sink=MySink

    "pacmd help" will tell you more about this Pulseaudio configuration utility. I'm going to need to learn it also, if I decide
    to decode with DREAM.
    Ron - KA7U
  • I have used Unix then Linux for 25 years just never dealt with the sound stuff.

  • Not much DRM to be heard here so far, so with the loopback working, I have explored Fldigi and SpectrumLab successfully.  MultiPSK is a bit cluttered!
  • I have W7 running in Virtual Box and Sodira on that. Decoding that way works.
  • W7 running in Virtual Box took some effort to setup. Sodira is running under the WINE API on my openSUSE desktop. I can feed audio to MySink from Chrome and get recording input to Sodira from Null Output, but I have not yet setup correctly to drive the speakers from sodira output. Have not looked for a DRM station to test on either.

    I had not heard of Sodira until you mentioned it!
  • I do have the loopback and the sink working properly, it was a need to select a decoder in Sodira. So now to find a DRM station to decode. Hi Hi

    Sodira runs great with Linux and the WINE API. I should probably write it up in my blog on so others can setup to use it with DRM. But first to actually decode a DRM station. I wonder which KiwiSDR and what time of day to look for that elusive DRM station. 
  • jksjks
    edited November 2017
    Try 3965 (RFI, Issoudun, France, 24/7) from a Kiwi in Switzerland or Germany during evening / night hours there:
    Also from Europe try beginning at these times: 04Z 9800 RRI, 06Z 3955 BBC, 06Z 6040 RRI, 08Z 17790 BBC
    See Not all the signals listed there seem to be transmitting.

    One problem I've noticed with HF DRM is that the way HF broadcasters have it configured (not enough redundancy) you really need a signal/noise ratio of > 18 dB to keep audio dropouts from happening. That means it's almost useless in any sort of significant fading condition (i.e. long distances, multi-hop etc.) Some interesting perspective here:

  • HI,

    I ran Dream and Sodira in parallel using VAC and tried a few DRM stations.

    Sodira only locked and produced audio for about 10% of the time Dream worked OK. In turn Dream would typically only stay locked for periods of up to 2 minutes or so and then drop out for a minute or two.

    So I wouldn't class any of these as being particularly usable as a replacement for traditional AM broadcast transmissions.

    I also tried Sodira for AM stereo but couldn't find good enough signals for it to lock properly either.

    I have fiddled around with all sorts of settings on the KiWi, VAC & Dream / Sodiara and nothing really seems to make that much difference to the reliability of the decodes. It's very much down to propagation and particularly (it would seem) the extent of phase distortion and selective fading on the signal path.

    I must say that so far I'm not overly impressed :-(


    Martin - G8JNJ

  • Hey Martin,
    I did try to decode DRM @ 3965KHz using your station this morning. Sodira would almost lock but not quite. So I was not successful with it on DRM. It does seem to work nicely on AM, but I have not tried it with the Stereo AM. The version of Dream in the openSUSE repositories does not support Pulseaudio, just Alsa, and I need to manage to install QT correctly in order to compile Dream to add Pulseaudio. I used the QT website script to install and compile QT but that didn't bring in all the dependencies I need and as it was written for Ubuntu I tried to add them by hand one at a time from the openSUSE repositories. After finally finding all of that stuff the "make" choked up on finding some of the headers and dependencies, so now to figure out how to include the path to the libraries into the Makefile or system path statement. Then again, a search for the first one to choke did not turn it up on the drive, so it may not even be available after all of the setup effort.

    To much effort for what it is worth! LOL
  • a Dream unfulfilled

  • edited November 2017
    There's already a discussion about AM stereo C-QUAM and SoDiRa -

    Please try to connect here and to use SoDiRa with VAC

    The result some days before was this:
  • Emmanuel,
    Thank you for the link to the video and the KiwiSDR. This particular thread is a Linux OS specific thread, although I think VAC will run in WA2ZKD's W7 OS running in a Virtual Box... 

    I do have SoDiRa playing AM from the IQ input, so it does work. The DRM decoder is not locking for me on the signals I have tried but no joy, and it seems others have some issues with that as well. DRM codecs are not all open source, so that might be a problem at some point. I've read that Debian/Ubuntu users have successfully compiled DReaM with Pulseaudio support and are decoding DRM received from other SDRs. I use openSUSE on my desktop currently and if Debian can do it, so can openSUSE, but it is difficult when the dependent libraries are not available in the repositories. If I decide to actually pursue DRM I'll probably setup a Debian system on a good computer and compile DReaM on that machine. But I'll remember that not all DRM stations are broadcasting with open source codecs and therefore DReaM will not have the needed codec to lock onto those DRM broadcasts.

    For what it is worth.
  • Further effort with DRM decoding. I compiled DReaM on a ACER Aspire One running Ubuntu 14.04 LTS this evening. I used the script file found here:
    The first run failed to compile looking for a fftw3.h so I manually installed it:
    sudo apt-get install fftw3-dev
    and then the script ran to perfection and DReaM was installed on the little ACER. Sadly it doesn't have the computing power to run it. But the thing will compile and a better computer will run it.

    Back to openSUSE (installed on a better computer), added the hamradio repository, duh...
    and installed DReaM the easy way.  Both Sodira an Dream are working as they should but neither will lock onto the DRM signals I've found so far on various German and British KiwiSDR units. Both softwares work fine with AM and SSB. 
    Sodira is running with the WINE API installed on openSUSE 42.3 and Dream is running natively on openSUSE 42.3. Pulse audio is connecting the audio from Chrome to the aforementioned receivers set to take IQ input from the sound card.

    To enable Pulseaudio to do the audio connections, this command is added from the terminal:
    ron@linux-4cdz:~/> pactl load-module module-null-sink sink_name=MySink \ sink_properties=device.description="MySink"



    Now a virtual audio cable exists called "MySink". Set the KiwiSDR to the IQ mode, start DReaM or SoDiRa, or both, start Pavucontrol, open the Recording tab and choose "Monitor of MySink", open the Playback tab and choose "MySink" for the web browser and choose "Built in Analog Stereo" (or whatever your sound card is called) for the IQ receiver. 
    Set the IQ receiver to AM or SSB or whatever mode is working, hear the audio output. 

    See the attached screen shots.  I hope this information is helpful...

  • This morning I managed to lock to a DRM station here:

    The lock did not hold long and the audio was not properly demodulated. I think the loss through the Internet feed is the biggest problem or perhaps the decimation of the IQ signal being received?

    The Dream DRM receiver did not lock, but did manage to light up the first 2 bars several times and once the 1st bar turned green. Given a proper steady IQ stream for the received DRM station, I think both of these softwares would work to decode DRM, but for a web receiver, this might be nearly impossible to achieve?

  • The same Kiwi (, but with SODIRA 0.099, getting much better results than the newer version 0100
    Please notice the working for me setup.
    O.K. this is Windows OS, not Linux, but I've noticed that the previous version of SODIRA is maybe more stable.

  • sv1btl,
    I do not yet have a source for Sodira 0.99. I'll try it if I can find it.

    I suspect the Internet feed is possibly defeating the decode of DRM. I notice many restarts of the DRM receiver that I think are caused by lost packets in the feed. I probably need a more dependable Internet service, but being out in the country and being served by a Motorola Canopy system, I consider myself fortunate to have Internet. Hi Hi

    The other modes work well and the audio seems better, that is higher fidelity, than the audio from the KiwiSDR alone, so the merit of the IQ feed from the KiwiSDR is noticeable.

    Thank you for your interest.
    Ron - KA7U
  • I made a video of running Dream on Linux Mint 18. I suspect most of the DRM audio dropouts were caused by CPU usage bursts and/or hard disk I/O activity when I did the screen recording.

  • UR5VIB,
    You were the encouragement I needed! You installed on Linux Mint and that got me thinking about libfaad. It also got me thinking about my audio setup for the IQ stream input. So back to the openSUSE repo and installed libfaad for the AAC Mono codec. No Dream plays like a dream. I'm listening to it, uninterrupted while typing this message. Oops it dropped out. The cursed audio under run strikes again. But it started right back up and is playing away now. Of course I have no idea of French, so it is just pleasant to listen to. Hi Hi
    Ron - KA7U

  • In case this may help to explain the cause of occasional dropped-out in Dream: when dream dropped-out is internet related (packet loss, network congestion etc.), watch out for the momentous blackout in its waterfall spectrum plot. Otherwise this is propagation related.
  • jksjks
    edited November 2017
    Under "Chart Selector" the "History > SNR / Audio" chart is a good way to see the SNR trend as propagation changes. It also charts audio drops over time.
    I find that +15 to +18 dB SNR minimum is needed for uninterrupted audio when the broadcaster is using 64 QAM.

  • Hi
    I been reading this thread with interest.
    My laptop runs on Ubuntu 18.04.
    I have been trying to install Sodira, but am unable to find a version for linux, can someone please help by pointing me in the right direction to download Sodira for Linux/Ubuntu.
Sign In or Register to comment.