time decoder issue? [should be fixed by v1.679]

I have not used my kiwi for some months (had surgery) but it has been on for that time (decoding WSPR) so I assume udates have been taking place.

I have a special interest in listening to VLF utility stations, such as time stations. I noticed that the list of time stations in the Timecode extention has been expanded. When I tried to use it, it did not work. Previously after some time syncing the extention would show the signal in a screen, show the decoded databits and after the final bit show the decoded time information.

Now I do hear the signal, see it on the waterfall and can confirm that the KIWI is tuned to the right frequency. I tried to decode MSF (60kHz), DCF77 (77.5kHz) and TDF (162kHz). I made sure to select the correct entry for MSF (same frequency as WWV). For all three decoding did not work. No signal was shown, the decoder kept saying "Looking for sync" and no databits were shown.

Does anybody have the same issue?

regards (73)



  • Some more info. I noted that the time decoder extention uses the wrong frequency for the Russian time station RBU. In the name it says 66.67kHz (actually it is 200/3=66.66666...) but the extention sets the frequency to 66.57 (so 0.1kHz low). You can see this frequency in the control window on the right.

    But even after manually correcting the frequency: no decode.



  • jksjks
    edited April 2021

    The frequency presets for RBU/RTZ are correct because the 100 Hz sideband modulation is what's being decoded. The decoder is not so great however. So you really need to have a good strong signal present. It decoded fine for me from a Kiwi in Moscow.

    DCF77 was off-air when I checked just now.

    TDF decoded fine when I tried it from a Kiwi in your general area.

    MSF seems to have a problem. On the top waveform display the red and black traces need to be opposite phase, i.e. when red is low black is high. Otherwise the data shown below is all ones because the wrong part of the waveform is being sampled. Pushing the re-sync button is supposed to fix this but it doesn't seem to work. You have to switch to another station (on a different frequency) and switch back and hope the phase is correct. When the phase is correct it decoded fine for me. I will look at this when I have time.

  • jksjks
    edited April 2021

    Until things get fixed it looks like the current status is:

    phase, sync, if_wrong, station

    in, min, never_sync, DCF77-ampl

    out, min, all_ones, MSF

    -, min, -, TDF

    in, min, all_ones, WWVB-ampl

    in, :13, -, WWVB-phase

    in, min, all_ones, JJY

    -, min, never_sync, RBU/RTZ

    out, /20s, never_sync, BPC-ampl (re-sync will change phase)

  • ...regarding the DCF77 I ask:

    I think I have a good reception signal but the synchronization doesn't happen, is it my problem or the decoder's?

  • jksjks
    edited April 11

    Some of the timecode decoders have problems that need to be fixed. Been on my bug list for quite a while.

    The DCF77 decoder will never sync if the initial phase is wrong. Keep pressing the re-sync button until the red and black traces both move in the same direction (instead of opposite to each other as your image shows). Then it should sync at the top of the next minute.

    MSF has a related problem where it will always decode as "ones" if the phase is wrong (it needs to be out-of-phase -- the opposite of what DCF77 needs).

Sign In or Register to comment.